SteamVR Developer Hardware

SteamVR Developer Hardware

View Stats:
jashan Apr 19, 2016 @ 3:36am
[SOLVED] Unity 5.4 beta 15: OpenVR failed initialization with error code VRInitError_IPC_ConnectFailed: "Connect to VR Server Failed (301)"
SOLVED: The issue was actually SteamVR having gotten stuck in some "Exiting" state. So the way to fix this issue (with its misleading error message) is actually simply shutting down and restarting SteamVR.


So, once again I'm trying to use Unity 5.4 ... beta 15 this time ... after making it compile:

Unity5.4 b14 InitializeVRPlayerSettingsForBuildTarget removed (http://steamcommunity.com/app/358720/discussions/0/365163686081219733/)

"camera.targetEye is not camera.stereoTargetEye" fixed (http://steamcommunity.com/app/358720/discussions/0/405693392925227850/#c385429125014820125)

... and also manually adding "OpenVR" to the list of Virtual Reality SDKs in the player settings (and of course, activating "Virtual Reality Supported" there) ... when I hit play, first I have to wait about a minute or so ... and then, eventually, I get:

VR: OpenVR Error! OpenVR failed initialization with error code VRInitError_IPC_ConnectFailed: "Connect to VR Server Failed (301)"!

and right after that (probably caused by the above error):

OpenVR initialization failed. Ensure 'Virtual Reality Supported' is checked in Player Settings, and OpenVR is added to the list of Virtual Reality SDKs. UnityEngine.Debug:Log(Object) SteamVR:CreateInstance() (at Assets/SteamVR/Scripts/SteamVR.cs:75) SteamVR:get_instance() (at Assets/SteamVR/Scripts/SteamVR.cs:44) SteamVR_Render:Update() (at Assets/SteamVR/Scripts/SteamVR_Render.cs:399)

So the cause of this seems to be that:

SteamVR.usingNativeSupport returns false because ...

UnityEngine.VR.VRDevice.GetNativePtr() == System.IntPtr.Zero

Besides, I'm getting "Failed to find Sprites-Default.mat" and "The resource Sprites-Default.mat could not be loaded from the resource file!" which has also been reported there: http://steamcommunity.com/app/358720/discussions/0/361787186433113581/

Last edited by jashan; Sep 12, 2016 @ 1:55am
< >
Showing 1-3 of 3 comments
Philipp Apr 22, 2016 @ 9:19am 
(Thank you for this overview, while I can't answer your question at the end, it was helpful.)
jashan Apr 22, 2016 @ 11:55am 
Well, as said in the first paragraph of the posting, I had solved it already - so I hope it will be helpful for other people that run into the same situation ... I probably should edit the subject, though. Let's see if I can (it's not really something that has anything to do with Unity 5.4 beta after all).
zook Sep 10, 2016 @ 12:20pm 
Thanks, was very useful
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Apr 19, 2016 @ 3:36am
Posts: 3