The Curious Expedition

The Curious Expedition

View Stats:
OlaRune Oct 23, 2016 @ 12:04pm
Game stuck on loading screen on Linux, electron seems to crash
Hello!

I just bought this game and I can't get it to start. When I start it a black window opens, which has an empty loading bar on top. Then nothing happens no matter how long I wait.

There is no unusual log output in the terminal from where I launch Steam. I have also tried starting the game without Steam running, by running ~/.local/share/Steam/steamapps/common/The Curious Expedition/electron but still the same error, and no log output in that terminal either.

However, when looking at the system logs I found the following core dump: http://pastebin.com/LV3DG9wP

I'm running 64 bit Arch Linux:
$ uname -a
Linux Scully 4.8.4-1-ARCH #1 SMP PREEMPT Sat Oct 22 18:26:57 CEST 2016 x86_64 GNU/Linux

Someone else seems to have had this problem before: https://www.gog.com/forum/curious_expedition_the/game_crashes_on_startup_on_linux

Does anyone have an idea on what's wrong? If there is something I can try or some more info you need in order to help localize the problem, just tell me.
Last edited by OlaRune; Oct 23, 2016 @ 12:17pm
< >
Showing 1-15 of 17 comments
OlaRune Oct 23, 2016 @ 1:07pm 
I have solved the problem by downgrading freetype2 to version 2.6.2-1.
ByteRiot  [developer] Oct 26, 2016 @ 2:33pm 
Thanks for the follow-up!
glub ♥Linux May 2, 2017 @ 5:56pm 
Thanks, I have the same issue. I figured it had something to do with fonts.
Don't want to bother downgrading anything so I'll just errr.... try playing another game. >_>
meh May 5, 2017 @ 3:01pm 
Same here...

Is the workaround even still working / don't you have to recompile lots of stuff if you downgrade freetype? Or were you using LD_PRELOAD?

*sigh* the old freetype doesn't even compile any more on my system. Maybe the game runs in WINE...? xD
ByteRiot  [developer] May 6, 2017 @ 6:42am 
Meh: Please send me a email to info@curious-expedition.com with your platform/distro info.
meh May 6, 2017 @ 5:14pm 
OP pretty much summed "platform" up already - same for me.

Any system with a recent, vanilla version of freetype (>= 2.6.4 or something) should have the segfault-problem. So archlinux and (guessing:) probably gentoo, fedora, slackware... or you might be able to find + use some freetype 2.7 PPA for Ubuntu if you really want to break it.

With some luck you can just recompile against a recent version of freetype at some point to update / fix it. If I remember correctly, it was the freetype version that introduced some new & improved subpixel rendering that lead some older binaries to break - I had to recompile a whole bunch of applications back then, no patching necessary. I barely remember the details (I think harfbuzz was involved too)

Problem is: updating *might* break the game for everyone still using the old versions of freetype, which at the moment appears to include Ubuntu and probably SteamOS?

On the bright side, that also means this is unlinkely to turn into a serious issue before October / Aardvark at the earliest (Aardvark might not even upgrade freetype?)... so you have a lot of time to put an updated version into one of those steam beta slot thingies.
Enverex May 7, 2017 @ 9:34am 
There's also other posts created about this - https://steamcommunity.com/app/358130/discussions/1/1319961618833715225/

The fact it doesn't even error is a bit infuriating.
meh May 7, 2017 @ 12:35pm 
Oh, thanks, I was too lazy to search for a precompiled old freetype but there's one in that thread :D

Works fine with LD_PRELOAD, so no need to downgrade... just put an old freetype somewhere:
( I put it in /tmp so I don't forget to delete it, you might want to choose somewhere more permanent )

$ cd /tmp
$ wget https://archive.archlinux.org/packages/f/freetype2/freetype2-2.6.2-1-x86_64.pkg.tar.xz
$ tar -xf freetype2-2.6.2-1-x86_64.pkg.tar.xz

then set LD_PRELOAD in that steam "custom start option" thing (edit: "Properties/Launch Options) for the game like that:

LD_PRELOAD="/tmp/usr/lib/libfreetype.so.6" %command%


Starts fine.

Guess that also means, bundling the old version with the game should work too (or - if the liceses are incompatible - adding a download script to the game) which could be a really easy temporary workaround.
Last edited by meh; May 7, 2017 @ 12:37pm
ByteRiot  [developer] May 7, 2017 @ 2:26pm 
Thank you for the detailed work around info! I'll look into the issue from my side.
glub ♥Linux May 7, 2017 @ 4:12pm 
Thanks for the info meh! :)

Why not copy that library into the game's directory and point to there instead of /tmp?

Edit: nevermind, redirect this question to the devs instead. Just ship the precompiled blob with the game?

I can confirm this workaround works by the way. Although having spaces in filepath for LD_PRELOAD is a bit problematic it seems (tried with single quotes too, didn't work, had to have a path without spaces in it).
Last edited by glub ♥Linux; May 7, 2017 @ 4:36pm
b0wter May 19, 2017 @ 1:08pm 
Sadly this doesnt seem to work for me any longer since the last update :/
Anyone experiencing the same issues?
glub ♥Linux May 20, 2017 @ 12:23am 
Version 1.2.5.0 working for me still.
meh May 20, 2017 @ 1:48am 
Did you put the library into the game's directory and steam deleted it when it updated the game? :3
Last edited by meh; May 20, 2017 @ 1:48am
b0wter May 25, 2017 @ 12:26pm 
My bad, didnt notice that I downloaded a wrong version after my temp folder was cleared :D
qptain Nemo May 31, 2017 @ 2:03am 
Also experiencing this issue.

Running the system-installed electron and then dragging the file resources/app.asar into its window manually also works as a workaround though.
< >
Showing 1-15 of 17 comments
Per page: 15 30 50