Oriental Empires

Oriental Empires

View Stats:
 This topic has been pinned, so it's probably important
Neutron  [developer] Oct 4, 2016 @ 11:39pm
Framerate Stutter ?. Try turning off grass.
The new update has an option in the video settings to turn off grass. If you have a bad framerate stutter, please try turning off the grass, and report here on whether or not it solved the problem.

I appreciate that just turning off the grass is not great for the look of the game, but if we can identify grass as a major cause of the stuttering, then I can work on improving it.
< >
Showing 1-15 of 24 comments
Qoojo Oct 6, 2016 @ 5:55pm 
So I have some stuttering when moving the map around that completely disappears when turning off the grass.

2560x1080
i7 - 5820k
AMD Fury
32gb
Neutron  [developer] Oct 7, 2016 @ 12:53am 
Thanks, useful to know
Tortuosit Oct 10, 2016 @ 4:59am 
Here still stuttering at solid ~60 FPS. But much better.
I think grass makes it worse. Without grass, still heavy stuttering, but less frequently. Probably depends on scroll speed... With grass it's like every 0.5 second a harsh stutter, without ... less... like every 2 seconds. There is some bottleneck at work :-)

1920x1200
i7 - 2600k
NVidia GTX-970
8GB/2133
Last edited by Tortuosit; Oct 10, 2016 @ 5:09am
Headset Feb 3, 2017 @ 3:15am 
I have some stuttering when moving the map around that completely disappears when turning off the grass. With Gras turned on = stuttering at any Graphic Preset. Gras off = smooth
Win 10 64 bit
I7 6700
Nvidia GTX 1080
32 GB Ram
stoic Nov 9, 2017 @ 2:25pm 
it works for me ..but l realize it stutters mosly in sieges in close looks..beside my sh..t system and my sh..t nvidia gt 540 m other reason :)
Eztrelle Nov 24, 2017 @ 2:55am 
Bad Stutter at 1080p @ 144Hz across all graphic option levels in game. Turn grass off and stuttering completely goes away.

i76700K @ 4.4Ghz
980ti 6Gb
16 GB DDR 4
Draeconis Dec 9, 2017 @ 3:27am 
Bad stuttering at 2560x1440 @ 60Hz, turned off grass and this improved, but didn't go away. Disabling Game Mode under Windows 10 seemed to improve this a little.

Some graphical glitches with certain units appearing as while blocks. Bit disappointing that the draw distance for units/buildings/terrain can't be tuned, or isn't smoother, as this is a bit jarring.

Xeon W3670, 16Gb DDR3, GTX 1080.
Last edited by Draeconis; Dec 9, 2017 @ 5:12am
Masacre Dec 13, 2017 @ 3:23am 
I just have to say, I am glad I saw this post in the last minute. I had actually filed for a refund for this game since it was stuttering so badly for no apparent reason. I really wanted to give it a chance though since from what I read it is right up my alley and when I saw this post I tried it and most of the stutters disappeared. And I am glad they did, because I am enjoying the game immensely and have cancelled the refund.

A tip though, to the esteemed developers: I am pretty sure there are plenty like me who will however not give the game a second chance which is a loss both for them and for you. You might want to take an extra look at those grass textures/models and give em a round with the optimization stick. It seems to be worse when you are actually at a height where you can not visually see the strands of grass so it might be prudent to not render them at that altitude. But I am not a software developer so I don't know if that is possible to implement.

In any case, I hope you continue improving upon the game and that it gets more success, coming from a 4x veteran it really deserves it.
I too am glad I read thru this thread as stutter absolutely drive me batty.

Has the problem been resolved?
Werewolf13 Jun 12 @ 11:16am 
2 months later and still wondering - has the stuttering problem been resolved?

I wand this game but will not buy it until stuttering is eliminated - even at 1/2 off.

One wonders if that's why it IS half price today?
Mine works pretty good with grass off - on both a good machine, and a machine which was♥♥♥♥♥♥5 years ago, and is worse now!
Masacre Jun 12 @ 1:59pm 
@Werewolf13

I haven't been playing for a while but I loaded it up to test for you. The issue appears to still be very much at large sadly. It still stutters just as much regardless of grahpical setting. Mind you, it might also be that my computer specs are not really up to snuff but my guess would still be an engine issue. Still, the stutters are very miniscule if you just turn off grass (which, quite frankly, does not add much since you are generally zoomed out anyway). I'd give it a go for 50% off, you can always refund it if it actually bothers you too much.
Thanks Masacre:
From everything I've read the stutter issue doesn't appear to be a function of PC performance as both those with newer high performance machines and older lower performance machines experience the stutter.

Good point you made about refunding if the stutter appears during game play. I think I'll go ahead and get this game.

Aside and something others may want to try:

Fallout 4 had a horrible problem with stutter when first released. Bethesda said it was fixed after a while but it still happened for some. Many suggested fixes which worked for some but not others. I was one of the others. I've got a high spec machine. Almost gave up on FO4, I was ready to just delete it right then and there but figured I'd try one more time to find a solution. One guy related his experience which was very similar to mine. His solution - unplug the controller from his PC - reset the FO4 settings to turn off all references to the controller. He did and voila - stutter gone.

I tried that and got the same result. No controller hooked up to PC and no more stutter and a frame rate as smooth as clear ice that ran from 55 to 70 on ultra settings.

Don't know if Oriental Empires supports controllers but if it does might be worth a try to unplug it, disable in settings (if you can) and switch to mouse and keyboard.
Werewolf13 Jun 13 @ 11:06am 
Removing Stutter with Grass on:

Bought game - turned on grass. zoomed all the way in. move forward, backward, sideways NO stutter, none, nada. Rotate and stutter. I think this has to do with having to load new textures - can't prove it just my thoughts. The other thing I noted was no screen tearing when moving fwd, bkwd or sideways no matter whether moving slow or fast. Rotating screen tear was horrible and the stutter was non-existent at slow to moderate turn rates but unbearable at hight turn rates.

I solved the problem with the nvidia setting noted below (except when rotating the view very fast I'd still get 1 skip for every 180 degrees of turn). Still an issue and one the devs need to fix. If this was an action game instead of a 4X game I'd be refunding it. Still might.

Applies only to nVidia Graphics cards.

I've got an nVidia 970 so these setting may not work for you if you don't have a 970 or higher nvidia card

Using nvidia profile inspector load up Oriental Empires (it's not a default so you'll have to add it using nvidia control panel 1st if you haven't already)

Turn on frame rate limiter and set it to 41 FPS (frame rate junkies - 51 might work, 61 does work but not as well as 41).

Set maximum prerendered frames to 1
Set preferred refresh rate to Highest Available
Turn triple buffering on
Set Vertical sync to Force On
Set smooth AFR behavior to On (this is a special setting - mine's on by default - might not need to be on)
Set Vertical sync tear to Standard

Set up Anti Aliasing and Texture filter settings to override the application and then set them to your preferred values.

In the OTHER section set Memory Allocation Policy to As Needed

NOTES that may be of interest.
I'm 90% sure that OE runs in windowed mode whether windowed is turned on or not. When windowed is not checked the game is running in windowed borderless mode.

How do I know - screen tearing when vsync is turned on even in fullscreen mode. nvidia cards have an issue with windowed 3d apps and even some 2d ones. Vsyn doesn't work.

That's part of the issue - there is and has been for a long while this issue with windowed mode and nvidia.

It doesn't create the stutter but it is IMO part of the issue. This is why forcing the frame rate limiter on and choosing a rate with an odd number (ending in a 1 seems to work best) mostly cures the stutter problem. At least for me.
Last edited by Werewolf13; Jun 13 @ 11:10am
Masacre Jun 13 @ 12:27pm 
A bunch of those settings were not available for me which got me searching around a bit until I found Nvidia Profile Inspector. Huh, you learn something new every day. Anyway, just out of curiosity I tried those exact settings you proposed but it did not change anything for me.

Just a quick question: You said you were zoomed all the way in when you tested things out. For me, being zoomed all the way in gives me basically no issues. However, zooming about half way out is where the issues start (and then disappear again when zoomed almost all the way out and beyond). How do things work for you when zoomed out about half way with grass turned on?
< >
Showing 1-15 of 24 comments
Per page: 15 30 50