Trine 2

Trine 2

View Stats:
Trine 2 > General Discussions > Topic Details
Haeloth Apr 11, 2015 @ 10:01am
Can't save on Windows 8.1 because of UAC (also Trine 1)
Hi everybody. I just upgraded from Win 7 to 8.1 but after that I can't save my games. When I try the game says you don't have enough space, but I do have enough space. Then I thought maybe that's because the access settings, so I entered the game via the hidden Administrator account, the game worked fine. But from that account, it's not possible to use windows apps, such as mail, store calender etc. So I turned UAC off via changing EnableLUA variable from 1 to 0 from registry. But that also blocked my ability to use Windows apps as well. Is there a workaround for this? I tried running as administrator, changing compatibility to win 7 but that doesn't work neither. Thanks in advance :)
Last edited by Haeloth; Apr 11, 2015 @ 10:02am
< >
Showing 1-5 of 5 comments
MarjutFB  [developer] Apr 13, 2015 @ 3:04am 
With quick search it seems this has also happened with other games and at least few users said reinstalling the game helped. We haven't ran into this issue at our office.

Does this happen only with Trine 2? Or also with other games or programs?

If reinstalling doesn't help, you could also try to change your user to an admin user, or if it's already then change it to normal user and then back. You could also try to run the game in other compatibility modes.

This does sound like the problem could not be related to Trine 2, which would mean this can cause other trouble on your computer too – if this is the case you could try to update your operating system or consider installing Windows again.

If above doesn't help, we can also try to look more into this – so let me know how it goes! :)
Haeloth Apr 13, 2015 @ 6:30am 
Thanks for reply :)

1-)It doesn't happen with other games. Only with Trine 1 and 2. After upgrading my system from windows 7 to 8.1, I only had problems with Trine games. Other games can save without problems. And also turning UAC completely solves this issue but after that I can't access my Win 8 apps (I mean apps on the retro start menu. Other apps don't have any problems after doing that.)
2-)I am already an Administator. UAC is all the way down but it's impossible to close (at least that's what I think) it completely without small changes to registry. And closing it completely causes some problems.

I even tried switching to the hidden Administrator account that comes with Windows. From that account I can play Trine without problems but the same problems appear. Windows doesn't let me access to Win 8 apps on the start menu from that account. I can provide screenshots if you want.

I really thank you for your reply. I didn't even think that you were going to answer :)

PS: If it's going to help, windows asks for my permission everytime I try to paste anything to C. No matter extension, directory or being an administrator. But that doesn't stop other games from saving to C drive, such as Europa Universalis, Skyrim etc.
Last edited by Haeloth; Apr 13, 2015 @ 6:31am
MarjutFB  [developer] Apr 13, 2015 @ 8:52pm 
Did you try reinstalling one of the Trine games? I'd recommend to make sure Steam is started as administrator when trying this.

If you didn't already, you could also try other compatibility modes than Windows 7. Let me know if that makes any difference. Please also make sure there aren't any updates available to your operating system.

If above doesn't help, I'll forward this to our QA and we'll hopefully have some other suggestions for you. For this could you tell what is the exact message you get when you're trying to save? You can take a screenshot of it for example.

Let me know how it goes! :)
Haeloth Apr 17, 2015 @ 10:31am 
Sorry for being late, kinda busy this week :(
I fixed that issue just now by mistake. Moving Steam from C to D fixed that issue. I don't know how they are related, but my games are now working fine. Thanks for your help! :)
MarjutFB  [developer] Apr 19, 2015 @ 8:13pm 
Good that you found a solution. :)

Generally Windows has stricter rules on the main hard disk, so that might be the reason. Good that you had another disk.

If something else comes up let me know, but otherwise I hope you enjoy playing! :)
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Trine 2 > General Discussions > Topic Details
Date Posted: Apr 11, 2015 @ 10:01am
Posts: 5