Trine

Trine

Visa statistik:
Trine > Allmänna diskussioner > Ämnesdetaljer
Graphics Weirdness on Linux?
I'm getting a strange graphics issue on the Linux beta for the enchanted edition of Trine. I'm seeing heavy discoloration, and everything seems to have red pixelated shading overlaid on top.

The screenshot below demonstrates the issue:

https://lh6.googleusercontent.com/-Wm7dHXsnxto/VG1ObLFFJHI/AAAAAAAAEgE/CZ2RCpJPLhE/s0/2014-11-19_00001.jpg

OS: 64bit Ubuntu 14.04 LTS, kernel 3.13.0-39
CPU: AMD Phenom II 970 Deneb quad-core, 3.5ghz
GPU: nVidia GeForce 650 Ti (manufactured by Gigabyte)
Driver: nVidia 331.20
Senast ändrad av Zauberin Paracelsus; 19 nov, 2014 @ 18:21
< >
Visar 1-11 av 11 kommentarer
MarjutFB  [utvecklare] 19 nov, 2014 @ 22:12 
Just recently another player hinted that this might be caused by graphics card's driver's setting to force its anisotropic filtering on. If you turn this option off from the Nvidia Control Panel, the game should look normal.

Let me know if you have any questions about this or just how it goes! :)
Yep, that did the trick. I had enabled anisotropic filtering from the nVidia control panel a long while ago and forgot about it.
Played a couple sessions on this game. One immediate improvement I've noticed is that I'm actually able to save my game, an issue that I couldn't figure out and caused me to give up on the game. On the other hand, I'm noticing some shader issues. It looks like the specular shaders aren't being used, as I recall in the original version of the game I played, the telescope and the golden lion statues at the Trine's chamber were much shinier.
MarjutFB  [utvecklare] 24 nov, 2014 @ 22:39 
Yes, Enchanted Edition has mid-level saving added to the game. :)

And about the shaders, we are aware of some graphical issues in the game and are working on a fix. However to determinate what exactly is the issue you described, could you give more information about your problem? Maybe by taking pictures? You're probably using the same computer as you mentioned in your first post, but what graphics settings are you using (from the game's launcher)?

You can post the screenshots here or email them to us to Support[at]Frozenbyte[dot]com. If you email us, please mention this thread in your message so we know it's you.

Cheers!
Senast ändrad av MarjutFB; 24 nov, 2014 @ 22:40
MacAlbert 2 dec, 2014 @ 13:05 
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?
Senast ändrad av MacAlbert; 2 dec, 2014 @ 15:55
JLarja  [utvecklare] 2 dec, 2014 @ 20:27 
Ursprungligen skrivet av MacAlbert:
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?

"Workaround" as you call it, simply prevents driver from forcing some settings that our code doesn't support. You are basically telling the driver to disregard what Trine EE is asking it to do and do something else instead. There's nothing for us to fix.

-JLarja
SpectatorX 3 dec, 2014 @ 1:59 
I had something what looked similar in borderlands 2 linux version when depth of field was enabled. Example:
http://steamcommunity.com/sharedfiles/filedetails/?id=322716928

I'm not sure if enchanted edition has dof, if you can find dof option in options.txt file disable it.
JLarja  [utvecklare] 3 dec, 2014 @ 22:04 
We have a graphics patch coming for Linux. I don't have any details, but some DoF related bugs were apparently fixed. It's possible that they will accidentally fix AF issue too, but I really don't have any technical reason to suspect that.

Edit: Unfortunately, I misremembered. There were no DoF related fixes, though other graphics bugs were addressed.

-JLarja
Senast ändrad av JLarja; 4 dec, 2014 @ 21:29
plumbum 25 jul, 2015 @ 7:24 
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)
Ursprungligen skrivet av rustyminion:
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)

Yeah, I had to turn Anisotropic Filtering off in the nVidia Control Panel.
plumbum 25 jul, 2015 @ 10:07 
Thank you very much. :)
< >
Visar 1-11 av 11 kommentarer
Per sida: 15 30 50

Trine > Allmänna diskussioner > Ämnesdetaljer
Datum skrivet: 19 nov, 2014 @ 18:20
Inlägg: 11