Trine
Trine > Yleiset keskustelut > Aiheen tiedot
Graphics Weirdness on Linux?
I'm getting a strange graphics issue on the Linux beta for the enchanted edition of Trine. I'm seeing heavy discoloration, and everything seems to have red pixelated shading overlaid on top.

The screenshot below demonstrates the issue:

https://lh6.googleusercontent.com/-Wm7dHXsnxto/VG1ObLFFJHI/AAAAAAAAEgE/CZ2RCpJPLhE/s0/2014-11-19_00001.jpg

OS: 64bit Ubuntu 14.04 LTS, kernel 3.13.0-39
CPU: AMD Phenom II 970 Deneb quad-core, 3.5ghz
GPU: nVidia GeForce 650 Ti (manufactured by Gigabyte)
Driver: nVidia 331.20
Viimeisin muokkaaja on Zauberin Paracelsus; 19.11.2014 kello 18.21
< >
Näytetään 1-11 / 11 kommentista
MarjutFB  [kehittäjä] 19.11.2014 kello 22.12 
Just recently another player hinted that this might be caused by graphics card's driver's setting to force its anisotropic filtering on. If you turn this option off from the Nvidia Control Panel, the game should look normal.

Let me know if you have any questions about this or just how it goes! :)
Yep, that did the trick. I had enabled anisotropic filtering from the nVidia control panel a long while ago and forgot about it.
Played a couple sessions on this game. One immediate improvement I've noticed is that I'm actually able to save my game, an issue that I couldn't figure out and caused me to give up on the game. On the other hand, I'm noticing some shader issues. It looks like the specular shaders aren't being used, as I recall in the original version of the game I played, the telescope and the golden lion statues at the Trine's chamber were much shinier.
MarjutFB  [kehittäjä] 24.11.2014 kello 22.39 
Yes, Enchanted Edition has mid-level saving added to the game. :)

And about the shaders, we are aware of some graphical issues in the game and are working on a fix. However to determinate what exactly is the issue you described, could you give more information about your problem? Maybe by taking pictures? You're probably using the same computer as you mentioned in your first post, but what graphics settings are you using (from the game's launcher)?

You can post the screenshots here or email them to us to Support[at]Frozenbyte[dot]com. If you email us, please mention this thread in your message so we know it's you.

Cheers!
Viimeisin muokkaaja on MarjutFB; 24.11.2014 kello 22.40
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?
Viimeisin muokkaaja on MacAlbert; 2.12.2014 kello 15.55
JLarja  [kehittäjä] 2.12.2014 kello 20.27 
MacAlbert lähetti viestin:
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?

"Workaround" as you call it, simply prevents driver from forcing some settings that our code doesn't support. You are basically telling the driver to disregard what Trine EE is asking it to do and do something else instead. There's nothing for us to fix.

-JLarja
I had something what looked similar in borderlands 2 linux version when depth of field was enabled. Example:
http://steamcommunity.com/sharedfiles/filedetails/?id=322716928

I'm not sure if enchanted edition has dof, if you can find dof option in options.txt file disable it.
JLarja  [kehittäjä] 3.12.2014 kello 22.04 
We have a graphics patch coming for Linux. I don't have any details, but some DoF related bugs were apparently fixed. It's possible that they will accidentally fix AF issue too, but I really don't have any technical reason to suspect that.

Edit: Unfortunately, I misremembered. There were no DoF related fixes, though other graphics bugs were addressed.

-JLarja
Viimeisin muokkaaja on JLarja; 4.12.2014 kello 21.29
plumbum 25.7.2015 kello 7.24 
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)
rustyminion lähetti viestin:
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)

Yeah, I had to turn Anisotropic Filtering off in the nVidia Control Panel.
plumbum 25.7.2015 kello 10.07 
Thank you very much. :)
< >
Näytetään 1-11 / 11 kommentista
Sivua kohden: 15 30 50

Trine > Yleiset keskustelut > Aiheen tiedot
Lähetetty: 19.11.2014 kello 18.20
Viestejä: 11