Trine
Trine > General Discussions > Topic Details
Graphics Weirdness on Linux?
I'm getting a strange graphics issue on the Linux beta for the enchanted edition of Trine. I'm seeing heavy discoloration, and everything seems to have red pixelated shading overlaid on top.

The screenshot below demonstrates the issue:

https://lh6.googleusercontent.com/-Wm7dHXsnxto/VG1ObLFFJHI/AAAAAAAAEgE/CZ2RCpJPLhE/s0/2014-11-19_00001.jpg

OS: 64bit Ubuntu 14.04 LTS, kernel 3.13.0-39
CPU: AMD Phenom II 970 Deneb quad-core, 3.5ghz
GPU: nVidia GeForce 650 Ti (manufactured by Gigabyte)
Driver: nVidia 331.20
Last edited by Zauberin Paracelsus; Nov 19, 2014 @ 6:21pm
< >
Showing 1-11 of 11 comments
MarjutFB  [developer] Nov 19, 2014 @ 10:12pm 
Just recently another player hinted that this might be caused by graphics card's driver's setting to force its anisotropic filtering on. If you turn this option off from the Nvidia Control Panel, the game should look normal.

Let me know if you have any questions about this or just how it goes! :)
Yep, that did the trick. I had enabled anisotropic filtering from the nVidia control panel a long while ago and forgot about it.
Played a couple sessions on this game. One immediate improvement I've noticed is that I'm actually able to save my game, an issue that I couldn't figure out and caused me to give up on the game. On the other hand, I'm noticing some shader issues. It looks like the specular shaders aren't being used, as I recall in the original version of the game I played, the telescope and the golden lion statues at the Trine's chamber were much shinier.
MarjutFB  [developer] Nov 24, 2014 @ 10:39pm 
Yes, Enchanted Edition has mid-level saving added to the game. :)

And about the shaders, we are aware of some graphical issues in the game and are working on a fix. However to determinate what exactly is the issue you described, could you give more information about your problem? Maybe by taking pictures? You're probably using the same computer as you mentioned in your first post, but what graphics settings are you using (from the game's launcher)?

You can post the screenshots here or email them to us to Support[at]Frozenbyte[dot]com. If you email us, please mention this thread in your message so we know it's you.

Cheers!
Last edited by MarjutFB; Nov 24, 2014 @ 10:40pm
MacAlbert Dec 2, 2014 @ 1:05pm 
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?
Last edited by MacAlbert; Dec 2, 2014 @ 3:55pm
JLarja Dec 2, 2014 @ 8:27pm 
Originally posted by MacAlbert:
I'm having the same issue OP had, and I don't think disabling AF at control panel is acceptable. I mean, is this gonna be fixed or the AF workaround will be necessary in linux version?

"Workaround" as you call it, simply prevents driver from forcing some settings that our code doesn't support. You are basically telling the driver to disregard what Trine EE is asking it to do and do something else instead. There's nothing for us to fix.

-JLarja
SpectatorX Dec 3, 2014 @ 1:59am 
I had something what looked similar in borderlands 2 linux version when depth of field was enabled. Example:
http://steamcommunity.com/sharedfiles/filedetails/?id=322716928

I'm not sure if enchanted edition has dof, if you can find dof option in options.txt file disable it.
JLarja Dec 3, 2014 @ 10:04pm 
We have a graphics patch coming for Linux. I don't have any details, but some DoF related bugs were apparently fixed. It's possible that they will accidentally fix AF issue too, but I really don't have any technical reason to suspect that.

Edit: Unfortunately, I misremembered. There were no DoF related fixes, though other graphics bugs were addressed.

-JLarja
Last edited by JLarja; Dec 4, 2014 @ 9:29pm
plumbum Jul 25, 2015 @ 7:24am 
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)
Originally posted by rustyminion:
This Thread is old, but I have the same problem so maybe someone found a solution so far. :)

Yeah, I had to turn Anisotropic Filtering off in the nVidia Control Panel.
plumbum Jul 25, 2015 @ 10:07am 
Thank you very much. :)
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Trine > General Discussions > Topic Details
Date Posted: Nov 19, 2014 @ 6:20pm
Posts: 11