Middle-earth™: Shadow of War™

Middle-earth™: Shadow of War™

View Stats:
Black Screen Glitch
Anybody else experiencing this glitch? Happens only in this game, from time to time. The game runs normaly but every few minutes the screen goes completly black as though its trying to alt tab, and then it goes immediatly back to the game. Wondering if its just me or if anyone else has experienced this?
< >
Showing 1-15 of 46 comments
Taco Wizard Oct 11, 2017 @ 6:50pm 
im having this happen too, youre not the only one. idk how to fix it, i just updated my drivers too.
same updated my drivers to the latest for shadow of war and i dont know how to fix this. Can anyone let me know if there is a solution found?
Ghost585☠ Oct 11, 2017 @ 8:15pm 
Same issue on my end
Nebula Oct 11, 2017 @ 11:45pm 
Same
Nebula Oct 11, 2017 @ 11:46pm 
I did to a test by disabling my antivirus for 15m and it auto turned back on but a few minutes after, it blackscreened. I think ill further test this later.
Same disabled mine and it didnt do anything. I think it may have something to do with the new Nvidia driver update
5341K#02n Oct 12, 2017 @ 9:33am 
Same here
HGDragon Oct 12, 2017 @ 11:05am 
Same, but with graphik settings "without edges" it runs better. Test it.
Last edited by HGDragon; Oct 12, 2017 @ 11:17am
Anybody else lose mouse control when this happens? I feel like if i click while it black screens when it goes back i cant use my mouse at all.




Originally posted by HGDragon:
Same, but with graphik settings "without edges" it runs better. Test it.
gonna test that out right now
HGDragon Oct 12, 2017 @ 12:57pm 
Yes same Problem with mouse -- use setting "without edges" . The last 2 Hours i play without any Blackscreens!
Dr.EvilZ Oct 12, 2017 @ 2:37pm 
Originally posted by HGDragon:
Yes same Problem with mouse -- use setting "without edges" . The last 2 Hours i play without any Blackscreens!
i can't find that setting? im sorry if its obvious, do you mean fullscreen xD?
Last edited by Dr.EvilZ; Oct 12, 2017 @ 2:39pm
SickSadist Oct 12, 2017 @ 2:44pm 
i found turning down texture quality from ultra to high fixed this issue. It shows my graphics card cannot support ultra which needs 8GB of video ram high needs 3GB and my 980ti has 6GB.
Dr.EvilZ Oct 12, 2017 @ 4:04pm 
i found playing borderless works so far, its defently a background program for me but i looked in task manger 100x and cant find anything so borderless it is until i can figure it out =(
DskillerBR Oct 12, 2017 @ 4:09pm 
Same here, kind of relieved i'm not alone. Was starting to think it was my hardware
Dr.EvilZ Oct 12, 2017 @ 4:29pm 
Originally posted by DskillerBR:
Same here, kind of relieved i'm not alone. Was starting to think it was my hardware
it started today for me, after yesterday i let my windows update before i went to sleep, i woke up today (obivously) and the problem started, so it might have been that update or some program, also been playing for 40mins in borderless and the problem i havn't seen the problem yet, so YES borderless is a solution
Last edited by Dr.EvilZ; Oct 12, 2017 @ 4:32pm
< >
Showing 1-15 of 46 comments
Per page: 1530 50

Date Posted: Oct 11, 2017 @ 6:46pm
Posts: 46