Dungeon Warfare
Jacowboy Nov 1, 2016 @ 3:34am
the game just broke... and I can't fix it =/
So everything was fine, then today I launched it, and clicked on another window on my taskbar by mistake while the game was loading and the game broke...

It became minimized (I could hear the sound), so then I did ALT+ENTER to maximize it and there was no visuals of any kind... just the intro music.

Edit: I can click once after the intro metal music, then it goes into the map selection one, but nothing else happens or is clickable, I have to ALT F4 it to close it.

I uninstalled it, deleted all the files, disabled cloud connection and did it all over again... heck I think I even ran a search for broken dlls and nothing is fixing it. it just stays on a black screen now, no matter what I do =/

It seems it saved a faulty configuration and I just can't do anything at all...

So... yeah? I can't play it now... and it was working perfectly yesterday... so wtf devs? u_u


2nd Edit: I just thought of doing a system restore to see if it worked, and it did. But it was a week old and have now to re-do a lot of stuff, so that's NOT an optimal solution...
Last edited by Jacowboy; Nov 1, 2016 @ 4:52am
< >
Showing 1-6 of 6 comments
Listege  [developer] Nov 1, 2016 @ 9:14am 
I'm not sure why this problem is happen but try this.
1) Right click 'Dungeon Warfare' in your Steam library
2) Click 'Properties'
3) Click 'Set launch options...'
4) Input '-show-screen-selector' on popup window
5) Start the game
Then popup window with screen resolution option will be shown. Select screen resolution and start it.
Jacowboy Nov 2, 2016 @ 3:29am 
Ok, I will try that the next time it happens, although I hope it doesn't... thanks.

Not sure what it was either, but only a system restore managed to fix it, so maybe that'll give you some idea of what it could be =/

Iron Dec 15, 2017 @ 7:09pm 
It may be very old, but I just wanted to say I had this same issue on windows 10. The issue was with the custom scaling I had. Reset it to normal and it works just fine. In case anybody else sees it.
Still relevant to me today. Tried all of the various fixes including the one here, but if I start it in fullscreen nothing appears but an icon in the task bar (bring to front in task manager does nothing) and all I hear is the music play.

If I start in windowed mode, a window appears with the steam overlay with a black screen and only the intro music. Bringing to front and maximizing this window does nothing as well.

Problem started literally out of nowhere that i can discern.

It should be noted that when I start with the screen selector, the only resolution available was 1600x900, all the graphics options, and the monitor selection tab had absolutely no options in it.

Iron - I don't know what custom scaling is and I don't know that I ever messed with anything like that. Can you tell me what you mean by it and how I can see if I inadvertently messed with it?

Thanks, GW

Edit: Running Windows 10 on 64bit, laptop, problem does not change when switching from integrated graphics card to video card.

2nd Edit: Curiously enough I have the same problem with another game (Castles, developer Whootgames), with the same changes showing the same results, only when I start the game without the screen selector it gives me an error saying its "attempting to switch to resolution (0x4)" twice, then says "failed to switch to resolution (1600x900)". Hope this may help, I think it points to something going on with windows 10 or subsequent updates.
Last edited by Angrysaurus Rex; Jan 28 @ 12:20pm
ADV Jan 29 @ 7:35pm 
Try re-installing the video driver (clean install - but don't use any third party driver cleaners!). I know it sounds cliche, but I've found that fixes a lot of resolution glitchs with games, simply because the driver registry files get deleted and replaced.
I did that, with a wipe of the old driver, restart, and download of the latest, all the issues persisted after that.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50