Rising Storm/Red Orchestra 2 Multiplayer

Rising Storm/Red Orchestra 2 Multiplayer

View Stats:
HOWITZER Jan 29, 2014 @ 3:20pm
Game Forces System Crash/Freeze.
So I bought the game on release and it played fine. After a few updates I got the entire system crash/freeze issue after 15 to 20 minutes of gameplay on any map. Literally having to hit the restart button on the case.

I uninstalled the game after a few days and reinstalled and tried again, but to no avail, and then unistalled for good :(
Today I reinstalled after upgrading some parts recently on my computer.
Same issue persists !

I have googled endlessly and gone through the Steam forums so many times and all I can find is questions about this issue, but no answers with a possible fix. If there are answers I'm sorry, but they must be deep in the forum archives.

I have noticed that when the crash happens I get a nasty buzzing sound with a frozen screen and a locked system. No Alt F4 possible nor Ctrl Alt Delete.

i5 750 stock @2.66 to 3.2, Old but Gold.
8GB Ram 2x 4GB.
Gigabyte 6870 1GB HD Radeon.
Onboard Sound Realtek.

I set the game to minimal settings and low sound quality also, but no help there either.

All Drivers up to date. Chipset, Sound, GPU & everything else !

No issues with RO2 "Which I have not played since Rising Storm was released" or any other game, just Rising Storm.

The game is getting old and since I last played last year there appears to be hardly any players and I really want to get my moneys worth.
Well there are still a few, but for me most servers have too high a ping !

Any chance anyone ever found a fix.

Apologize if this is old news :)
Last edited by HOWITZER; Jan 29, 2014 @ 3:22pm
< >
Showing 1-12 of 12 comments
Kraft ♥ Squad Jan 29, 2014 @ 3:38pm 
I smell Realtek + PB.
No clue if there is any solution for that.

For validation, join a server that has PB disabled.
Last edited by Kraft ♥ Squad; Jan 29, 2014 @ 4:09pm
HOWITZER Jan 29, 2014 @ 3:55pm 
Ok I'll try that, I did forget to mention that in all this time I have not tried the PB option.
I'll join a non PB server and see what happens. Thx for the reply :)
HOWITZER Jan 29, 2014 @ 4:52pm 
Just played roughly 50 mins. No Crash !
On non PB server.

Now all I need to do is find out how to fix PB.

Thanks dude :)
Kraft ♥ Squad Jan 29, 2014 @ 5:00pm 
try everything that has something to do with PB
Some people said it worked after they did x/y

Other than that I can only suggest you don't buy another Realtek soundcard. This problem occurs in pretty much every game with PB support, but not for everyone. For example I can't play BFBC2 on my laptop because of this yet RO2 works fine :/
Last edited by Kraft ♥ Squad; Jan 29, 2014 @ 5:00pm
HOWITZER Jan 29, 2014 @ 5:22pm 
Just got a system freeze on a PB server, but it took longer to occur.
I will just go through that whole list from the link you gave and try whatever I can.
There are a few non PB servers so it's not all bad.

Thanks anyway :)
Last edited by HOWITZER; Jan 29, 2014 @ 5:23pm
HOWITZER Jan 30, 2014 @ 5:43am 
I tried the PB fix and nothing. Tried removing Realtek and used onboard and nothing again.
Went through that entire list and tried what was relevant to me and none of that worked either.

I'm guessing that my system just simply rejects this game :(

Shame really cause this never happened in RO2. Rising Storm is one of my fav games on Steam.
Kraft ♥ Squad Jan 30, 2014 @ 6:14am 
Have you uninstalled the Realtek drivers before removing the soundcard?
HOWITZER Jan 30, 2014 @ 7:32am 
I removed the Realtek Drivers, I only have onboard sound, No PCI Sound Card.
I just simply unistalled the drivers and used the base windows sound driver.
To no avail again though.

Have removed everything from Documents/MyGames as I remembered that I backed up, then replaced all those files after installing 64bit Win 7 from an old 32bit Win 7. Maybe this could be the issue, Using 32 bit saved data from old Win 7 on a 64bit system.
HOWITZER Jan 30, 2014 @ 4:33pm 
That's everything tried, But no luck. Seems to take longer for some reason, but still freezes system.

I'm just gonna put this down to faulty hardware. My GPU plays up sometimes when running Accelerated Hardware on flash videos. I just remembered I cannot run Cliffs over Dover either due to artifacts all over the game world "I got Screenshots for that" which is what happens when I watch flash videos on Youtube, Just artifacts "Little black squares everywhere". And my RAM is not exactly a well known brand.
Was a gift from a friend, but it was more than I had.
2x 8gb of 1600 @ 1333, Komputer Bay or something. Yh that's with a K :)
Was a cheap motherboard aswell, Wont be making that mistake again.

Thanks for the help anyway. I intend on upgrading my CPU and Board this year.
So Hopefully I don't miss too much of RO2/RS :)
Last edited by HOWITZER; Jan 30, 2014 @ 4:34pm
Kraft ♥ Squad Jan 31, 2014 @ 8:10am 
I don't think it's faulty hardware since It worked before RS.
Anyway, are your temps ok?
Last edited by Kraft ♥ Squad; Jan 31, 2014 @ 8:11am
HOWITZER Feb 1, 2014 @ 10:36am 
I have not checked. It's something I have never had an issue with. My GPU has Windforce x3 always at 100% fan speed and my CPU is cooled by Arctic Cooler Rev 2 or something. Been a long time since I installed it and I used Arctic Silver. Since then I've had no heat issues.

If it was gradually overheating the games performance would slowly diminish, Which it does not.
Think I'll grab one of these ingame monitors to see if the temp does go up.

Other than that I think I'll just leavie it until the next update, if ever there is one :)
HOWITZER Feb 12, 2014 @ 4:00pm 
Well. I upgraded my Motherboard to a Z87 and got an i5 4670K and all my issues seem to have stopped. Not saying that I bought the new system to stop this from happening, but wanted to do this for a long time. i5 750 was just to old.

It could of been the new instal of Windows 7 that may have fixed the issue. Or maybe it was a RAM issue.
My RAM is rated for 1600, but my old board & CPU was running it at 1333. There is no telling exactly what I have done to fix the freezing system, but it works.

Personally I'd say it was my OS that was at fault.

Sorry for bringing up an old topic, but just had to metion this.
Thanks for the help anyway :)

Peace !
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Jan 29, 2014 @ 3:20pm
Posts: 12