Steam Link

Steam Link

View Stats:
Steam Link > General Discussions > Topic Details
DonSeismo Oct 20, 2015 @ 10:31am
Resolution limited when PC monitor is switched off
Hello all,

this might not be only a steam link issue but nevertheless I need more information and a solution for this topic. I have a dual monitor setup, 1 primary monitor with 1920*1200 connected via displayport and 1 monitor with lower resolution connected via DVI.

Everything works fine with my Steam Link as long as my primary monitor is switched on. It streams Full HD resolution on my TV. But as soon as I switch of my primary monitor windows seems somehow to lower the resolution in the background and steam link is no longer displaying at full hd. Also in streamed games I can no longer seleect higher resolutions!?

Is there any possibility to avoid Windows lowering the resolution!? Also setting host Steam to stream at 1080p doesn't help.


Thanks!
< >
Showing 1-15 of 20 comments
Deathnutz Oct 20, 2015 @ 11:19am 
The closest thing I've seen so far talking with folks in here, is giving your steam shortcut target options to run in windowed mode... and then set that window to your desired resolution. While this works pretty well for going to lower than desktop resolutions, we can't figure out how to go higher than desktop resolutions. Steam is blocking the resoltuion to be higher than the desktop resoluion somehow... have to find the option to disable that.

I have an nVidia card made a custom resolution to 1080p... then have to set my desktop to that before I stream to get the best restults. There is a little $10 peice of hardware out there that you plug into your video card to make it think you have a crazy high rez monitor... then giving you the option to choose any resoluion under that and making it your "primary" monitor for steam. I don't know how well it works, but I'd perfer a steam fix... or a driver option to mimic that hardware dongle. In any matter, we are kinda without a solution yet.
DonSeismo Oct 20, 2015 @ 11:23am 
Already tried the windowed solution, but didn't work out for me. Of course I could also try to use DVI connection with my primary monitor but this should only be last solution.

I have now also tried to unplug my lowerr res secondary monitor but then windows seems to still lower the resolution once the displayport monitor is switched off.
Deathnutz Oct 20, 2015 @ 11:26am 
What happens if you have no monitors on?
DonSeismo Oct 20, 2015 @ 11:28am 
Steam link is only showing very low resolution ingame.
No idea where it gets this setting from. Also Big Picture mode itself is at 7xx to something resolution.
Deathnutz Oct 20, 2015 @ 2:21pm 
Interesting. I turned mine off but it didn't affect anything. Perhaps if I removed the power from the monitor as well...
DonSeismo Oct 21, 2015 @ 9:25am 
But you also use displayport?
monikerpl Nov 10, 2015 @ 2:22pm 
I think the problem is that when monitor is turned off, your GPU is also turned off so your computer reverts to using your on-board graphics. I've found some hacks that involve 'tricking' your GPU into thinking it is connected to a monitor. Not a nice solution. Hope Valve works out something very soon.
Tatler Nov 11, 2015 @ 1:57pm 
I have this exact problem as well. How can i trick the GPU?
monikerpl Nov 11, 2015 @ 6:12pm 
Search for 'headless hdmi'. There's some hacks to get around having to pay ~$25 that use a dvi adapter plus some resistors, but that's probably not preferred.

This is silly though. Valve should have anticipated that people would not want to have to have another monitor running while streaming. The device for the hack is really simple and it would seem to make sense to provide it to people who purchase the steam link.
cp_clegg Dec 1, 2015 @ 9:43pm 
I have been using the Steam Link for a while with a PG278Q monitor connected via Displayport and didn't have this problem. I just recently replaced the PG278Q with a PG279Q (also connect with Displayport) and I started having this issue. If my monitor was off when I started streaming, the stream would be rendered at a low resolution.

I discovered the PG279Q had some new options that were enabled by default in the OSD called "Displayport Deep Sleep" and "HDMI Deep Sleep". I disabled these and the problem went away.

Hopefully this will help others with the PG279Q or if your monitor has a similar option. I have also read that if your monitor has a DDC/CI option that disabling that might help.

Here is a thread that has a somewhat useful discussion on the topic: http://superuser.com/questions/630555/turning-displayport-monitor-off-disables-monitor-completely

If all else fails, and you don't want to try the physical HDMI dongle to emulate a monitor, you could try this solution which circumvents EDID detection: https://sites.google.com/site/ebobster/stuff/displayportblanking
Tucu Dec 2, 2015 @ 1:18am 
This HOWTO for a Headless setup works for me: http://www.pcgamer.com/how-to-set-up-steam-in-home-streaming-on-your-pc/
Last edited by Tucu; Dec 2, 2015 @ 1:18am
Sperber Dec 2, 2015 @ 2:18am 
Originally posted by Tatler:
I have this exact problem as well. How can i trick the GPU?
One thing that comes to mind: you can plug a powered HDMI switch to one of your video card's HDMI output. Those HDMI switches usually report to the video card as an active display capable of any resolution, even if they don't have any device plugged into an output. Thus your PC will default back to that output if your main monitor is turned off and should maintain a resolution that's supported by HDMI.
jUNCTURE Dec 26, 2015 @ 9:53am 
Has this been fixed. I can't believe that I'm supposed to leave a monitor plugged into my pc just to use steam link.
DonSeismo Dec 26, 2015 @ 10:49am 
I could fix it by changing the Display Port energy saving features in my monitor.
jUNCTURE Dec 26, 2015 @ 1:56pm 
And when you unplug your monitor from your system it still works? Or just when powered off?
< >
Showing 1-15 of 20 comments
Per page: 15 30 50

Steam Link > General Discussions > Topic Details
Date Posted: Oct 20, 2015 @ 10:31am
Posts: 20