Steam Controller

Steam Controller

CalienteBoots Jun 22, 2016 @ 7:30pm
Turn off controller keyboard (Rocket League)
So now whenever I go to type a comment during a match (pressing T or Y in-game), the steam overlay controller keyboard pops up. This is annoying to me since it blocks the screen from the gameplay. I don't comment frequently but if I do I like to keep the field in view just in case I need to stop and jump back into driving. I play with my computer's keyboard at hand so I don't need to use the controller and I would much rather just type normally. Is there any way to disable this?

< >
Showing 1-15 of 16 comments
Go into your Steam settings, and under "In-game" uncheck the box that says "Use the Big Picture Mode overlay when using a Steam Controller from the desktop"

Then, always launch Rocket League from the desktop.
CalienteBoots Jun 23, 2016 @ 5:57pm 
I didn't want to completely disable Big Picture mode, but I guess it'll have to do for now. Thanks m8
LymePi Nov 13, 2016 @ 8:35pm 
necroing this thread because I found a solution in a different forum. I will quote it here:

"If you'd like to get rid of this, go to Rocket League in your steam Library, then right click on it and go to properties.
At the bottom left you'll see "Set launch options..."
open that and then add in -NoKeyboardUI
Press ok and play RL as you normally would. This will revert it back to the normal chat box"
- Dirkened on the Psyonix forums
Tea_Maniac Nov 14, 2016 @ 12:15am 
Thanks!
it was all a meme Jan 21, 2017 @ 9:30pm 
thanks rootfair that's what i was looking for
yak Jan 26, 2017 @ 6:18pm 
Thanks, RootFair, I appreciate you.
The Milkman Jul 8, 2017 @ 12:04pm 
Thank you so much for that, RootFair. That stupid on-screen keyboard is what keeps me from playing in BPM but it's been randomly launching mid-match lately and then re-binding (!!!?!!) my controller.
adumb Dec 7, 2017 @ 11:32pm 
To those of you who would like to turn off the on-screen Steam keyboard altogether
In your Steam window:

View ----> Settings ----> Controller ----> Desktop Configuration

This will open a window that displays your controller.
  • Click the box on the bottom left showing the various Arrow Keys.

  • It will show a few settings. On the right, click on "Show Keyboard" under the "Click Action" setting.

  • This will open up a keyboard and mouse with a bunch of possible bindings.

  • Click the "Remove" button, below the keyboard display.

  • Back out of the settings and click 'OK'
This will unbind the stupid keyboard from popping up when you press down on the stick.
Last edited by adumb; Dec 7, 2017 @ 11:40pm
Dec 7, 2017 @ 11:53pm 
Originally posted by ☠ King Satin ☠:
To those of you who would like to turn off the on-screen Steam keyboard altogether
In your Steam window:

View ----> Settings ----> Controller ----> Desktop Configuration

This will open a window that displays your controller.
  • Click the box on the bottom left showing the various Arrow Keys.

  • It will show a few settings. On the right, click on "Show Keyboard" under the "Click Action" setting.

  • This will open up a keyboard and mouse with a bunch of possible bindings.

  • Click the "Remove" button, below the keyboard display.

  • Back out of the settings and click 'OK'
This will unbind the stupid keyboard from popping up when you press down on the stick.
Nobody is talking about desktop config here. :) Thanks for trying to be helpful anyway.
yak Dec 8, 2017 @ 11:08am 
What do you mean? I was totally talking about a desktop config.
almo2001 [BHVR] Dec 10, 2017 @ 12:51pm 
Originally posted by RootFair:
necroing this thread because I found a solution in a different forum. I will quote it here:

"If you'd like to get rid of this, go to Rocket League in your steam Library, then right click on it and go to properties.
At the bottom left you'll see "Set launch options..."
open that and then add in -NoKeyboardUI
Press ok and play RL as you normally would. This will revert it back to the normal chat box"
- Dirkened on the Psyonix forums

OH YEAH. Thanks man.
wingback18 May 31, 2018 @ 10:27am 
hi everyone , im having the same problem , but the keyboard pop ups when Im playing origin games. im playing mirrors edge catalyst , the keyboard keeps closing the game and appearing, i disabkle big picture and still happening , is there something i need to do . i have a ps3 controller
Raynaga Aug 23, 2018 @ 4:02pm 
Originally posted by ☠ King Satin ☠:
To those of you who would like to turn off the on-screen Steam keyboard altogether
In your Steam window:

View ----> Settings ----> Controller ----> Desktop Configuration

This will open a window that displays your controller.
  • Click the box on the bottom left showing the various Arrow Keys.

  • It will show a few settings. On the right, click on "Show Keyboard" under the "Click Action" setting.

  • This will open up a keyboard and mouse with a bunch of possible bindings.

  • Click the "Remove" button, below the keyboard display.

  • Back out of the settings and click 'OK'
This will unbind the stupid keyboard from popping up when you press down on the stick.

You sir are a God! Thanks, I was so tired of this configuration!
Darth Agony Nov 11, 2019 @ 10:30am 
Originally posted by ☠ King Satin ☠:
To those of you who would like to turn off the on-screen Steam keyboard altogether
In your Steam window:

View ----> Settings ----> Controller ----> Desktop Configuration

This will open a window that displays your controller.
  • Click the box on the bottom left showing the various Arrow Keys.

  • It will show a few settings. On the right, click on "Show Keyboard" under the "Click Action" setting.

  • This will open up a keyboard and mouse with a bunch of possible bindings.

  • Click the "Remove" button, below the keyboard display.

  • Back out of the settings and click 'OK'
This will unbind the stupid keyboard from popping up when you press down on the stick.


You sir are a ♥♥♥♥♥♥♥ hero. I couldn't figure out where the damn keyboard was coming from :)) Thank you!
PhoenixTomb Aug 22, 2020 @ 12:43pm 
Originally posted by ☠ King Satin ☠:
To those of you who would like to turn off the on-screen Steam keyboard altogether
In your Steam window:

View ----> Settings ----> Controller ----> Desktop Configuration

This will open a window that displays your controller.
  • Click the box on the bottom left showing the various Arrow Keys.

  • It will show a few settings. On the right, click on "Show Keyboard" under the "Click Action" setting.

  • This will open up a keyboard and mouse with a bunch of possible bindings.

  • Click the "Remove" button, below the keyboard display.

  • Back out of the settings and click 'OK'
This will unbind the stupid keyboard from popping up when you press down on the stick.

YES!
Thank you so much :)
< >
Showing 1-15 of 16 comments
Per page: 15 30 50