Steam Controller

Steam Controller

komali 2 Jun 10, 2022 @ 8:07am
steam controller "steam" (home) button inputting random buttons and keys
Randomly tonight, my steam controller home button started inputting r1 and r2 at full strength, as well as the b button, and some random key, at the same time, instead of launching the steam overlay.

1. This behavior is maintained regardless of which of my steam controllers are used
2. I use my steam controllers over wireless dongle plugged into a steam link, which streams over Ethernet from my PC
3. I tried resetting the steam link, PC, unplugging all input devices, changing steam controller batteries
4. I tried toggling and untoggling "enable steam overlay"
5. This issue started today, though I haven't used my steam controllers in about a week
6. I can hold the steam button to cause the "control remote session" overlay to launch

Any ideas? Reddit noticed chorded inputs from their home button, but I never use those, and anyway I followed their solution of resetting chord input bindings and still nothing.
< >
Showing 1-5 of 5 comments
DaMu Jun 10, 2022 @ 3:13pm 
If the behavior happens across multiple steam controllers regardless if streaming or at the desktop, then it's a software issue. Don't bother "resetting" the chord input bindings, try removing them all together in a custom config to completely rule out controller configuration conflicts.
komali 2 Jun 11, 2022 @ 7:36pm 
You made me realize I hadn't tested in desktop only mode. In fact, when not streaming, and plugged into PC via USB, and using big picture mode, the steam button functions as expected.

When plugged into steam link via USB, still functions improperly. Will try removing all chorded configs now.
komali 2 Jun 11, 2022 @ 7:40pm 
Though I was on the default chorded configuration, deleting all chorded config buttons (except for y button turn off controller) appears to have solved the issue. My steam button now pops overlay on single press. Very very weird.
komali 2 Jun 11, 2022 @ 7:42pm 
To do this, I, from streaming steam link big picture mode, went to the settings wheel in top right, went to "base configurations" under "controller," went to "steam button chord configuration," and in this controller configuration, unbound all buttons. Then pressed "B" for "done." It began working as expected immediately after.
qck Jun 30, 2022 @ 2:19pm 
So I'm having a similar issue - pressing my Steam button triggers a full press of the left and right triggers. Similarly, this only happens when connected to the Steam Link hardware; connected to the PC it works fine. However, unmapping all of the buttons under the Steam Button Chord Configuration didn't seem to help. I've actually been unable to use the steam button + Y to turn off the controller as well, even when mapped in the Steam Chord options...

Don't suppose anyone has any other suggestions?
< >
Showing 1-5 of 5 comments
Per page: 1530 50