ARK: Survival Evolved

ARK: Survival Evolved

View Stats:
Skydor69 Aug 13, 2015 @ 6:20pm
Singleplayer Exit To Main Menu Loading Time.
Is anyone else experiencing really long load times when exiting from singleplayer to main menu?
< >
Showing 1-15 of 33 comments
josephjames972 Aug 13, 2015 @ 6:23pm 
yes
Ballsy Aug 13, 2015 @ 6:24pm 
Same. Been like that for the last few patches for me.
Ghost Ryder Aug 13, 2015 @ 6:25pm 
yep very long now
not only that it craches every now and again after exiting.

What I do now since it takes forever to exit.
Bring up console:
type in "saveworld"
then type in "exit"
Last edited by Ghost Ryder; Aug 13, 2015 @ 6:28pm
PlayerNumber03 Aug 13, 2015 @ 6:42pm 
Originally posted by Skydor69:
@Ghost_Ryder - I'll have to try that next time. The last time I played it took 5 mins before it exited to the main menu.

I've noticed this since like v190. What about on official servers? I ONLY experience it in singleplayer
Pufferfish Aug 13, 2015 @ 6:59pm 
Originally posted by Ghost_Ryder:
yep very long now
not only that it craches every now and again after exiting.

What I do now since it takes forever to exit.
Bring up console:
type in "saveworld"
then type in "exit"
This is almost exactly what I do as well. Except I Cntr Alt Del out and end the game that way, have to try the exit command instead. Thanks.
Ultragamer Sep 4, 2015 @ 10:39am 
I know this is an older thread but I just recently bought/installed this game. Same issue here.
Last edited by Ultragamer; Sep 4, 2015 @ 10:40am
Greystar Sep 4, 2015 @ 10:42am 
Yep its been this way the whole time i've played.
Ultragamer Sep 4, 2015 @ 10:44am 
Funny thing is I don't need to do tab - saveworld, it does that upon quit.
Qubaal3 Sep 4, 2015 @ 10:56am 
I believe this is realated to how many dino spawns in the world when exiting SP. SP world will have more dinos roaming than a MP world? Secondly, the .bak files need to be updated too?
Ultragamer Sep 4, 2015 @ 11:07am 
I don't know if it's backups but it shouldn't take that long. It's just that alot more must go on behind the scenes when exiting from your own server and it's hanging the game compared to being just a client.
Last edited by Ultragamer; Sep 4, 2015 @ 11:07am
TNSEE Sep 4, 2015 @ 11:28am 
Single player is nothing more than running a very short term local server, it takes anywhere from 60 seconds to 5 minutes (depending on your machine) to setup and properly shut down the server portion. Joining / quiting a running server is always going to be much quicker.
Max Sep 20, 2015 @ 9:57am 
Originally posted by EvilEngineer:
Single player is nothing more than running a very short term local server, it takes anywhere from 60 seconds to 5 minutes (depending on your machine) to setup and properly shut down the server portion. Joining / quiting a running server is always going to be much quicker.

I run a dedicated server (DS) and test mods on my single player.
My dedicated server is an 8 year old Intel Q6600, 8GB RAM, mechanical HDD.
When I test mods in single player its on an i7-4790k, 16GB RAM, Evo 850 SSD with verified 500MB/s write speed on my system.
My DS takes 240 seconds to start, 5 seconds to shut down.
Joining my DS from my i7 computer via LAN takes me ~15 seconds from hitting JOIN to PLAY, ~ 3 seconds to exit.
My single player takes ~ 40 seconds to start and up to 5min to exit which I usually don't have patience for and simply force quit.

Doesn't make sense at all, must be a bug is all I can say.
Its nothing to do with drivers that people blurt out as the first thing to try and remedy the situation on all the "hangs on exit from sp" threads. I mean, really, you can start game and play for hours and then exiting to main menu crashes and people say its driver related?

A strange issue indeed.

Update: I now test my mods and play in non-dedicated multiplayer mode as it uses the same game data as single player only and it starts up and shuts down quickly without hanging.
Roughly 7.9GB RAM out of 16GB and 17% CPU usage while playing, 36% CPU usage while shutting down for ~ 8 - 10 seconds before getting back to main menu.
Last edited by Max; Sep 20, 2015 @ 10:19am
Jynn Sep 20, 2015 @ 10:04am 
Same, I've always had this issue.

Though with the latest patch, if i try to do ANYTHING when it's quitting singleplayer, it crashes my game and my comptuer >.<
Red River Sep 20, 2015 @ 10:07am 
yup super slow on my super fast SSD almost longer than to load the game lol
Max Sep 20, 2015 @ 10:15am 
You know what, I just ran in Non Dedicated Multiplayer mode which uses your SP game info as far as I can tell just that it allows a friend to join if they wish, no problem, exiting took ~8 seconds.
I edited my post on page 1 to reflect this finding which is a working interim solution for me.
Last edited by Max; Sep 20, 2015 @ 10:20am
< >
Showing 1-15 of 33 comments
Per page: 15 30 50

Date Posted: Aug 13, 2015 @ 6:20pm
Posts: 33