ARK: Survival Evolved

ARK: Survival Evolved

View Stats:
Jimmy NoShoes Jul 7, 2016 @ 1:40pm
Linux Server Auto Mod Update
On Linux Servers, you need to run this script (included with the ARK dedicated server files) once to install SteamCMD: \SteamCMDInstall.sh

---

Care to enlighten just where this script is? Cannot find it.
< >
Showing 1-7 of 7 comments
Blaksmith Jul 7, 2016 @ 3:49pm 
I would like to try this on my servers too. I can not find it anywhere either. even doing a complete updatedb, then "locate -i SteamCMDInstall", it is nowhere to be found. For now, I will just have to use my own updater program that I wrote.

Another issue, which goes along with this, is when I add this to the command line: "-automanagedmods", I get the following error over and over (I use ARKRemote also):
Server Starting
state:running
Using binned.
4.5.1-0+UE4 7038 3077 402 5
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 346110
LowLevelFatalError [File:E:\SVN_Ark\Engine\Source\Runtime\Core\Private\Linux\LinuxPlatformProcess.cpp] [Line: 652]
FLinuxPlatformProcess::WaitForProc: waitid for pid -1 failed (errno=22, Invalid argument)
Signal 11 caught.
EngineCrashHandler: Signal=11
Process Exited - restarting
Server Starting
state:running
Using binned.
....
and it just repeats until I tell ARKRemote to stop the server. Once I remove the command line entry, it works just fine. The error that I'm pointing out, is the LowLevelFatelError line. The [S_API FAIL] line has always been there, so that is not an actual error.
Hattrick Jul 7, 2016 @ 5:40pm 
My Linux server won't start with the new switch in the command or the section added to Game.ini. I tried all permutations. The script does not exist either. Unfortunately, now when I try to connect the server spikes the CPU to 100% and I get a timeout on the client. There seems to be something very wrong with 244.4.
Blaksmith Jul 7, 2016 @ 6:17pm 
3 of my 4 servers I did "not" add in the command line switch, and they are running just fine. The one that I did test the switch on, a local dedicated that I use for testing that is sitting behind me, after adding / removing the switch, and adding / removing the section in the Game.INI file, is doing that also. I have had htop running, and it seems like it is pegging a single core, insted of running on all 4, and is not threading properly any more, and the CPU fans are just screaming on the machine. I have even gone to the point of re-validating the files, and it still does the same thing.
It shows up in the list of servers, but when I join, it just times out. I was able to join about 2 - 3 min after it came up, then it disconnected, and won't let any more connections come in.

Just for troubleshooting, I think I'm going to try and remove the maps, and let it start fresh (after doing backups of course).
Blaksmith Jul 7, 2016 @ 7:07pm 
After wiping the map, and starting fresh, I was able to log in, create a new character, run around, do normal game play (only did it for 3 - 5 minutes).
Stopped the server, copied the player, tribe, and one of the map backup files to the SavedArks directory, fired it up, and back to square 1 with not able to connect, and single thread going full blast. iotop shows no HDD read/write activity, other than normal processes.

Next test:
Remove map, but leave player / tribes files.
Loaded in just fine, playing on a fresh map, have all engrams etc..
Server is nice and quiet, and using multi-threads.

So, I am going to assume for now, that the map file has some issues. I read on other threads, that going to 244.2 caused map issues, but this one actually went from 243.something (was shut down for a while, because it is just a test server) to 244.4.

Final test:
restore all the files, put some ear-plugs in, and let it rip for a few hours, and see if it finally actually calms down.
Blaksmith Jul 7, 2016 @ 8:51pm 
Update: server quieted down finally, and able to log in and play normally. I'm assuming a map format change, even though very little disk activity, something wasn't properly threaded to process the data.

Back to the original OP.
Devs, can you please make sure that the sh shell script is in the next hotfix? Still not found.

Jimmy NoShoes Jul 8, 2016 @ 3:49am 
Still doesn't exist. Either they need to explain the process in more detail, or actually include the required files to do so....

Kinda ridiculous.
Jimmy NoShoes Jul 9, 2016 @ 5:28am 
bumping.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Jul 7, 2016 @ 1:40pm
Posts: 7