Vis statistikker:
Eversion > Generelle diskussioner > Trådoplysninger
sebas86pl 29. dec 2012 kl. 14:31
Crash on Linux
Probably game crash on sound subsystem initialization:

$ ./Eversion
GNU gdb (Gentoo 7.5 p1) 7.5
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /home/seba/Steam/SteamApps/common/Eversion/x86/eversion.x86...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/seba/Steam/SteamApps/common/Eversion/x86/eversion.x86
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0xf7e8fb40 (LWP 1670)]
Setting breakpad minidump AppID = 33680
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197988416633 [API loaded no]
[S_API WARN] Overlay does not appear to be loaded into game, but SetOverlayNotificationPosition() is being called
[New Thread 0xf1d95b40 (LWP 1680)]
[Thread 0xf1d95b40 (LWP 1680) exited]
Available Modes
1920 x 1080
1680 x 1050
1680 x 945
1600 x 1200
1600 x 900
1440 x 900
1400 x 1050
1366 x 768
1360 x 768
1280 x 1024
1280 x 960
1280 x 800
1280 x 768
1280 x 720
1152 x 864
1024 x 768
1024 x 576
848 x 480
832 x 624
800 x 600
720 x 576
720 x 480
720 x 400
640 x 480
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
/dev/dsp: Device or resource busy

Program received signal SIGSEGV, Segmentation fault.
0x0806982b in InitAudio(char*, char*) ()
(gdb) bt
#0 0x0806982b in InitAudio(char*, char*) ()
#1 0x0804d594 in main ()
< >
Viser 1-9 af 9 kommentarer
sebas86pl 29. dec 2012 kl. 15:24 

resolves problem...
anarchisttomato 14. jan 2013 kl. 19:17 
Do I just copy and paste this into the launch options? Because if so, that didn't work. If not, soz...
sebas86pl 16. jan 2013 kl. 12:11 
Launch options pass arguments directly to application. SDL_AUDIODRIVER must be set as environment variable. You can edit Eversion run script or set it with other system environment variables (in /etc/env.d).
twice_11 21. jan 2013 kl. 15:21 
The error messages sounds more like a missing 32-bit ALSA pulse-audio plugin. The sound card is occupied by pulseaudio running, and ALSA is correctly configured to use pulseaudio as default output device, but it fails to load the pulseaudio support, falls back to direct hardware access, fails again as the sound card is busy, so there is no working sound driver. Eversion can't handle that. crash.
sebas86pl 22. jan 2013 kl. 10:38 
Even if something goes wrong with sound subsystem application should handle that (log tels nothing about sound driver fail), not just crash. Sadly other application works just fine using Pulseaudio, Alsa or OSS (emulated by Alsa) subsystems. ;)
Isammoc 24. jan 2013 kl. 13:24 
Thanks sebas86pl , the export solve the problem for me. ^^
anarchisttomato 26. jan 2013 kl. 21:38 
My copy's still crashing. I tried launching by console inside the game folder itself and got the following (note that it starts the opening screen with the Lovecraft info etc, then crashes, see after '640x480'):

nhoj@nhoj-desktop:~/.local/share/Steam/SteamApps/common/Eversion$ ./Eversion
Setting breakpad minidump AppID = 33680
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198010812299 [API loaded no]
Available Modes
1920 x 1080
1680 x 1050
1600 x 1200
1440 x 900
1400 x 1050
1280 x 1024
1280 x 960
1280 x 720
1152 x 864
1024 x 768
800 x 600
640 x 480
(eval):267: [BUG] Segmentation fault
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-linux]

-- Control frame information -----------------------------------------------
c:0004 p:---- s:0013 b:0013 l:000012 d:000012 CFUNC :getButtonOnce
c:0003 p:0117 s:0009 b:0009 l:000008 d:000008 METHOD (eval):267
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:001d1c d:001d1c TOP

-- Ruby level backtrace information ----------------------------------------
(eval):267:in `daemon'
(eval):267:in `getButtonOnce'

-- C level backtrace information -------------------------------------------
./x86/libruby.so.1.9(+0x15e364) [0xf756a364]
./x86/libruby.so.1.9(+0x4ec31) [0xf745ac31]
./x86/libruby.so.1.9(rb_bug+0x41) [0xf745b261]
./x86/libruby.so.1.9(+0xf7d8d) [0xf7503d8d]
./x86/eversion.x86() [0x806070e]
./x86/eversion.x86() [0x806e95a]
./x86/libruby.so.1.9(+0x148a0b) [0xf7554a0b]
./x86/libruby.so.1.9(+0x157c9b) [0xf7563c9b]
./x86/libruby.so.1.9(+0x14d4db) [0xf75594db]
./x86/libruby.so.1.9(+0x1530cc) [0xf755f0cc]
./x86/libruby.so.1.9(+0x154299) [0xf7560299]
./x86/libruby.so.1.9(rb_funcall+0x1f9) [0xf7560929]
./x86/eversion.x86() [0x807002d]
./x86/libruby.so.1.9(rb_protect+0xc3) [0xf745f503]
./x86/eversion.x86() [0x807105c]
./x86/eversion.x86() [0x804e8c8]
./x86/eversion.x86() [0x804e999]
./x86/eversion.x86() [0x804d9c5]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0xf70b54d3]
./x86/eversion.x86() [0x804e581]

-- Other runtime information -----------------------------------------------

* Loaded script: embedded

* Loaded features:

0 enumerator.so
1 /home/nhoj/.local/share/Steam/SteamApps/common/Eversion/scripts/camera.rb
2 /home/nhoj/.local/share/Steam/SteamApps/common/Eversion/scripts/player.rb

* Process memory map:


You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

./Eversion: line 22: 22017 Aborted (core dumped) ./x86/eversion.x86
flibitijibibo  [udvikler] 4. feb 2013 kl. 20:46 
Do you have any controllers attached? Try running this:


Post what it tells you about the joystick itself (name, number of axes, etc).
anarchisttomato 25. feb 2013 kl. 0:02 
Sorry about delay, must have unsubcribed by accident. By solving a problem for another game, I solved this. Yes, it is to do with controllers, *technically*. ;) I have a Microsoft USB keyboard, and for some reason it's detecting as a joystick - something I only discovered yesterday. This would cause in a few other games to have the character start spinning immediately. I fixed this by actually plugging in a joystick. So if there's any other users out there with crashing who have a Microsoft keyboard, try plugging in an actual joystick (you don't have to use it, just have it plugged in).

< >
Viser 1-9 af 9 kommentarer
Per side: 15 30 50

Eversion > Generelle diskussioner > Trådoplysninger
Dato opslået: 29. dec 2012 kl. 14:31
Indlæg: 9