From Dust

From Dust

From Dust > General Discussions > Topic Details
Pr0xima_Centauri Nov 10, 2012 @ 10:25am
From Dust and Uplay/UbisoftGameLauncher
I installed the game a long time ago and today I wanted to play it again. The Ubisoft Game Launcher made an update and now I had to create an Ubisoft-account for Uplay in order to play. I don't want an Uplay-account so I did the following to avoid the account:

  • Deleting From Dust and uninstalling Ubisoft Game Launcher (or Uplay)
  • Redownloading the game via Steam
  • Starting the game (Steam installs DirectX and Ubisoft Game Launcher)
  • As soon as "UbisoftGameLauncher.exe" appears in "\Program Files (x86)\Ubisoft\Ubisoft Game Launcher" blocking the File in the Windows Firewall or any other Firewall
  • Now choose Offline-Mode in the Ubisoft Game Launcher when starting From Dust
  • Play the Game ;)
Last edited by Pr0xima_Centauri; Nov 10, 2012 @ 10:25am
< >
Showing 1-15 of 26 comments
Arsimael Inshan Nov 10, 2012 @ 5:25pm 
Is annoying that Steam allows this...
Prima Seclorum Nov 10, 2012 @ 6:47pm 
could you be more specific in your instructions? i tried them but they didn't work. idk if i'm doing something wrong
Pr0xima_Centauri Nov 11, 2012 @ 5:43am 
Well, what exactly is your problem? Is Uplay or Ubisoft Game Launcher (UGL) being loaded when you start From Dust? It is essential that UGL starts since I couldn't find a way to get Uplay in offline mode without a login. UGL tries to update to Uplay on the first start, therefore I denied UGL internet access.
I have the german version btw. I don't know if all versions are shipped with UGL or if some were already "upgraded" to Uplay. From Dust is my first and will be my last Ubisoft game with UGL/Uplay until they drop this crap. So I don't know if my instructions interfere with other Ubisoft games.
Prima Seclorum Nov 11, 2012 @ 8:55am 
the problem is when i try to play, it takes be to the UPlay screen and i put in my loads and then says "login failed: a ubisoft service is unavailable." i sent in a ticket to them but they wont be getting back till monday.
Pr0xima_Centauri Nov 11, 2012 @ 9:23am 
Sorry, I don't see what your problem has to do with this workaround?! I tried to avoid Uplay and the Uplay account. You are using Uplay and obviously you have an Uplay account. Your problem is probably a connection problem. Either Ubisofts server are down or your Uplay can't get an internet connection (you maybe blocked Uplay in your firewall).
Prima Seclorum Nov 11, 2012 @ 9:37am 
i think its the server because when i type in a random pass/user it says "incorrect pass/user" but when I type in my own, it loads and then gives me that message.
also, when i created an account, i had to do it on ubisoft's website since the server was down earlier yesterday.
you want to know what i did? i downloaded a cracked version, i mean, if i baught it i should have my rights to play it without the means of having sh*t programming slow down my computer and inialate the fun
Celtic-Soul Dec 2, 2012 @ 4:53pm 
I just want to say that uplay is the most boring program i ever had to use to play a game i bought. I can't count how many times i've been stuck to play because of bugs from uplay.

If Ubisoft wants to impose a security program, it please make these programs work properly.

About From Dust : woooonderful game. It's a shame users can't mod it :( :( there could be so many good mods!
angry waffle Dec 15, 2012 @ 1:18pm 
i start game up doesnt work i tryed everything here and even talked to someone from uplay and still doesnt work i want a refund i think i should just let them keep the dam money and pirate the hell out this game i did buy it i just want to play it is that so much to ask
Willibald Jan 5, 2013 @ 7:11am 
Thank you very much, taurus! It works for me.

I uninstalled the game from steam and "Ubisoft game launcher" again,
and then installed the game again.
When "ubisoft game launcher" tried to connect to the internet while installation,
i declined it with my comodo firewall (what i didnt in the first installation).

Now the "Searching for game updates" screen shows up for about 10-15 Seconds
and then the different (unpatched) Launchscreen shows up
with which you can choose "start offline".

Last edited by Willibald; Jan 5, 2013 @ 7:11am
Pr0xima_Centauri Jan 5, 2013 @ 4:54pm 
I'm glad I could help :)
Fengor Jan 8, 2013 @ 4:25pm 
This is a load of crap. I tried blocking it with windows firewall and the damn thing still patched all the way up. I only bought the damned game because Ubisoft removed the DRM, but now they've put it back? Yeah they can kiss my ♥♥♥. Now if I want to play it I have to make a Uplay account (something I do not want) so I'm forced to hunt down a working crack and jump through the pain in the ♥♥♥ hoops required to get it working. ♥♥♥♥ Ubisoft, they'll never get another god damned dime out of me.
Artifice Feb 24, 2013 @ 1:21am 
I forgot to check it was ubisoft before I bought it last year, and now I'm paying for that mistake. I need to boycott them harder, apparently.
5eagles.gaming Feb 25, 2013 @ 6:07pm 
This is very annoying...If I knew this was the case when I was going to buy From Dust, I wouldn't have wasted my time...
Last edited by 5eagles.gaming; Feb 25, 2013 @ 6:08pm
Xiaolinstyle Mar 14, 2013 @ 4:49pm 
This Uplay business is why Im not going to even bother with From Dust. Steam is sufficent DRM Ubisoft is just trying to screw us (again).
< >
Showing 1-15 of 26 comments
Per page: 15 30 50

From Dust > General Discussions > Topic Details