Axiom Verge
Redax May 16, 2015 @ 2:51pm
[SOLVED] "Unable to Initialize Steam Api" After Latest Update
I bought Axiom Verge on Thursday a few hours after it came out. Played it to a little after the second boss, mostly this morning since I actually had time. When I rebooted my computer and Steam and went to play this afternoon, of course I allowed the update to install before I played, but after the update the game does not even display the title screen. After a bit of searching, I found the logfiles, so here is my output:

2015-05-16 17:12:07,601 - Creating Game.
2015-05-16 17:12:07,860 - Initializing SteamAPI.
2015-05-16 17:12:08,042 - Unable to initialize SteamAPI. Make sure Steam is running before executing the game.
2015-05-16 17:12:08,048 - Caught exception constructing THGame().
System.Exception: Unable to initialize SteamAPI. Make sure Steam is running before executing the game.
at c..ctor()
at co.a()

It does not take a developer to realize that this means that AV does not recognize that steam is started. However, the other two games I updated recently (Skyrim and Towerfall) have no issue opening or playing. And like I said, I was able to play AV before the latest update. Is anyone else having this issue? I do not usually post issues with games, but this game is so new that there is no knowledge base yet. Also, if you think I am I pirate trying to covertly get technical support for something I did not pay for, you can check my steam page. I bought the game on Thursday and even have at least one steam card for it. From what I got to play, this game is amazing, and I would love it if I could get this solved quickly so I can get back to playing. In the meantime, I'll go back to my corner of the Internet and play Skyrim.

Computer specs:

AMD A6-4400M APU with Integrated Graphics
4 GB RAM
Windows 8 64-bit x64 processor

EDIT: Fix is to re-install Steam. Must be an issue with Steam, not the game. You're still the best, Tom!
Last edited by Redax; May 17, 2015 @ 7:06am
< >
Showing 1-13 of 13 comments
Corran2010 May 16, 2015 @ 3:39pm 
Hey Well-Timed, while I'm not the dev. I have something you might to want to try. I just got the patch too and the game started up just fine for me. It's good to hear that you've had success running the game already. Due to all the recent patches, you could have had some packets download incorrectly, albiet rare. Try removing Axiom Verge, redownloading the game and trying again.
Last edited by Corran2010; May 16, 2015 @ 4:01pm
Redax May 16, 2015 @ 3:57pm 
Actually did that already, as well as verifying the game cache. Would doing it again help, do you think? It did nothing the first time. Apologies for not including that initially.
Last edited by Redax; May 16, 2015 @ 3:58pm
Corran2010 May 16, 2015 @ 5:09pm 
No worries on not sharing everything initially. It's hard to know of everything that is relevant to post on a bug. You covered the basics just fine. I'm assuming you have tried restarting already. Have you patch anything since Axiom Verge first worked for you (other than Axiom Verge)? Have you tried playing Offline vs. Online Steam?
Redax May 16, 2015 @ 6:37pm 
Restarting was the first thing I did. I was initially downloading Skyrim, stopped the Skyrim download to patch AV, then tried to start AV, and that's when the problem started. Maybe it had something to do with that? I have uninstalled and redownloaded this game twice now, once after restarting everything so that nothing else was running, to no avail. Guess I'll just have to wait for the next patch (or a new computer, it could very well be the fault of this piece of crap). Also yes, I've tried both modes, if only because before the patch I'd only really played it in offline mode. Still nothing.
Corran2010 May 16, 2015 @ 7:12pm 
I doubt it had anything to do with the download combo of Skyrim and AV since you have uninstalled and redownloaded AV twice now. There have been a lot of tweaks to AV since the release. It could have broken something that the logger isn't capturing as well.
Redax May 16, 2015 @ 7:55pm 
Yeah, that's what I thought, too. Darn.
Redax May 17, 2015 @ 6:59am 
FIXED IT! Had to re-install Steam. Should have done that earlier, but was avoiding it for obvious reasons... I have to deal with the weird way Steam detects already-downloaded content. Will probably have to redownload half my games now. Anyways, thanks for your help, Corran.
Corran2010 May 17, 2015 @ 7:39pm 
Glad to hear you got it resolved! and you're welcome!
Lignorof May 28, 2017 @ 3:56pm 
Another way to fix: start steam as admin. it worked for me at least
Ass Whoopin Nov 25, 2017 @ 2:44am 
BROS ***ANYONE WHO CANT GET IT WORKING CUZ THE MISSING STEAM FILE***
just gotta copy the files from cracked folder , then replace it with the actual game folder steam file and it works
Seamus Nov 25, 2017 @ 9:41am 
Originally posted by Ass Whoopin:
-snip-
Seriously? This is the official forum. :cfacepalm:
Last edited by Seamus; Nov 25, 2017 @ 9:41am
Redax Dec 13, 2017 @ 6:12pm 
Wow, what a doozy of a necro. If you're gonna bump an old thread maybe read it first. :happymeat:


Last edited by Redax; Dec 13, 2017 @ 6:14pm
Kibutsuji Alice Jul 2, 2019 @ 3:03am 
stream still running but it's still say Unable to Initialize Steam Api now what should i do
< >
Showing 1-13 of 13 comments
Per page: 1530 50

Date Posted: May 16, 2015 @ 2:51pm
Posts: 13