AER Memories of Old

AER Memories of Old

View Stats:
YouTube.GTuxTV Jun 23, 2018 @ 6:37am
[Linux] Black-Screen-Bug
If you try to run the game on Linux you will stuck in Loading Screen.
This is a Bug in the Unity 5.6 Engine

You can work around this bug if you change the following line in the config file of the game:
<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref> -> <pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>

But this will change back if you do anything in the settings ingame.
So the more easy thing is to set up the following steam start option for the game:
"-screen-fullscreen 0"

btw if you want to try the vulkan renderer you can force it with "-force-vulkan" but it seems to be broken so you will not have fun with it.
< >
Showing 1-15 of 22 comments
Is this fixed in the game version 1.0.4.2?
asdf Jul 7, 2018 @ 9:05pm 
Originally posted by Wurzelzweig Linux:
Is this fixed in the game version 1.0.4.2?

it is a unity bug. there are some unity games with it. try fishing planet, its free and has this bug
just use "-screen-fullscreen 0" as start option and it should work

i also have to start this game with -screen-fullscreen 0 , but then it works fine
Ghostbird Jul 16, 2018 @ 12:13pm 
Thanks a lot. This worked for me.
Just to clear up one thing I wondered about for future readers: The game WILL still run in fullscreen mode. I have no idea what the option means, but when I start it, I'll see a tiny windowed screen for about a second, and then it goes into fullscreen and works.
Otherwise, it starts immediately in full-screen and the graphics are buggy as hell. Mostly the screen stays black, and the steam overlay will leave afterimages.
Lord Derf Aug 6, 2018 @ 4:25pm 
Where is the config file?
asdf Aug 6, 2018 @ 8:42pm 
Originally posted by Lord Derf:
Where is the config file?

why? just write "-screen-fullscreen 0" in the start options
Spazzoid Aug 8, 2018 @ 4:46pm 
When I launch my game it doesn't give me an option to set the screebn size. There's nothing, just a black screen. :(
RedYarus Aug 10, 2018 @ 11:25pm 

Originally posted by asdf:
Originally posted by Lord Derf:
Where is the config file?

why? just write "-screen-fullscreen 0" in the start options

does not work, the game began to boot up but after the start of the company again black screen
Last edited by RedYarus; Aug 10, 2018 @ 11:29pm
PublicNuisance Aug 24, 2018 @ 9:42am 
Originally posted by YouTube.GTuxTV:
If you try to run the game on Linux you will stuck in Loading Screen.
This is a Bug in the Unity 5.6 Engine

You can work around this bug if you change the following line in the config file of the game:
<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref> -> <pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>

But this will change back if you do anything in the settings ingame.
So the more easy thing is to set up the following steam start option for the game:
"-screen-fullscreen 0"

btw if you want to try the vulkan renderer you can force it with "-force-vulkan" but it seems to be broken so you will not have fun with it.

Thanks for the workaround. I bought the game from Humble and encountered the bug right away. Your workaround worked for me and so far it is sticking meaning that I have only had to adjust it once and it hasn't changed back. Man Unity has gone downhill the last year or so.
arthur.lutz Sep 24, 2018 @ 5:28am 
thanks that solved it for me too
Sneaky_Koala Oct 19, 2018 @ 11:10pm 
Thanks champ - appreciate it.
grox Feb 4, 2019 @ 12:18pm 
thx 2
Wuffyhumps Mar 2, 2019 @ 7:49pm 
Devs, is this bug being fixed? Starting a game up to a black screen is NOT good!
yæqa Jun 10, 2019 @ 9:58am 
Works perfectly. Thanks.
Uno_Molto_Scarso Jun 20, 2019 @ 1:59am 
Starting a game up to a black screen for me :(
Uno_Molto_Scarso Jun 20, 2019 @ 2:25am 
I SOLVED:
I hope it can serve others, I started the game in steam play mode, the compatible one, and the game that was black screen now works, I hope someone can serve, I use ubuntu mate

< >
Showing 1-15 of 22 comments
Per page: 15 30 50