Reassembly

Reassembly

View Stats:
Reassembly > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
manylegged  [developer] Dec 3, 2014 @ 11:53pm
Bug Reporting Guidlines
Hello, Thanks for playing!

This discussion forum is a good place to report bugs. There is also a forum on the official website: http://www.anisopteragames.com/forum/viewforum.php?f=4 . Bug reports and file attachments can be emailed to arthur@anisopteragames.com.

Please including the following information:

1. Clear description of the problem - if the bug is reproducible (you can deliberately trigger the bug) please include steps to reproduce. For random bugs a description of what you were doing (flying spaceship, editing, just clicked on a certain button) will help narrow the problem.

2. A screenshot of the game if applicable: for graphics bugs, driver error popups, user interface problems, etc. http://imgur.com/ is a great place to host images.

3. A game log (especially for crash bugs, bugs with save files, and network/agent related bugs)
This log contains information about your computer and steam username but is otherwise anonymous.
Windows logs: C:/Users/<You>/Saved Games/Reassembly/data/Reassembly_log_<time>.txt
Mac logs: /Users/<You>/Library/Application Support/Reassembly/data/Reassembly_log_<time>.txt
Linux logs: ~/.local/share/Reassembly/data/Reassembly_log_<time>.txt
Additionally, the file log_latest.txt is a copy (link to) the most recent log file.

4. A save file (for bugs that are reproducible by loading a save game)
Steam save files are located in <SteamLibrary>/userdata/<long random number>/329130/remote/data/save<N>
Where <N> is 0-5 depending on the save slot. You may want to zip the directory for easier transport. Email to arthur@anisopteragames.com.

5. If the game crashes on startup, you can try running in min spec mode:
Try running the game in minspec mode:

Right click on Reassembly in the steam library view and select "Properties", then SET LAUNCH OPTIONS. Paste in "--MinSpec=1".

This will turn off all the fancy graphics options - if it works you can try turning them back on in the Options menu and see which one is causing the problem.

6. Try running the game binary directly:
Right click on Reassembly in steam, select Properties, then the "LOCAL FILES" tab, then click "BROWSE LOCAL FILES". In the win32 directory run ReassemblyRelease.exe.
If this doesn't work, try running it from the command line (CMD.EXE) - this should at least give you a couple of error messages that should help narrow down the problem.


PLEASE MAKE SURE YOUR GRAPHICS DRIVERS ARE UP TO DATE. This is a good resource: http://www.updatemyvideodrivers.com/

Finally, several 3rd party programs are known to cause crashes. Please make sure these programs are up to date or consider uninstalling them.
* MSI Nahimic (NahimicMSIDevProps.dll, Nahimic2DevProps.dll)
* PlaysTV / Raptr
* Razer Kraken and ManOWar drivers (0ManOWarDevProps.dll, 0Kraken71ChromaDevProps.dll, 0Kraken0502DevProps.dll)
* Sonic Studio 2 (installed on some ASUS machines) (SS2OSD.dll, SS2DevProps.dll)
* Steel Series headset drivers (SSAudioOSD.dll, SSAudioDevProps.dll)

You can upload your crash log and see the demangled stack trace (instead of a bunch of hex numbers) at http://www.anisopteragames.com/sync/stack_lookup.py

Thank you!
Last edited by manylegged; Oct 11, 2018 @ 3:03pm
< >
Showing 1-15 of 318 comments
AnimeGirl Dec 4, 2014 @ 2:54pm 
I tried to make an account on your forumns but the confirmation email isn't being sent so ill just have to put it here.

When i go to play the game and load a save it crashes when doing it. the game only works when i make a new game, and it only works that once. after i close that save and try to re-open it just crashes like the original.

The game was working fine yesterday before that patch to wormholes/steam logging/whatever the problem was. so i have a feeling its got to do with that.

This rar has the crashlogs, a screenshot of what the screen looks like when crashed (probably not needed), and the save file.
https://www.dropbox.com/s/tsqov5uxmmfnz76/CrashDetails.rar?dl=0

Last edited by AnimeGirl; Dec 4, 2014 @ 2:55pm
Haanz Dec 5, 2014 @ 2:36am 
same problem here, my savegames keep breaking with the latest patch.
and also still waiting for the forum confirmation email.
manylegged  [developer] Dec 5, 2014 @ 8:15am 
I manually activated both of your forum accounts - sometimes the emails get stuck in spam folders? I think they are getting sent (at least sometimes) because other people have registered in the last few days successfully.

I think I've identified the save crashing issue - it will be fixed in the next update. I'm also adding the ability to recover from somewhat broken saves by regenerating the world directly from the save slot selection screen.

This is a model bug report BTW, thanks for all the details!
(Note: This bug can be avoided all together by simply not pressing the button)

Hey guys, I've been playing your game and it's ton of fun despite being a 30$ hople in my wallet. Regardless I'd like to report a small bug I noticed in my game, I cannot garuntee that this bug is repeatable on any PC but it certainly is on mine.

When playing, simply flying around(I have not tried in edit menu) I occasionally press Mouse4 which is located on the side of my Razer DiamondBack 3G with my thumb by mistake. When this button is pressed them game seems to just simply stop, I am unable to move, the rest of the units and ai don't move non of the buttons work and the only way to stop it is to shut down the game via the task manager and start it back up. This is not the game freezing, I know this because the bloom animations and wave animations around my ship proceed to work just fine.

As a System Administrator I'm quite arawe that everything on my PC should be up to date, my Driver for GPU is one behind on it's drivers but I've noticed no issues on any other games or the general performence of your game. I would send you a picture but that'd...Be useless. There are no error logs as like I said it doesn't crash or freeze it just stops.

- Thank you for your time and please look into this as a side bug, TheGuardian.
AnimeGirl Dec 5, 2014 @ 4:11pm 
haha i wasnt aware i tried to make 2 accounts. anyways thanks. glad that your so quick to react to the bug reports :p
Haanz Dec 6, 2014 @ 7:13am 
Thanx mr manylegs, i can log into the forums now :)
I never got the mail tho (ive checked), im using a hotmail so maybe there is a problem with that?
Btw, ive found my save file at a different location of where you said, on my pc its over here Steam\userdata\25149261\329130\remote\data\save0
Well i hope the broken save bug gets fixed soon, already have withdrawel symptoms from not playing hah.
Last edited by Haanz; Dec 6, 2014 @ 12:53pm
manylegged  [developer] Dec 6, 2014 @ 3:52pm 
The Strategist - I just fixed the mouse button 4 bug, will be in the next update.

Save bug will be in the next update as well.
sharex [CZ] Dec 7, 2014 @ 5:28am 
I'm not able to build some ships since it's not possible to save them.

1) try to build this ship (a lot of missiles): http://i.imgur.com/5EVl8Nf.png
2) click save
3) see this http://i.imgur.com/NuwmJeh.png
Originally posted by manylegged:
The Strategist - I just fixed the mouse button 4 bug, will be in the next update.

Save bug will be in the next update as well.

Thank you for taking into account the last bug and fixing it, I just noticed that there was a file on my desktop reading as a crash file for the game. I recall it crashing but I can't remember why, this may be related to Mouse-4 bug or possibly other bugs, I'll gladly send you the file: {LINK REMOVED} It took me a while to notice it so sorry I can't give you much information as to what I was doing.
- Thank you for fixing the previous bug and take a look into this just in-case, TheGuardian.
The Shape Dec 13, 2014 @ 4:58pm 
me and my friend awaween found a bug involving the G key, when used in movement, and perhaps other bindings, it does nothing...as if the game doesnt recognize it being pressed, both him and I tried it.
awaween Dec 13, 2014 @ 4:59pm 
i'm used to have this keysetup: R = forwards, F = backards, D = left and G = right

however, if i change my basic buttons to this, my G-key doesn't do anything at all, wich is realy anoying, plz fix this bugg, i've talked to a friend and he had the same problem, so it isn't my computer
manylegged  [developer] Dec 14, 2014 @ 5:32pm 
Hi HSG Morgan Freeman/awaween,
I fixed the non-functional 'g' bug, will be in the next update.
Circumsoldier Dec 15, 2014 @ 5:18pm 
After the newest update to physics I have noticed ships "hitching" while rotating or move ships will stop in place and lose momentum. This happen to every ship I have try, shooting missile also stops ships. Sometimes it is so bad that ship will not even move and stay lock in place. This has never happen before december 15 update.
AnimeGirl Dec 15, 2014 @ 5:50pm 
i noticed that also circumsoldier. when you turn the ship will kinda twitch/spaz and lose some speed
Paybackwolf Dec 18, 2014 @ 9:18pm 
Hi I would like to a report bug, when i was going through a wormhole the game would not load the new world and I force quited the game and when I loaded up the same save I was presented with this http://i.imgur.com/YgzWyfZ.png?1 and when I click the game freezes. It will occasionlay revert back to normal but whenever I try to enter a wormhole the game does not respond. This is also happening to my friends game. please help. note i'm running this on mac
Last edited by Paybackwolf; Dec 19, 2014 @ 10:33pm
< >
Showing 1-15 of 318 comments
Per page: 15 30 50

Reassembly > General Discussions > Topic Details