Devil May Cry® 4 Special Edition

Devil May Cry® 4 Special Edition

View Stats:
Kingz Jun 24, 2015 @ 4:05pm
[PC - Workaround] Turning Off Blur
You can turn off blur by hex-editing the EXE file:

imgur link[i.imgur.com]

Open the exe with a hex-editor and change the name of mbGSDOF to mxGSDOF and uDOF to xDOF.

To do this you will need a hex editor, be sure to backup your exe file in case you somehow corrupt it with the editing.

EDIT:

Ok so some people are having trouble changing this so step to step would be:
1. Backup your DMC4SE exe file
2. Open the exe file inside the game folder with a HEX editor (someone linked a free hex editor on this discussion, it will work fine)
3. Once you open the exe you will see a bunch of numbers in the table form, this represents the memory locations and contents of that location in hexadecimal, on the right you have the textual description of the binary content on those locations.
4. Now you need to either use the search function or position correctly according to the image i attached, rows:
00BA0BD0 (offset may vary, but it should be around here somewhere, look at the description)
00BA2088 (offset may vary, but it should be around here somewhere, look at the description)

When you reach these rows you should see the options mbGSDOF , uDOF on the right sides in the description.

5. Click on the description on the right, select the proper character and replace it, do not use DELETE/BACKSPACE and then try to type it in, it won't work like that. Highlight the character using your mouse and type over it.

6. Once you made these changes save the executable file, if you did everything correctly it should work without any errors.

Disclaimer:
* Always backup the exe file in case you mess something up with the hex editing
* There has been a report of this changing some cutscenes in a way, not sure how since i haven't noticed anything :P

TO TURN OFF MOTION BLUR, FOLLOW THE INSTRUCTIONS AT THIS DISCUSSION:
link
Last edited by Kingz; Jun 25, 2015 @ 4:13pm
< >
Showing 1-15 of 82 comments
Fish Jun 24, 2015 @ 4:13pm 
post before and after please?
Seems to work. Thank you.
That Makuta♪ Jun 24, 2015 @ 4:20pm 
Thank you based god Kingz
Kingz Jun 24, 2015 @ 4:21pm 
I can't be arsed to download a software for screen capture, normal printscreen doesn't seem to cut it for whatever reason.

If no one posts comparison images tomorrow i will try to post some, don't have the time for it now.
Edit: The executable won't start, though it saves properly and the filesize isn't changed. Might I be doing something wrong?
Last edited by An Angry Shōnen Protagonist; Jun 24, 2015 @ 4:52pm
Sleix Jun 24, 2015 @ 5:01pm 
Originally posted by Durendal:
Edit: The executable won't start, though it saves properly and the filesize isn't changed. Might I be doing something wrong?

I got mine working flawlessly. You must have make a mistake somewhere.
Candesco Jun 24, 2015 @ 5:34pm 
Here's a hexeditor which you can use and it's called HxD. It's freeware.
http://mh-nexus.de/en/hxd/
Last edited by Candesco; Jun 24, 2015 @ 5:34pm
cjswnsdn1 Jun 24, 2015 @ 6:06pm 
You are Genius!! thanks Kingz!
Mad Chad Jun 24, 2015 @ 6:07pm 
Motion blur or the slight blur on ♥♥♥♥ing everything?
Dinjoralo Jun 24, 2015 @ 6:44pm 
It says "dof" so it's probably that slight blur on everything.
AOM Jun 24, 2015 @ 6:48pm 
Not motion blur. Motion blur is a real trouble.
Mad Chad Jun 24, 2015 @ 6:51pm 
Originally posted by KenHalo:
post before and after please?
I did some comparison shots. This appears to fix the vaseline smear.
Heres an imgur album: http://imgur.com/a/6T6pi#0
Settings
>720p
>no AA
>Super High Quality
>High textures
>Shadows: High(capped)
Last edited by Mad Chad; Jun 24, 2015 @ 6:53pm
a CriminaI Jun 24, 2015 @ 7:04pm 
Increases performance and looks better.
oomomow Jun 24, 2015 @ 7:42pm 
I think I only changed what it said to.
The "x"es are bolded right now, and the game won't start.
Citizen Fish Jun 24, 2015 @ 8:01pm 
You are a god among men for this
< >
Showing 1-15 of 82 comments
Per page: 15 30 50