Worms W.M.D

Worms W.M.D

View Stats:
Worms W.M.D > Report a Problem > Topic Details
INP | Xandaros Feb 22, 2017 @ 3:50pm
Getting the game to run on Arch Linux
Introduction
I was having a lot of issues trying to get it to run on Arch Linux, but it finally runs!
So, for anyone else having problems, I'm going to post what worked for me.
It might be different for you, depending on how your system is already setup, but it's a place to start.

Summary
I had to install libcurl-gnutls and modify the Run.sh as posted below.

The journey
Initially, the game didn't start at all, but starting the game from console revealed that I was missing libcurl-gnutls.so.4.
So I installed the package, but that didn't quite do the trick. I eventually built it myself and it worked. However, I believe this to be unnecessary. I have since reinstalled the package and it still works fine.

After that, I was able to start the game from console, but it still crashed when I tried to open it from steam. I didn't really care, though, since it seemed to work from console.
Alas, I got to hear some music and soon after it froze and eventually crashed. On some attempts I even got to see the main menu before it eventually died.

The console output seemed to reveal that it is a problem with dbus, but what exactly was going on, I had no idea.

Lots of googleing later, I finally figured out that it seems to be an issue with Arch's libdbus being too new. The solution to this problem is to preload the dbus libraries steam ships with, which is explained here.

The script you see there probably works, but I dislike how it puts everything on one line. All you really need to do is add this line to after the two export statements:
export LD_PRELOAD="$( printf "%s " ~/.steam/SteamApps/common/WormsWMD/lib/libQt5*.so* \ ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libdbus-1.so.3 \ ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libdbus-1.so.3.5.8 )"

Depending on how old or new your installation is, you might have to lowercase "SteamApps". Your game might also be installed in a different location.

The final Run.sh then looks like this:
#!/bin/bash export LC_ALL=C export LD_LIBRARY_PATH="/usr/lib:/usr/local/lib" export LD_PRELOAD="$( printf "%s " ~/.steam/SteamApps/common/WormsWMD/lib/libQt5*.so* \ ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libdbus-1.so.3 \ ~/.steam/steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libdbus-1.so.3.5.8 )" chmod a+x ./Worms\ W.M.Dx64 ./Worms\ W.M.Dx64

With this, the game should work and it even works when running through steam! \o/

If you were having trouble running the game on Arch, give this a try and maybe that works already for you. If it doesn't and you figure out the issue, please post here so we can help more people get the game running.
Last edited by INP | Xandaros; Feb 22, 2017 @ 3:51pm
< >
Showing 1-8 of 8 comments
大妖怪(>_<)=b  [developer] Feb 23, 2017 @ 4:31am 
Hats off to you :steamhappy:
±e^2πi Mar 1, 2017 @ 1:01pm 
What GPU and driver are you using? I’m on AMDGPU (mesa 13) with an RX 480. The game does start for me, but unfortunately I can’t see anything but artifacts.
INP | Xandaros Mar 2, 2017 @ 5:05am 
Nvidia GTX 650TI with the proprietary drivers.
Also tested it with a GTX 970.
±e^2πi Mar 2, 2017 @ 8:34am 
Thanks. This solution might only work for Nvidia then.
Spacesurfer May 9, 2017 @ 10:05pm 
Thank you for this! Since I'm running Mesa I found that this I also had to add "LC_ALL=C MESA_GL_VERSION_OVERRIDE=2.0COMPAT MESA_GLSL_VERSION_OVERRIDE=410 %command%" to my Launch Options in Steam. After your changes and this everything seems to work just fine. Thanks again for posting this.:steamhappy:
osgur May 12, 2017 @ 12:17pm 
Thanks a lot! Worked for me with a GTX970. Just had to use the path to my custom steamapps directory.
003n Jan 7 @ 12:09am 
THANKYOUMUCHOGRANDE:steamhappy:
MoonLS Feb 4 @ 12:08pm 
Hi
Thank you it works for me too ! But crash 10s after on the game menu.
On Arch with GTX970

Just one mistake for me:
export LD_PRELOAD="$(
printf "%s " ~/.steam/SteamApps/common/WormsWMD/lib/libQt5*.so* ...

export LD_PRELOAD="$(
printf "%s " ~/.steam/steam/SteamApps/common/WormsWMD/lib/libQt5*.so*

I need the lauch option too:
LC_ALL=C MESA_GL_VERSION_OVERRIDE=2.0COMPAT MESA_GLSL_VERSION_OVERRIDE=410 %command%

My journalctl after the crash and the very nice coredump
févr. 04 21:11:52 AGAMEMNON steam.desktop[1117]: D-Bus not built with -rdynamic so unable to print a backtrace févr. 04 21:11:52 AGAMEMNON systemd[1]: Started Process Core Dump (PID 31228/UID 0). févr. 04 21:11:55 AGAMEMNON systemd-coredump[31229]: Core file was truncated to 2147483648 bytes. févr. 04 21:11:58 AGAMEMNON systemd-coredump[31229]: Process 31005 (Worms W.M.Dx64) of user 1000 dumped core. Stack trace of thread 31012: #0 0x00007f23d282b860 n/a (n/a) févr. 04 21:11:58 AGAMEMNON steam.desktop[1117]: /home/moonls/.local/share/Steam/SteamApps/common/WormsWMD/Run.sh: line 11: 31005 Aborted (core dumped) ./Worms\ W.M.Dx64
Last edited by MoonLS; Feb 4 @ 12:19pm
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Worms W.M.D > Report a Problem > Topic Details