STAR WARS™: The Force Unleashed™ II

STAR WARS™: The Force Unleashed™ II

View Stats:
The Vogel Dec 7, 2012 @ 6:32am
Error in Gorog Fight?
When I fight the Gorog and am at the situation where I have to open this metal plate on its head... At the third lock, I follow the button-instruction correctly as displayed, but the game does not seem to realize it. I get the message that I faild to press the correct buttons (those rex X'es above the displayed buttons) and the fight starts over....

I tried it with an 360 Controller and also with Keyboard/Mouse....

Does anyone have the same error, or know how to fix it?
< >
Showing 1-2 of 2 comments
I do have the same error here... I tried holding and smashing the shock button and it always fails... iam stucked
Last edited by ☭Vladimir Lenin☭; May 3, 2015 @ 8:01pm
This was effectively the end of the game for me for a long time, as I had no way past the bugs.

Some things glitch or don't register if you use a kb. Others don't register if you use a pad. My "solution" to this has been to pause the game and unplug/plug in the controller for different parts of the Gorog battle and just live with the way that about 30% of the time it CtDs and you have to start again, still this means the battle can be done at all, and if you have this problem you are probably used to doing it over, and over, and over again.
Last edited by Uhtred son of Uhtred; May 25, 2015 @ 4:48am
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Dec 7, 2012 @ 6:32am
Posts: 2