TOXIKK
TOXIKK > General Discussions > Topic Details
corpse Sep 13, 2016 @ 2:47pm
LAN and Friend joining connection issues
Was able to play LAN games with my bro no problem in early access but now since the game launched I am unable to create a game with mutators and have him connect to me. Everytime he pushes the refresh button by trying to join by lobby it crashes the host's game.

So we tried to do an online multiplayer game with password protection. Server not showing up.

Just to update it...anyone else having issues hosting lan or multiplayer games? Would like a help in the right direction for a solution, unless its a bug or issue on the other end.
Last edited by corpse; Sep 14, 2016 @ 9:11pm
< >
Showing 1-15 of 21 comments
corpse Sep 14, 2016 @ 9:11pm 
Issue is still happening I'm afraid this post got lost. We both own full versions of the game.
Last edited by corpse; Sep 14, 2016 @ 9:12pm
hundredeir Sep 14, 2016 @ 9:34pm 
hmmm, I can try hosting a game and then try it
I'm having a similar problem. Did the port forwarding but no luck. My friends can see the server but when they try to join it goes into a loop until their game crashes or they get an error telling them they couldn't connect. We can all join official servers with no trouble.

Playing private custom servers was the reason I bought the 4 pack and while we still have fun playing, it loses steam fairly quickly when we can't customize it because we're not in control of the server. Just disappointing.
bothered Sep 15, 2016 @ 12:16am 
I have literally just posted a thread with this same problem. We turned the mutators off and all was fine.
Equim Sep 15, 2016 @ 12:29am 
Just throwing this link here with a similar post on the official forums which is preferred when it comes to support from the devs. Easier for them to follow and monitor what is going on than over here.

http://forum.toxikk.com/viewtopic.php?f=11&t=4000&sid=70dbc46b6701080685d0b2067c39ff6b
@That Cat: I've done everything I can think of and everything I've seen suggested as to port forwarding. I got it from not being able to see or join my server to seeing but not being able to join. I may be wrong but one of the things that makes me think it's not a port forwarding issue is that when they try to join it never asks them for the password for the server. Which to me makes it seem like the game is doing something wrong when making the server. I tried creating an external dedicated server and everyone could join but each persons game would crash after they started moving around on the server.

@bothered: I have not attempted to use any mutators at all so that doesn't seem to be one of my issues yet.

@Equim: I appreciate the attempt but I've already looked all over the official forums as well. I'll keep looking and if I find anything I'll pass it on to anyone who needs the help. Right now it would just be nice if it worked.
Last edited by Civ 105 | Sados Staff | Dev; Sep 15, 2016 @ 12:48am
PredatH0r Sep 15, 2016 @ 2:03am 
Portforwarding is needed for internet game hosting.

For local (and internet) hosting you also need to make sure to open the ports in the windows firewall. UDP 7777 and 27015. Normally, when toxikk starts the first time, you are asked by windows firewall whether you want to allow the game to open ports.
If you have any 3rd party firewall software, like Comodo or some sort of "Total Security" Antivirus package, you may have to open the ports there too.

This solves the vast majority of connection issues.
Today I tried port forwarding again, no luck. I even tried forwarding all ports (with DMZ) and still no luck. Unless players have to forward ports to play private servers (not just the host) it has to be an issue with the game.
Last edited by Civ 105 | Sados Staff | Dev; Sep 15, 2016 @ 10:15pm
corpse Sep 15, 2016 @ 11:10pm 
well I figured out that much because when my bro pushed that refresh button while I was host it crashed my game. :P first time ever had that happen to me in a game.
Last edited by corpse; Sep 15, 2016 @ 11:10pm
Agreed. Between this issue stopping us from playing privately and the rampant "hackers" ruining the official servers my friends have already given up... I'm sure I can get them back on board but it has to be private servers at this point. Which only works if I can get the game to let people join.
I didn't do anything with my modem because nmap said my ports were open.
corpse Sep 26, 2016 @ 9:45pm 
Any news on this being fixed with recent patch or we still in the dark? Haven't tested it out yet with the recent patch will do later.
Tested after last patch and had no luck. I haven't tried since yesterdays patch but I will soon. Let me know if you have any luck.
corpse Sep 26, 2016 @ 9:50pm 
will do. Something got messed up in the code when they were preparing the game for official launch. Hope nothing wrong with the network code for LAN games. Such a weird issue.
corpse Nov 12, 2016 @ 1:25pm 
this update fixes the problem yet? Tired recently before patch still no go!
< >
Showing 1-15 of 21 comments
Per page: 15 30 50

TOXIKK > General Discussions > Topic Details