Monkey Island 2: Special Edition

Monkey Island 2: Special Edition

View Stats:
krovikan Aug 4, 2018 @ 8:41am
[SOLVED] Game no have sound
I had played in February and I have all type of sounds. Now, no sound at menu game, no music sound in the game.

What's is happening with sound? (M1 SE have identical issue)

I use Steam with Wine at my Linux OS.

SOLUTION:
For Monkey 1 SE override XAudio2_4 to "Native (Windows)".
For Monkey 2 SE override XAudio2_6 to "Native (Windows)".
Last edited by krovikan; Aug 11, 2018 @ 3:10am
< >
Showing 1-8 of 8 comments
Overkill Lee Aug 4, 2018 @ 11:50am 
The problem is on your end, the sound works perfectly fine mate. I fix computers for a living, if you need help add me on steam.
krovikan Aug 4, 2018 @ 1:41pm 
The hardware of my computer is the same to the February.
The only change is the OS (major update of openSUSE).
Overkill Lee Aug 4, 2018 @ 1:42pm 
It can be anything causing it, the problem is defo on your end.
krovikan Aug 4, 2018 @ 2:49pm 
The solution for Monkey 1 is override xaudio2_4 to Native (windows).

For Monkey 2 I can't find solution, yet.
Overkill Lee Aug 4, 2018 @ 2:56pm 
What Windows are you using mate? Are you using a soundcard or onboard audio? The audio is fine for me on both games.
Last edited by Overkill Lee; Aug 4, 2018 @ 2:56pm
krovikan Aug 4, 2018 @ 3:01pm 
openSUSE Leap 15 (is a Linux OS) and have the audio fine before. But something in the install of Leap 15 leave me with no audio (solved en MI 1 SE only, for now).
Last edited by krovikan; Aug 4, 2018 @ 3:01pm
Overkill Lee Aug 4, 2018 @ 3:18pm 
Ah ok, Linux is prob part of the issue then, I use Windows and always have done. Linux is just not popular enough I guess so they don't put that much effort in to make things work correctly. Works fine on Win 7, 10 and even worked fine on Vista back when I had it on.
krovikan Aug 11, 2018 @ 3:00am 
Reading again the first post of https://bugs.winehq.org/show_bug.cgi?id=21097#c0 where I can find the solution to Monkey SE 1, it has made me think "if the soultion was the same or very similar...?".

I look in the subdirectories of the two games and in the installer's subdirectory I could see cabinets files (.CAB) with the name XAudio.

For Monkey 1 SE I could see inside XAudio.CAB the file Xaudio2_3.dll (runs ok the Monkey 1 SE with override to native XAudio2_4, yes 2_4 not 2_3).

For Monkey 2 SE I could see inside XAudio.CAB the file Xaudio2_6.dll and I think "If I add a override to Native for XAudio2_6 ...?"

Bingo! With the XAudio2_6 override to "Native (Windows)" I have sound again in Monkey Island 2 SE. :dentures:

Problem is solved!!

PS: Sorry for my English
< >
Showing 1-8 of 8 comments
Per page: 15 30 50