STAR WARS™ Jedi Knight: Mysteries of the Sith™

STAR WARS™ Jedi Knight: Mysteries of the Sith™

View Stats:
WilhelmScreams Nov 11, 2013 @ 7:45pm
Says to Insert Disk...steam plz..
Anyone know how I fix this
< >
Showing 1-15 of 23 comments
Rahm Kota Nov 12, 2013 @ 5:19am 
The same problem occured with my Dark Force II game bought via Steam.
Fortunately somebody on the forum pointed out what was wrong with the game.
I quote:
======================================
"Here's a fix for all Windows 8 users whose game simply doesn't launch :

Go to your Steam folder, and from there, go to :

"...\steamapps\common\Star Wars Jedi Knight" for Jedi Knight
"...\steamapps\common\Jedi Knight Mysteries of the Sith" for MotS

For Jedi Knight delete the Jedi.EXE file that you'll find there.
For MotS delete the Sith.EXE file that you'll find there.

Then you must change the compatibility settings for JK.EXE (for Jedi Knight) and JKM.EXE (for MotS to Windows XP (Service Pack 3).

To do this, right-click the file, then click "Troubleshoot compatibility". Select "Try recommended settings". Windows should now automatically set the compatibility to Windows XP SP3.

You will then be asked to test the program before closing the window. Both games should now run normally. You're welcome."
======================================
Just moments after I applied that fix, I saw the opening cutscene of Dark Forces II.

I'm hoping this'll help you.
WilhelmScreams Nov 12, 2013 @ 2:02pm 
Im still on Vista... lol But all other games work. Have no Problem with Dark forces 2

I dont have the option to try recommended settings but I tried running it in all the compatibility modes thats it offered.

Still no Dice
Thanks anyways !
Cap10wow Jan 18, 2014 @ 2:55am 
once i delete the sith.EXE file and launch game i get a window that says "Insert the Mysteries of the Sith CD and press Enter" any ideas on how to fix this? PLZ
Ajax Jan 18, 2014 @ 1:35pm 
I have the same problem. Dark Forces II: Jedi Knight launches, but Mysteries of the Sith will not.
Tomix Mar 11, 2014 @ 10:09am 
Same to me. So anyone knows how to fix it? Because we've just paid for the game to play, not to fix errors.
Ma77i7yahu Mar 15, 2014 @ 2:19am 
Can confirm that Rahm Kota's suggestion worked for me.
Last edited by Ma77i7yahu; Mar 15, 2014 @ 2:57am
Cap10wow Mar 16, 2014 @ 12:08pm 
still not working for me
Tomix Mar 19, 2014 @ 9:44am 
Same here.It might be because I'm using windows 7, but I've tried everything and nothing happened.
Raell May 4, 2014 @ 8:49am 
Go into the .exe and set it to run on an early version of windows under the compatability mode.
astroninja May 5, 2014 @ 9:00am 
Originally posted by Athega:
Can confirm that Rahm Kota's suggestion worked for me.
this, it worked for me for both games
GabbaMan May 5, 2014 @ 11:36am 
game still want CD ... this " fix " is for compatibility issue...not for " CD problem " ...
OhCollusion May 5, 2014 @ 1:09pm 
Yes same issue here the fix everyone is saying to do just fixes the color error issue and some compatability issues. What is happening here is the game is asking for a CD at startup and cannot get around it. There is no way to type in a cd key or anything just insert a a physical disk. Im going to try a renistall and see what happens.
OhCollusion May 5, 2014 @ 1:20pm 
Okay I found a solution to this problem. My laptop does not have a disk drive so I thought that might have been the issue, I did not have any virtual drives installed either so I tried installing daemon tools to see what would happen and it worked. Just install the free version of daemon tools and just let the game think you have a cd drive and the game should run.
GabbaMan May 5, 2014 @ 1:37pm 
Originally posted by OhCollusion:
Yes same issue here the fix everyone is saying to do just fixes the color error issue and some compatability issues. What is happening here is the game is asking for a CD at startup and cannot get around it. There is no way to type in a cd key or anything just insert a a physical disk. Im going to try a renistall and see what happens.

Ok, I can admitt that after this tip game finally runs. http://steamcommunity.com/sharedfiles/filedetails/?id=241209118

I have downloaded two files for Win 7:

1) JKM_Pre-Steam_Release_EXE.7z ( unpack it to the game folder - replace it with the original one )

2) MotSUnofficialPatch-NoCD_2007-09-08.zip ( unpack and copy to the same exact game folder and run "patcher.exe". It will patch JKM.EXE.

Run Game from steam. Cut scenes lounch ( on my PC ) in window but game runs in Full screen mode. Importand thing is that optimum resolution is 1024*768 (software mode) coz when I'm trying to set 3D with / or higher resolution game crashes or return to the standard settings. When you start the game you will probably see funny 8 bit colour, just use " force " ( Q, E + F ) and screen will get back to original 256 colour state. Same " bug " with 8 bit colour is in the dark forces II, and game returns to the 256 colour state when some enemy hit you with the blaster. That is my tip, not the best but game runs quite good. Use verry often F9 (quick save) because game crash some times.

Last edited by GabbaMan; May 5, 2014 @ 1:38pm
< >
Showing 1-15 of 23 comments
Per page: 15 30 50