STAR WARS™ Jedi Knight: Dark Forces II

STAR WARS™ Jedi Knight: Dark Forces II

View Stats:
LanceSEELot Mar 4, 2017 @ 11:44am
How to FIX / MOD the damn game! [Including Files]
***TESTED ON WINDOWS 10 PROFESSIONNAL 64BITS, NVIDIA VIDEOCARD***

Took me a while to figure it out so I guess I might as well upload this for others to use. Those are all the required files to run the game properly. It includes the higher res textures, model and hud. That is all, nothing else. (Unofficial patch is here too no worries.)

DO USE THE INSTALLATION INSTRUCTIONS. You have been warned.

Files can be aquired from my mediafire page.

Files: /http://www.mediafire.com/file/vylcc275c2mzh6u/JK2-2017.7z

Remove the first " / "

I do not take credits for any of those mods. All thanks to the mods authors.

NOTE: I forgot a step in the instructions. Set the shortcut in compatibility mode for Windows XP SP2.
Last edited by LanceSEELot; Jun 1, 2017 @ 7:05am
< >
Showing 1-11 of 11 comments
Cecinho Apr 25, 2017 @ 10:53am 
Thanks. This worked perfectly.
Also, if you're using Win 8.1 you don't need to use -windowgui. And I got it to work only when I removed the "jedi.exe" from the folder.
On of the mods, the one that changes the textures and models, is glitchy. I get huge parts of the scenario with no textures at all, which makes them completely white.

Other than that, the game is working perfectly. Thanks!
Cthulhu's Prophet May 31, 2017 @ 5:26am 
This crashed the main .exe when I launched through steam (Win7). When I launched through shortcut, all was fine until game start (post cutscene) when the game informed me that my video card does not have the required memory to run and to set to lower resolution. Assumed this was because of AMD compatibility issues, downloaded Voodoo 2 thingy, ran it, replaced .dll files and it now runs perfectly, so anyone with the same problem should go here: https://pcgamingwiki.com/wiki/Star_Wars:_Jedi_Knight_%E2%80%93_Dark_Forces_II#3D_Acceleration_problems and follow instuctions under "3D accelerator problems"

Thanks Lancelot, just spent 4 hrs trying to get it to work before stumbling on to your post.... Off to Nar Shaddar for me now!!

EDIT: Oh the pain!!! Though this workaround has allowed me to play with steam overlay and controller (which was my main objective in patching this game, I have carpal tunnel syndrom and can't use a mouse) - it has deactivated all the juicy graphics mods. Lancelot, do you know of a way of getting the best of both worlds?
Last edited by Cthulhu's Prophet; May 31, 2017 @ 5:49am
LanceSEELot May 31, 2017 @ 5:57am 
Originally posted by Cthulhu's Prophet:
This crashed the main .exe when I launched through steam (Win7). When I launched through shortcut, all was fine until game start (post cutscene) when the game informed me that my video card does not have the required memory to run and to set to lower resolution. Assumed this was because of AMD compatibility issues, downloaded Voodoo 2 thingy, ran it, replaced .dll files and it now runs perfectly, so anyone with the same problem should go here: https://pcgamingwiki.com/wiki/Star_Wars:_Jedi_Knight_%E2%80%93_Dark_Forces_II#3D_Acceleration_problems and follow instuctions under "3D accelerator problems"

Thanks Lancelot, just spent 4 hrs trying to get it to work before stumbling on to your post.... Off to Nar Shaddar for me now!!

EDIT: Oh the pain!!! Though this workaround has allowed me to play with steam overlay and controller (which was my main objective in patching this game, I have carpal tunnel syndrom and can't use a mouse) - it has deactivated all the juicy graphics mods. Lancelot, do you know of a way of getting the best of both worlds?
Wish I could help for the controller thing. Maybe try a controller remapper like xpadder or joy2key.

But you have to disable the overlay. It causes a lot of issues.
Thanks I've worked around it by launching out of steam and using a modified base desktop config for the controller and it works great... However, just got the lightsaber, andit was fine at first, but when I reloaded a game it appears to have glitched out and is displayed in a way I can only call fat, no pictures but think "lightsaber-length-telephone-pole". I 've tried to reload the game, level etc. but no luck... Any ideas? (other than this the game runs perfectly)
LanceSEELot Jun 1, 2017 @ 5:57am 
Originally posted by Cthulhu's Prophet:
Thanks I've worked around it by launching out of steam and using a modified base desktop config for the controller and it works great... However, just got the lightsaber, andit was fine at first, but when I reloaded a game it appears to have glitched out and is displayed in a way I can only call fat, no pictures but think "lightsaber-length-telephone-pole". I 've tried to reload the game, level etc. but no luck... Any ideas? (other than this the game runs perfectly)
I'd really love to help. But sadly the game is so old that it is very hard to pin point the issue. It works flawless on my end but thats maybe because im using an Nvidia videocard. Wich, honestly, is way more adapted to retrogaming due to its superior compatibility with older version of opengl.

The workarounds for AMD are different and I ain't really familiar with them. So I doubt I'd have anything more to say than the guides that already are online.
Ok, no worries man, thanks a bunch, take care!
LanceSEELot Jun 3, 2017 @ 6:10am 
Originally posted by Cthulhu's Prophet:
Ok, no worries man, thanks a bunch, take care!
Good luck and if you find a solution. Drop a reply here. Gotta help eachother out in this mess. Damn early direct3d games are a ♥♥♥♥♥ to run.
BonzoJon Jun 4, 2017 @ 11:30am 
Originally posted by Cthulhu's Prophet:
This crashed the main .exe when I launched through steam (Win7). When I launched through shortcut, all was fine until game start (post cutscene) when the game informed me that my video card does not have the required memory to run and to set to lower resolution. Assumed this was because of AMD compatibility issues, downloaded Voodoo 2 thingy, ran it, replaced .dll files and it now runs perfectly, so anyone with the same problem should go here: https://pcgamingwiki.com/wiki/Star_Wars:_Jedi_Knight_%E2%80%93_Dark_Forces_II#3D_Acceleration_problems and follow instuctions under "3D accelerator problems"

Thanks Lancelot, just spent 4 hrs trying to get it to work before stumbling on to your post.... Off to Nar Shaddar for me now!!

EDIT: Oh the pain!!! Though this workaround has allowed me to play with steam overlay and controller (which was my main objective in patching this game, I have carpal tunnel syndrom and can't use a mouse) - it has deactivated all the juicy graphics mods. Lancelot, do you know of a way of getting the best of both worlds?


I was able to get it working in Steam on AMD Hardware (HD 7970)!!

I did everything as the OP listed above following all the steps.

I then downloaded the Voodoo2 wrapper here:

http://www.jkhub.net/project/show.php?projid=756&section=downloads

I copied JUST the dll files from the zip file into the Jedi Knight installation folder.

I then ran dgVoodoo from the JK installation folder. I selected Other Greater (free to configure) on the Glide tab selecting 128MB of ram. I also selected ATI Radeon 8500 with 64MB Vram on the DirectX tab.

Next clicked on properties for Jedi Knight in Steam. I clicked on Set Launch Options and added -path Mod.

From here I was able to launch JK2 from Steam with the graphics mods working.

Hope this helps!!!
JamestheFreak Jun 4, 2017 @ 12:10pm 
So is there some bugs or something that makes the game unplayable? I just started it and did the first level and the only thing I noticed are how the graphics are glitchy, everything has weird white spots and the Hud is kinda hard to read from it. Its annoying but doesn't make the game unplayable, so far.
Last edited by JamestheFreak; Jun 4, 2017 @ 12:12pm
LanceSEELot Jun 4, 2017 @ 5:13pm 
Originally posted by JamestheFreak:
So is there some bugs or something that makes the game unplayable? I just started it and did the first level and the only thing I noticed are how the graphics are glitchy, everything has weird white spots and the Hud is kinda hard to read from it. Its annoying but doesn't make the game unplayable, so far.
Try turning on 3d acceleration and youll see the problem.
Sigma Jun 7, 2017 @ 2:19am 
-HOT TO INSTALL-
< >
Showing 1-11 of 11 comments
Per page: 15 30 50