Trine 3: The Artifacts of Power

Trine 3: The Artifacts of Power

View Stats:
JohnnyGui Apr 21, 2016 @ 8:21am
Annoying bug on Home Screen
Hello,

For some reason, when launching the game and it gets to the Home screen (after loading) where it says "Click to start", it'd still show the Windows cursor which doesn't work when I click the "Click to start" prompt. I'd have to wait until the cursor spontaneously turns into the game cursor (the circle shaped one) so that I can click to start and open up the Main menu screen. This usually takes about 20 seconds.

Windows 8.1 x64
GTX 660Ti with latest drivers
i5-3570K
8GB RAM

How to fix this?
< >
Showing 1-4 of 4 comments
JohnnyGui Apr 22, 2016 @ 6:36am 
There's something else that I noticed while the cursor stays as a standard Windows cursor for some time. I also can't seem to move the character with the keyboard at the Home screen. As soon as the cursor turns into the ingame one, I can move the character.

It is as if the game is running in the background and I have another program open (I don't) until it realises (after 20 seconds or so as mentioned before) that the game should be the main active program.
MarjutFB  [developer] May 11, 2016 @ 1:14am 
Sorry for the delay! There has been a lot of messages to go through.

This issue sounds strange, but here is a couple things you could try to do:

1. Close Other Programs
Please check that you don't have any programs on that you don't need, just in case these might be resulting the delay.

2. Try Windowed Mode
The option for this is located just below the “Screen resolution and refresh rate” text in the game's Launcher.

3. Disable Additional Controllers
If you have any additional controllers connected to your computer, please try if disabling them would help. Note that also drawing tablets are often counted as controllers.

4. Delete Options.txt
I don't know if this will help, but you can use this method to reset the game's settings. You can find the file's folder by pasting the following to your Windows Explorer: %appdata%/Trine3

After deleting the file you can just open the game normally, but note that you might have to set some settings again like the correct resolution.


Unfortunately I don't think I have other suggestions. Twenty seconds isn't ridiculously long, and because we haven't managed to reproduce this, I don't think we can do anything about this. This could also be caused by your keyboards drivers – for example many gaming keyboards use different profiles for each game which might be causing the delay.

I'm sorry for the inconvenience, but hopefully this helped. Cheers!
Last edited by MarjutFB; May 11, 2016 @ 1:16am
JohnnyGui May 20, 2016 @ 7:57am 
Originally posted by MarjutFB:
Sorry for the delay! There has been a lot of messages to go through.

This issue sounds strange, but here is a couple things you could try to do:

1. Close Other Programs
Please check that you don't have any programs on that you don't need, just in case these might be resulting the delay.

2. Try Windowed Mode
The option for this is located just below the “Screen resolution and refresh rate” text in the game's Launcher.

3. Disable Additional Controllers
If you have any additional controllers connected to your computer, please try if disabling them would help. Note that also drawing tablets are often counted as controllers.

4. Delete Options.txt
I don't know if this will help, but you can use this method to reset the game's settings. You can find the file's folder by pasting the following to your Windows Explorer: %appdata%/Trine3

After deleting the file you can just open the game normally, but note that you might have to set some settings again like the correct resolution.


Unfortunately I don't think I have other suggestions. Twenty seconds isn't ridiculously long, and because we haven't managed to reproduce this, I don't think we can do anything about this. This could also be caused by your keyboards drivers – for example many gaming keyboards use different profiles for each game which might be causing the delay.

I'm sorry for the inconvenience, but hopefully this helped. Cheers!

Thanks a lot for the extensive reply! For some reason this bug magically vanished on every game launch until I finished the game. Don't know what solved it.
Last edited by JohnnyGui; May 20, 2016 @ 7:58am
MarjutFB  [developer] May 23, 2016 @ 11:59pm 
Originally posted by JohnnyGui:
Thanks a lot for the extensive reply! For some reason this bug magically vanished on every game launch until I finished the game. Don't know what solved it.

That's really strange, but I'm glad to hear the game works now. Feel free to write here if the bug magically appears again, but let's hope it won't.

Cheers!
< >
Showing 1-4 of 4 comments
Per page: 15 30 50