Chaos Reborn

Chaos Reborn

View Stats:
Chaos Reborn > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
Cercallunes Sep 9, 2017 @ 11:24am
No graphics on Linux, just a black screen
I have been a few months without playing Chaos Reborn but since I bought it I have happily played more than a hundred of hours on my Ubuntu 14.04LTS... Today all I get when I launch it is a black screen. Well, the audio works fine but there is no graphics.

I did not change my graphics card nor the drivers and I know there was an update for the game a few weeks ago, so I think it could be related this issue.

No one else have problems to run CR on a Linux machine?
< >
Showing 1-15 of 17 comments
RafiRomero Sep 11, 2017 @ 2:19am 
There is some discussion of this, and some suggested workarounds here:
Unfortunately, the developers have not released a patch yet that addresses the issue itself:(
Cercallunes Sep 13, 2017 @ 10:05am 
Thank you RafiRomero, I did a quick search before write my post but I missed this one... :-S
RafiRomero Sep 14, 2017 @ 2:47am 
Do you have a workaround for this now, then?
Narf reported that using the
switch and running in windowed mode allows him to play (then manually switch to fullscreen, I think).
Holding ALT, SHIFT, or CTRL during statup also forces this screen selection dilaog (I can't remember which, sorry; all 3 work in windows, I don't think all 3 work in Linux).
Cercallunes Sep 14, 2017 @ 1:16pm 
None of these keyboard keys work for me.

But I added "-show-screen-selector" as a parameter in the set launch options box for the game properties window on the Steam games library and it works fine. From there you can set the desired resolution and mark the windowed mode. Then the game launches fine (even at 1920x1080) and after that you can turn on the full screen mode again, from the video section of the game preferences in the main menu.

The only problem is that you have to do this way every time you launch the game. I tried to directly set the resolution and the windowed mode as parameters in the set launch options box mentioned before: I did as indicated in this Setting Game Launch Options article of Steam Support, but it doesn't work. I suppose it only works for games developed or published by Valve (but I tried anyway, just in case...).

I see this problem was reported more than a month ago so I imagine it still will take time until developers can solve it... So, It would be nice to pin a post explaining this workaround step by step for any returning Linux player like me... What do you think RafiRomero?

Thanks again for your help! :-)
Last edited by Cercallunes; Sep 14, 2017 @ 1:22pm
RafiRomero Sep 15, 2017 @ 6:16am 
Hi, I pinned this.

Have you tried the:
thing instead of -show-screen-selector?

This works in Windows and allows you to run a maximized borderless window, in Windows it's actually a little better than full-screen for me, as it doesn't minimise if I click a different monitor.

The other thing you might do is grab copies of:
~/.config/unity3d/Snapshot Games Inc./
~/.config/unity3d/Snapshot Games Inc_/
(if you have both - you probably don't need both, whatever is most recent is probably good)
I can try copying your config file over mine and see if I have the same problem.
Cercallunes Sep 20, 2017 @ 12:30pm 
Hi again RafiRomero!

I'm sorry for answering so late. I took a quick look to your last post from the phone on my way to work and after that I completely forgot about it. Thanks for the pin!!

About the "-popupwindow" parameter, it does not work for me, but I have solved with the "prefs" files... Like Narf here

So, yes, there are two folders:

"~/.config/unity3d/Snapshot Games Inc./"


"~/.config/unity3d/Snapshot Games Inc_/"

Inside both of them you can find a folder for Chaos Reborn and again in both cases there is a "prefs" file you can read and edit with any plain text editor.

For the prefs file which is in the first directory mentioned (the one with the dot at the end), you find these prefferences and values (line 55 to 57 in my case):

<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>
<pref name="Screenmanager Resolution Height" type="int">1080</pref>
<pref name="Screenmanager Resolution Width" type="int">1920</pref>

*(Obviously, I assume the height and width resolution values will differ for other players with other default resolutions for their monitors...)

In this first file I have tried to set the "Screenmanager Is Fullscreen mode" to 0 and it doesn't work, but for the prefs file in the other folder (the one with the underscore at the end) I have found the width and height values set to 0. So, the three same prefferences where like this:

<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>
<pref name="Screenmanager Resolution Height" type="int">0</pref>
<pref name="Screenmanager Resolution Width" type="int">0</pref>

Again, here I have set to 0 the one for the fullscreen mode and I have set the height and the width value with the ones of my screen resolution and it works. With this, the game launches fine for me and I can return to fullscreen mode from the video section of the main menu with no problems.

What I have not done is to delete the directory for the prefs file that seems to take no effect... Before opening any of them, the last acces date was the same for the two directories and in the one with the dot at the end there are two more subfolders (one called "OfflineData" and one called "Unity") with several files, but they are not present in the other directory whith the underscore at the end. There I have only the "prefs" file and a "Player.log" file. Do you mean the one with the dot it is not needed?
Last edited by Cercallunes; Sep 29, 2017 @ 4:16pm
RafiRomero Sep 21, 2017 @ 7:01am 
So, is this permanently fixed now?
Once you have the game started, if you exit the game in fullscreen mode, can you launch it again without any problems (without having to re-edit these files)?

The "OfflineData" folder, FYI, stores information about progress in the Single Player Campaign.
Cercallunes Sep 21, 2017 @ 1:01pm 
Yes, the change I made in the prefs file is persistent and you do not have to re-edit. The game launches fine, just that you still have to turn on the fullscreen mode from the main menu.

Thanks again for your help RafiRomero.
LMnet Nov 6, 2017 @ 3:03am 
I have the same issue with the black screen. Options `-show-screen-selector` and `-popupwindow` did not work for me. I manually changed `prefs` file and set this options:

<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
<pref name="Screenmanager Resolution Height" type="int">1440</pref>
<pref name="Screenmanager Resolution Width" type="int">2560</pref>

And now the game works. But, only in windowed mode. Also, I have 2 monitors, maybe it somehow affects the problem?
Interesting moment: if I set up fullscreen option from the game - all works fine.
Last edited by LMnet; Nov 6, 2017 @ 3:05am
Beeze Nov 19, 2017 @ 5:29am 
In launch options, "-show-screen-selector" and selecting windowed mode worked for me. OS; Debian testing buster...
Cxpher Nov 27, 2017 @ 8:07am 
Definitely a bug. Seems that setting fullscreen in game resets the prefs file to 1 for fullscreen and 0 0 for height and width respectively.

Workaround is to launch with screen selector showing every time and selecting Windowed mode and then changing to fullscreen in game.

Devs : FYI.
nkc Dec 16, 2017 @ 1:16am 
The problem still actual after the latest update. Prefs workaround works but not for the full screen. If it is set to 1, the game resets screen sizes to zero on exit.
Offtopic: is there a launch option that skips intro and starts multiplayer mode? If not, could we have one?
wardrobe Dec 19, 2017 @ 8:32am 
yup black screen
adding '-show-screen-selector' and using windowed mode worked for me on steamos
nkc Feb 3 @ 9:55am 
Instead of -show-screen-selector, edit prefs file and use borderless window, make it overlap everything on desktop. You can do that in KDE with few clicks. Works like charm.
< >
Showing 1-15 of 17 comments
Per page: 15 30 50

Chaos Reborn > General Discussions > Topic Details