Chaos Reborn

Chaos Reborn

View Stats:
Chaos Reborn > General Discussions > Topic Details
rasaar Aug 9, 2017 @ 9:02am
Cannot run in Linux after last update
Chaos updated today and I wen't to see what's new. Unfortunately the game only shows a black empty screen. Mouse cursor is visible and music is running. Steam overlay leaves a graphical smudge at the low right corner. I could run the earlier versions without a problem except the occasional invisible text bug.
< >
Showing 1-15 of 25 comments
RafiRomero Aug 9, 2017 @ 9:07am 
Thanks for reporting this, I've passed this on to the developers.
RafiRomero Aug 9, 2017 @ 9:29am 
Not sure if you are aware of this/ if it helps:

I'll check my own Linux computer later this evening.
rasaar Aug 9, 2017 @ 10:07am 
Thanks RafiRomero for the info. Unfortunately that did not solve the problem.
Narf Aug 9, 2017 @ 11:20am 
Same situation as OP.

jemalloc work-around doesn't help. I even tried it on all three of steam, ChaosReborn.x86 and ChaosReborn.x86_64 binaries.

I see no way to revert updates ... or is there?
MáDKínG Aug 9, 2017 @ 11:38am 
yeah can confirm this, it's broken now ...

and why are there 2 folders in ~/.config/unity3d

1. 'Snapshot Games Inc.'
2. 'Snapshot Games Inc_'

I tried also with a clean user config and deleted them, no change.

Player.log looks ok....just the last part <snipped>
Desktop is 2560 x 1440 @ 59 Hz Unloading 6 Unused Serialized files (Serialized files now loaded: 0) UnloadTime: 5.116000 ms Unloading 25 unused Assets to reduce memory usage. Loaded Objects now: 4154. Total: 4.869000 ms (FindLiveObjects: 0.142000 ms CreateObjectMapping: 0.083000 ms MarkObjects: 3.017000 ms DeleteObjects: 1.626000 ms) Material seeker_bolt_sparks_02 doesn't have _Stencil property (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) Material seeker_bolt_sparks_02 doesn't have _Stencil property (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) Material seeker_bolt_sparks_02 doesn't have _Stencil property (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) requesting resize 0 x 0 requesting fullscreen 0 x 0 at 59 Hz Desktop is 2560 x 1440 @ 59 Hz Setting up 4 worker threads for Enlighten. Thread -> id: 7fb507bff700 -> priority: 1 Thread -> id: 7fb5073fe700 -> priority: 1 Thread -> id: 7fb5063fc700 -> priority: 1 Thread -> id: 7fb506bfd700 -> priority: 1
Last edited by MáDKínG; Aug 9, 2017 @ 11:53am
RafiRomero Aug 9, 2017 @ 12:16pm 
I don't think you can revert on Steam.
The developers should be looking at this tomorrow.
I *think* if you hold CTRL or SHIFT while running the game, you can try forcing the resolution and quality settings to something different, but I don't know if this is the problem.
I'm going to run it up on my Linux machine in a couple of hours, can't get there yet, however.
RafiRomero Aug 9, 2017 @ 12:34pm 
It worked fine for me straight away, sorry.
I'm running Ubuntu 16.04 LTS (64-bit) AMD A10-6800K / GeForce GTX 960.
I haven't updated Ubuntu for a long time, however.
Narf Aug 9, 2017 @ 12:36pm 
Worked fine for you, even without the jemalloc thing?

I'm running Mint 18.1, which is pretty much Ubuntu 16.04 with Cinnamon on top of it.
RafiRomero Aug 9, 2017 @ 12:47pm 
I have a clean install of Ubuntu from ages ago, that I haven't updated.
I don't think I had to do anyting exotic (this time!) to get the game to work ages ago when I installed it. I was able to run the previous version of Chaos Reborn just fine.
Today I turned on my Linux machine for the first time in maybe a year, ran Steam, it updated the game, I ran it and it worked fine.
I don't know much about Linux, I'm sorry.

There are now two ~/.config/unity3d things because Snapshot switched from Unity 4 to Unity 5, I guess, and I guess 5 stores files in a different place.

Have you tried this thing with holding down shift or CTRL (I forget which, and I forgot to try this because mine just worked without it) to reset the resolution etc?

Also, Unity stores stuff in 2 places, if you were trying to scrub it clean:

Your persistent data stores your offline realms progress.
Your PlayerPrefs store your tutorial progress (as well as a bunch of other things).

Since mine worked, I didn't try scrubbing it.
Narf Aug 9, 2017 @ 1:04pm 
Tried holding CTRL; didn't work, but doesn't matter - found a way to make it work!

@kingron mentioning the new dir, it got me looking into what the different content in both dirs is ...

The one with the underscore is the new one, so I made a backup of the dot one, and copied it each time the game overwrote its settings. That is, if you've erased yours - don't know if this will work (the old "Snapshot Games." had a lot more contents than the new "Snapshot Games_", and the prefs file contents are significantly reduced after the blackscreen failure).

Anyway, I made it request 1920x1080 instead of 0x0, but there's no option for the refresh rate, which the logs also indicate is set to 0. Since refresh rate can only be set when in full-screen mode - tried changing that and it worked! :)

i.e.: set this in the prefs file:

<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>

(original value was 1)

Afterwards, just switch to fullscreen from inside the game menu and it runs just fine (though I haven't quit and re-launched again).
Narf Aug 9, 2017 @ 1:47pm 
Unfortunately, I have to do this each time I start the game.

Also, there's a considerable performance regression (seems fine with Medium graphics quality, but can no longer enjoy on High), and in-battle chat prints 0 when hitting LShift, / when hitting RShift.

All in all, quite a lot of bugs with this update. :(
RafiRomero Aug 9, 2017 @ 1:55pm 
For a less editor-intensive solution, ALT might be the thing to hold down before/during the start of the game (maybe even left-shift:/). I can't try this tonight (all three work on Windows, but I can't remember which key on Linux/ Mac), but if people are still having problems, that should fix it. It forces the resolution dialog to appear, and should use whatever resolution you ask for.

commandline option should do the same.

Regardless, thanks for posting a workaround Narf!
RafiRomero Aug 9, 2017 @ 1:57pm 
Ah, just read your latest post.
It's midnight for the developers now, but I've passed this thread on to them, and they should pick it up tomorrow.
Narf Aug 9, 2017 @ 3:56pm 
Thanks, the -screen-show-selector switch does help a lot (still have to set it to windowed mode though).

More bugs detected:

- It's not just LShift, RShift unexpectedly printing characters in the chatbox - Caps Lock does too; not that I've intentionally tried, but pretty much every key I hit except Enter and Backspace do print something
- Also while in chatbox, bound keys (like Q, E for rotating the camera) trigger actions even though I'm just typing text
- That performance regression triggered again, even though I was playing on medium quality; seemed random ... Sorry I didn't think to copy the Player.log, devs; I always tail it and never noticed it gets truncated with each game start. Game crashed right after it started lagging.

Here's some other possibly useful stuff from the log (filtered):

Invalid vertex colors assigned to Ruin3_2. Check the Maintenance window for your VPaint Group for more info.
Invalid vertex colors assigned to Ruin3_4. Check the Maintenance window for your VPaint Group for more info.
Invalid vertex colors assigned to Ruin3_5. Check the Maintenance window for your VPaint Group for more info.
Invalid vertex colors assigned to CR_Rock3. Check the Maintenance window for your VPaint Group for more info.

*note: all of the above is followed by:

(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

And another one:

The referenced script on this Behaviour (Game Object '_echoPFXManager') is missing!

(Filename: Line: 1743)

Hope that helps.
Last edited by Narf; Aug 9, 2017 @ 3:56pm
RafiRomero Aug 10, 2017 @ 1:09am 
Weird! Q and E (etc) don't move the camera for me, but I am seeing these extra characters when I hit shift etc in chat (in Linux, not Windows). It doesn't do this for the lobby chat, just the in-battle chat.
< >
Showing 1-15 of 25 comments
Per page: 15 30 50

Chaos Reborn > General Discussions > Topic Details