Microsoft Flight Simulator X: Steam Edition

Microsoft Flight Simulator X: Steam Edition

Voir les stats:
"Steam initialisation failed, steam must be running to play?"
I just downloaded FSX steam addition. I went through the installation process and everything. But when i try and play the game it comes up with the message "Steam initialisation failed, steam must be running to play?". Despite steam running when i start the game. Any help would be aprecciated thanks

UPDATE: Problem has been fixed
Dernière modification de Jinnah; 20 janv. 2015 à 11h38
< >
Affichage des commentaires 1 à 15 sur 17
try to run steam as administrator. i have the same issue. when i run steam as admin it works.

in my opinion this is something that needs to be fixed in the next patches.
Dernière modification de \\ZEN\\Swarley; 16 janv. 2015 à 3h58
Try this one, please.

I have posted an answer in this thread. Maybe it helps you too. Just download the .exe file I have linked in the third post and replace the original .exe (you can make a copy for sure).
http://steamcommunity.com/app/314160/discussions/0/626329820755274025/
Option 1, the simplest is to simply close Steam *properly* and restart.

The other option is also to exit Steam, r-click Steam icon, Run as Admin.

A more permanent fix to run as admin is right click properties of Steam icon, shortcut, advanced, set Run as Administrator.

Whilst I understand what la♥♥♥♥♥♥♥has done (hacked the .exe) it's not a solution because every update involving the .exe will need to be fixed. (It also opens up serious issues downloading .exe from some "random", no disrespect la♥♥♥♥♥♥♥ just pointing out bad practise).

FYI: It is NOT specifically an FSX issue - has been going on for *years* on multiple games.

tbh, it would be REALLY NICE if people would come back *confirm* that fix X or fix Y works. We seem to see a lot of this exact same issue with nobody bothering to forward on their success/failure.
I had the same issue as fazz7. After reading all the post on this op I right click steam shortcut & run as administrator. I am running a Windows 8.1 pro media center x64 bit. 6.3.9600 build 9600.
so. I have the same problem, how did you fixed it?
Mareșalu' a écrit :
so. I have the same problem, how did you fixed it?
I ran the program through my admin account
that is the correct procedure, right click steam and run steam as administrator, that should allow FSX to inherit the admin rights it needs
thanks, problem solved
Fast_Swarley a écrit :
try to run steam as administrator. i have the same issue. when i run steam as admin it works.

in my opinion this is something that needs to be fixed in the next patches.

Tks so much I was looking for the solution everywhere. I will definetly try it
fazz7 a écrit :
I ran the program through my admin account
THAT WORKED TY
The Widower a écrit :
A more permanent fix to run as admin is right click properties of Steam icon, shortcut, advanced, set Run as Administrator.

I tried with above option and it works for me.. Thank you.
Run as administrator on the account you use the most that should solve it :) Just tried it and it WORKED!
The Widower a écrit :
Option 1, the simplest is to simply close Steam *properly* and restart.

The other option is also to exit Steam, r-click Steam icon, Run as Admin.

A more permanent fix to run as admin is right click properties of Steam icon, shortcut, advanced, set Run as Administrator.

Whilst I understand what la♥♥♥♥♥♥♥has done (hacked the .exe) it's not a solution because every update involving the .exe will need to be fixed. (It also opens up serious issues downloading .exe from some "random", no disrespect la♥♥♥♥♥♥♥ just pointing out bad practice).

FYI: It is NOT specifically an FSX issue - has been going on for *years* on multiple games.

tbh, it would be REALLY NICE if people would come back *confirm* that fix X or fix Y works. We seem to see a lot of this exact same issue with nobody bothering to forward on their success/failure.

nope didn't work for me
Uncle Franco & Friends a écrit :
I just downloaded FSX steam addition. I went through the installation process and everything. But when i try and play the game it comes up with the message "Steam initialisation failed, steam must be running to play?". Despite steam running when i start the game. Any help would be aprecciated thanks

UPDATE: Problem has been fixed
I found another solution, this is for users that already required User Account Control (UAC for short - the blue and yellow shield icon) to load the game, and you could play fsx until suddenly UAC required a password. To fix this, you simply need to switch your user to administrator. Clicking "run as administrator" won't work if it already requires administrator password.

If you are confused on how to switch your user account over to an administrator user (In Windows 8 and above, not sure how to below), you must go into PC settings on another user that is already an Administrator, click accounts, other accounts, select your user, click edit, and finally set your user to administrator.
Hope this helps.
Dernière modification de Tom; 3 juil. à 4h58
< >
Affichage des commentaires 1 à 15 sur 17
Par page : 15 30 50