Microsoft Flight Simulator X: Steam Edition

Microsoft Flight Simulator X: Steam Edition

View Stats:
Falconer Dec 28, 2015 @ 5:00pm
FSX SE Crashes On Startup.
Hey guys, I have been trying to fix this in many ways. But for some reason, whenever I start FSX, 30 seconds in it sais a "Fatal Error Has Occured". I have tried all the fixes, including installing and reinstall VCREDISTx86 and x64 2005. I have tried re-installing Simconnect. I have tried almost everything. As a last resort, I checked the crash dump file. It contains this:


Dump Summary
------------
Dump File: fsx_62615_crash_2015_12_27T22_57_46C0.mdmp : F:\SteamLibrary\steamapps\common\FSX\fsx_62615_crash_2015_12_27T22_57_46C0.mdmp
Last Write Time: 12/27/2015 5:57:51 PM
Process Name: fsx.exe : F:\SteamLibrary\steamapps\common\FSX\fsx.exe
Process Architecture: x86
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

System Information
------------------
OS Version: 6.1.7601


I have tried deleting the logbook.bin, but I had another recent FSX boxed installation and I think that may have been linked to it. So I uninstalled boxed FSX. I then deleted every FSX folder I could. Including "Flight Simulator X Files" in my documents. Then I re-installed FSX SE. After looking in my documents, the "Flight Simulator X Files" folder is not there. i tried renaming config. I tried removing the config. I removed the appdata from the old FSX. I read somewhere that there may be a problem with FSX's admin privileges. So I re-installed FSX SE into my F drive (Hard Drive). Same problem. I do not want to install Steam in the F drive because I have more than 50GB of games on there. Any ideas on how to solve anything? Also I uninstalled McAffee. I disabled Firewall in the services window. I set all of my services to default except for Firewall. Also I think this issue may be linked to DEP. So if possible, does anyone know how to fix it? Help would be much appreciated. As an award for your pain, I will link your channel (Youtube) or Steam in the next video I make. Thank you. Once again, All help is appreciated.
< >
Showing 1-3 of 3 comments
Tonnie Jan 22, 2016 @ 12:59am 
I also have this same problem. I don't know what else to do. I really hope someone has a way to help out with this
MRollins Jan 22, 2016 @ 9:43pm 
Same for me. Can't even get to the main screen. Just the FSX temporary image that doesn't respond.
mikeytwc Jan 23, 2016 @ 4:30am 
First make sure you are running steam as admin(fsx requires admin rights for itself, and some addons)
make sure your video card drivers are up to date, dont just assume they are, check to make sure

step 1, Install all the simconnects that DTG doesnt automatically install for you

keep in mind these are simconnect.msi files...just double click to install

where my FSX:SE is installed into my E:\ drive
there are actually (4) simconnects in FSX:SE

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\lib
(install this one first)

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-RTM
(install this one 2nd)

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1
(install this one 3rd)


E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-XPACK (YOU SHOULD NOT NEED TO INSTALL THIS ONE)
DTG now includes the install for the xpack since the last update/patch

the 2nd thing to do is install the C++ redistributable



E:\SteamLibrary\steamapps\common\FSX\_CommonRedist\vcredist\2005
there are 2 files here

vcredist_x86.msi (to install for 32 bit)
vcredist_x64.msi (to install for 64 bit)
just double click on the pertinant one for your system,should be 64bit


If you can't find them in your directory can you please go to this website, download and install these two files.

http://www.microsoft.com/en-us/download/details.aspx?id=3387
http://www.microsoft.com/en-us/download/details.aspx?id=21254



Please make sure you install them to the same drive where you have FSX installed. It doesn't need to be same folder or anything. Just the same hard drive.


just to make sure it is installed, the XML parser should also be installed, it should have been loaded already by fsx

E:\SteamLibrary\steamapps\common\FSX\Installers
msxml.msi
double click this file to install

It looks like the game needs the MSXML 4.0 dlls installed for x86 and they aren't included in the redistribution or are failing to install as part of the Steam setup on Win 8.1 Pro.

I downloaded the MSXML 4.0 SP2 and SP2 Hotfix from Microsoft and everything then worked. Get the files from:

MSXML 4.0 Service Pack 2 (Microsoft XML Core Services) - http://www.microsoft.com/en-us/download/details.aspx?id=19662
Security Update for MSXML 4.0 Service Pack 2 (KB954430) - http://www.microsoft.com/en-us/download/details.aspx?id=14623


install Directx 9.0c
E:\SteamLibrary\steamapps\common\FSX\_CommonRedist\DirectX\Jun2010

i know it seems a bit overkill, but these steps usually correct issues for most people
If you had a side by side FSX:BOXED and FSX:SE install, it could be registry/directory structure/files issue, some have had suces with side by side, others have had nothing but headaches
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Dec 28, 2015 @ 5:00pm
Posts: 3