Crookz - The Big Heist

Crookz - The Big Heist

ziabice Nov 27, 2015 @ 9:36am
[LINUX] How to make the game work using Radeonsi + Manjaro (and others distros)
This game doesn't work out of the box on my Manjaro Linux using open source radeonsi drivers. This also applies to the game demo.

There are two problems:
  • Missing libraries
  • Game fails to recognize the OpenGL version

Note: on Manjaro (and other distros) to run the Steam client using the open source drivers you have to disable the Steam Runtime and rely on system libraries and the Mesa OpenGL implementation.

Before continuing, open a terminal and move to the Crookz executable directory:

$ cd <SteamLibrary>/steamapps/common/Crookz/Binaries/Linux

(change the <SteamLibrary> with your steam library path)

Missing Libraries

You need libGLEW version 1.10 (Manjaro has version 1.13), just use the one from the Steam Runtime and link it into the executable directory:

$ ln -s ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/

To know what's missing just do:

$ ldd Crookz | grep found => not found => not found => not found => not found => not found

Don't worry about libPhysX* and libsteam_api, you already have them.
Even if we linked the libGLEW library into the executable directory the command above will tell you that the library is "not found", don't worry about that, because on launch the game will override the library path and search libraries into the game directory.

Game fails to recognize the OpenGL version
The game need at least OpenGL 3.3. My ATI 7850 with RadeonSI driver supports OpenGL 4.1, but the game fails to recognize it. How it is possible?
Launch this command to check you OpenGL version:

$ glxinfo | grep OpenGL OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 2.43.0, LLVM 3.7.0) OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.0.5 OpenGL core profile shading language version string: 4.10 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 11.0.5 OpenGL shading language version string: 1.30 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.0.5 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00 OpenGL ES profile extensions:

The game reads the string "OpenGL version string: 3.0 Mesa 11.0.5" and believes that you have OpenGL 3.0, this is a bug, but I don't know if it's a Mesa bug or a game engine bug.
We can fix this easily, editing the launch script and forcing the OpenGL version.
Using your favourite text editor edit the file Launch, from:

LD_LIBRARY_PATH=:.:../../Development/External/PhysX/SDKs/lib/linux-x86_64/:../../Development/External/GFx/Lib/x86_64-linux/Shipping_NoRTTI/:../../Development/External/Bink/lib/linux/:../../Development/External/Steamworks/sdk/redistributable_bin/linux64/:$LD_LIBRARY_PATH export LD_LIBRARY_PATH ./Crookz


LD_LIBRARY_PATH=:.:../../Development/External/PhysX/SDKs/lib/linux-x86_64/:../../Development/External/GFx/Lib/x86_64-linux/Shipping_NoRTTI/:../../Development/External/Bink/lib/linux/:../../Development/External/Steamworks/sdk/redistributable_bin/linux64/:$LD_LIBRARY_PATH export LD_LIBRARY_PATH export MESA_GL_VERSION_OVERRIDE=3.3COMPAT ./Crookz

We simply added the line:


Before launching the executable.

Hope this helps, enjoy this game! :D
Last edited by ziabice; Nov 30, 2015 @ 7:53am
< >
Showing 1-3 of 3 comments
Skybreaker Nov 30, 2015 @ 1:34am 
Hi ziabice.
Thank you for this awesome guide! :rulez:
Keep it up! :maneki:
ziabice Nov 30, 2015 @ 7:57am 
Thank you for your kind words! :D
kurros Feb 7, 2016 @ 10:00pm 
Thanks for the guide. One change I'd make is that it is not necessary to edit the game's Launch file. From within Steam, you can go to the game's properties, and for Set Launch Options set it to


Hopefully the detection code can be fixed in a future patch.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50