Sleeping Dogs: Definitive Edition

Sleeping Dogs: Definitive Edition

View Stats:
EZZA Aug 8, 2015 @ 10:46am
Single screen tearing issue after Win10 update
After l upgraded my OS to Win10 a single screen tear appeared onto my monitor, even with V-sync. My frame's are stable but that one single WIDE screen tear is just there, it's really annoying. I tried everything l could think of but it didnt help. I didnt have this issue in Win8.. FFS... Is anyone else suffering from this?
< >
Showing 1-9 of 9 comments
Terminus Aug 8, 2015 @ 11:02am 
Hey

Have a look on turning on the FPS counter (it's worked for a couple of users)
Ensure that the Steam Overlay is Active and run the game.

Go to: Steam > Settings > In-Game > In-game FPS Counter > (Select area, e.g. Top-left) > Ok

Source: Can't get Vsync to work (Windows 10)
EZZA Aug 8, 2015 @ 12:39pm 
Originally posted by Terminus:
Hey

Have a look on turning on the FPS counter (it's worked for a couple of users)
Ensure that the Steam Overlay is Active and run the game.

Go to: Steam > Settings > In-Game > In-game FPS Counter > (Select area, e.g. Top-left) > Ok

Source: Can't get Vsync to work (Windows 10)

Damn.. That fixed it. Thanks!
War Boy Aug 10, 2015 @ 11:52pm 
I'd just like to say that I encountered the same issue as AnttiEerik and I can confirm that in my case enabling the frame per second counter in Steam settings fixed the single screen tear on my monitor. My monitor also happens to be a 32" LG HDTV in case anyone is running that kind of setup. Anyways, no more distracting screen tear while gaming!
ginjninj Mar 6, 2016 @ 5:25am 
Bumping this for anyone like me bought it in the squeenix sale this week. Turning on the FPS counter in the steam overlay fixes the screen tearing issue.
sfalexi Mar 31, 2016 @ 4:42pm 
Re-bump. the FPS counter didn't work for me, but what did was using an outside source to limit the fps to about 2 below my refresh rate. I used NVidia inspector to limit fps to 58 and put on vsync in the game and it solved the problem.
⛧ LucYfer ⛧ Mar 31, 2016 @ 5:26pm 
The FPS counter worked for me in combination with ingame Vsync.
However, I dont like the FPS counter.

I actually use a program called Borderless Gaming. Disable Vsync ingame, use Windowed mode with your native screen resolution, add the game to Borderless Gaming.
Done, fullscreen windowed gameplay and no tearing problem.
Windows has an own, usually best, Vsync. Means it locks to your screen refreshrate anyway.
I always use fullscreen windowed if possible. Best way to game!
TransLucida May 1, 2016 @ 4:28pm 
I think I found a solution...

I tried the Steam's FPS thing and it worked, only problem is that it shows on ALL your games. and as I noticed a small input lag on Street Fighter 4 after enabling it, then it's a no for me.

HOWEVER... I did manage to get rid of the damn tearing by setting Vertical Sync to ON and Triple Buffering to ON in the NVIDIA Control Panel and then, in the Sleeping Dogs's settings, by setting the quality preset to ULTRA and V-Sync to OFF.

my specs are Intel i7 OC'd @ 4.75GhZ / 12GB RAM / GTX 970 (ASUS) and with these settings I'm getting around 40-50 frames per second which doesn't look too bad to me.

I thought that letting the driver deal with V-Sync rather than the game would be better in this case. but for some reason the tearing only disappears if use the ULTRA preset. it will come back if I use HIGH or a lower one. go figure!
Rahza Aug 4, 2016 @ 12:52pm 
The FPS counter thing totally worked for me. If it enables it in other games, then I'll probably just turn it on only when playing this and having it off otherwise. Good enough for me! Thank you! :P
fastica Aug 7, 2016 @ 3:54pm 
FPS counter didn't worked for me. I've tried the Borderless Gaming app and while it works, it distort the text so it's not a good workaround. Tried also locking the FPS with nvidia inspector and it didn't work.

It's incredible, this is the only game I have where I can't activate vsync in fullscreen. I know the game it's abandoned but a patch to be able to play it in borderless fullscreen would be awesome.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Aug 8, 2015 @ 10:46am
Posts: 9