The Elder Scrolls Online

The Elder Scrolls Online

Ben N'wah Jul 6, 2017 @ 6:49pm
Infinite Loading Screen After Login
The game won't allow me to play it. When I start the game from the launcher, it takes me to the login screen, but automatically logs me in without allowing me to input my information. Following this, it takes me to the loading screen where it shows you some artwork of a Tamrielic landscape; however, rather than loading into the game from here, it just loads infinitely. I have no idea how to fix this as I am not tech savvy and don't know why it would decide to stop working on my so suddenly. If anyone has a fix, please please please let me know so that I can get back into playing this awesome game.
< >
Showing 1-6 of 6 comments
ArcLight Jul 6, 2017 @ 7:20pm 
Uhh, check your internet? Specs for your PC? Idk much sorry
Tove Jul 6, 2017 @ 7:24pm 
Try repair the game from the ESO Launcher. NOT trough Steam!
ArcLight Jul 6, 2017 @ 7:25pm 
Originally posted by Tove:
Try repair the game from the ESO Launcher. NOT trough Steam!
Mabye true, idk...
0Samuel Jul 6, 2017 @ 7:28pm 
This used to happen to me a lot, and often still happens after an update. Try closing the game and the launcher, and relaunching both. It could take a few tries.
You might just be missing a patch.
I think changing settings sometimes causes it too.

Finally, and perhaps most importantly, be patient. This situation sucks, and it might be that what feels like forever might only be a minute or two after the third or fourth time rebooting the game. A 20 minute loading time is unacceptable, but chances are you wouldn't be able to tell between it and an infinite loading screen. Try tabbing out, getting something to drink, idk, and you might find the game has loaded when you come back.

Of course, this is just my experience. Your problem may be completely different, and if so none of what I suggested is likely to work.
amapola76 Jul 8, 2017 @ 7:43am 
I'm having exactly the same issue, and it's definitely far more than a minute or two. I've had the game for over a week, and have put over two hundred hours into attempts to install and load, and have yet to get past the loading screen described above, although I was able to verify/activate my new ESO account. The longest loading stretch thus far was around 10 hours, as I started it a bit before I went to sleep last night, and after I woke up and got my coffee this morning, it was still trying to load. This is completely ridiculous; while, like the original poster, I'm not particularly tech-savvy, ESO is not my first rodeo with either an Elder Scrolls game, Steam generally, or an MMO. I have put thousands of hours over the last six years into all of the above, and I have never seen anything like this.
amapola76 Jul 8, 2017 @ 7:44am 
Also: my internet is just fine, I've had no problem with my other games in the meantime (or with streaming Netflix and such), and I have around 98 GB still free even after installation, so that shouldn't be the issue.
< >
Showing 1-6 of 6 comments
Per page: 1530 50

Date Posted: Jul 6, 2017 @ 6:49pm
Posts: 6