Trove
Trove > General Discussions > Topic Details
Alph Feb 23, 2019 @ 7:29pm
Can't play the game.
Hey y'all! I recently downloaded the game but I can't seem to get it to even boot, I hit play on Steam and it won't launch it, it shows like I'm playing the game on my Steam status for a while, then it goes back to blue, the launcher doesn't show up or anything; I tried to run the launcher from the install directory of the game but it won't do anything.
< >
Showing 1-9 of 9 comments
Jok3rRL Feb 27, 2019 @ 1:00am 
me too
S H O R T Feb 28, 2019 @ 1:49pm 
Go to the game directories, find the main file, the executable. Select it and click Properties. Then go into compatibility, and enable this program as an administrator.

Please, try!
BulldogFasti Feb 28, 2019 @ 2:09pm 
It sounds like a permissions issue, as SHORT mentioned above. Something somewhere is possibly blocking either Trove or Glyph from launching.

There was a Glyph update back in January that requires the newest version. Did you start playing prior to that? If so, you may need to uninstall Trove completely, confirm all Glyph files are also gone, then download again. That's only necessary if you played Trove last year, stopped for a while, then picked it up again in late January.

Alph Feb 28, 2019 @ 11:42pm 
Originally posted by BulldogFasti:
It sounds like a permissions issue, as SHORT mentioned above. Something somewhere is possibly blocking either Trove or Glyph from launching.

There was a Glyph update back in January that requires the newest version. Did you start playing prior to that? If so, you may need to uninstall Trove completely, confirm all Glyph files are also gone, then download again. That's only necessary if you played Trove last year, stopped for a while, then picked it up again in late January.

Already tried uninstalling and running as an admin; I tried to play prior to January (Like in June last year) but I was met with the same error, the launcher wouldn't open. I have to note that I can open Trove by its .exe, but can't play since I'm not logged into the launcher.
Alph Feb 28, 2019 @ 11:44pm 
I managed to open the launcher by setting compatibility mode with Windows 7, weird. Thanks y'all!
BulldogFasti Mar 1, 2019 @ 12:18pm 
Originally posted by Alph:
I managed to open the launcher by setting compatibility mode with Windows 7, weird. Thanks y'all!
Hmm, that is odd, but super happy it's working for you now. Did you set Glyph itself in compatibility mode, or something else?
Alchemedes Mar 1, 2019 @ 2:05pm 
I'm having the exact same problem, this happens off and on but now it just won't work. I've tried reinstalling ,running in compatibility mode, and i can't verify troves integrity.
I need help :/
Alph Mar 1, 2019 @ 8:03pm 
Originally posted by BulldogFasti:
Originally posted by Alph:
I managed to open the launcher by setting compatibility mode with Windows 7, weird. Thanks y'all!
Hmm, that is odd, but super happy it's working for you now. Did you set Glyph itself in compatibility mode, or something else?

Well besides that, if I'm not mistaken I also turned my antivirus off, but I don't think that the antivirus was the issue.

Originally posted by Alchemedes:
I'm having the exact same problem, this happens off and on but now it just won't work. I've tried reinstalling ,running in compatibility mode, and i can't verify troves integrity.
I need help :/

Try turning your antivirus off (if you have one), then again, I don't think that it was what solved it, but doesn't hurt to try.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Trove > General Discussions > Topic Details
Date Posted: Feb 23, 2019 @ 7:29pm
Posts: 9