Roundabout
Roundabout > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
DeliciousBees  [developer] Sep 18, 2014 @ 8:43pm
(Updated 4/20) Having trouble with Roundabout? Check this thread out first!
Hey there, Roundabout pals! Thanks so much for grabbing the game, it's super wonderful seeing everyone jump in and have fun!

This is a thread to give you some troubleshooting tips if you're one of the unlucky pals having problems running the game, and to also keep you up to date on the status of any particular bugfixes for bugs in the game you find.

I'm having a problem! What do I do!
Step 1 - Check the "Quick Fix" list below to see if there's anything in the known list of issues.

Step 2 - If there's nothing there, try switching to the "safety" branch. While it doesn't have the video and speed fixes that the current build has, it also has a less experimental culler that's been battle tested (even if it is slower). Give that a shot and see if that fixes your problem!

Step 3 - If your problem still happens in the safety branch, let us know! You can either post here, tweet at me at @deliciousbees, or send me an email to ohnogeorgio@nogoblin.com! I'll do my best to let you know what's going on and when things get fixed/updated!

Here's some quick solutions to the most common issues we've seen crop up:

I'm running Linux and am having issues!
There's two reasons why this might happen:

#1: I can't start! My log shows "error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory"

If you see that and you're running Ubuntu, just type the following command in at a command prompt to fix your problem:

sudo apt-get install libglu1-mesa:i386 libxcursor1:i386

#2: I can't start! The window flashes after hitting "Play" in Steam
On some installs, Steam has trouble starting the game. In this case, launch Roundabout.x86 from the command line and things should work fine.

#3: I have a 5-series AMD card running the open source drivers and all my video is green!

This is a known bug we're working with the Mesa/FreeDesktop guys to fix. It's bug 86789 if you're interested in following along too!

#4: All of my minimap icons are locked in the center/invisible

It looks like this is an issue for specific locales in Linux. We hope to have a fix soon, but in the meantime here's a workaround:

Originally posted by mjau:
...In the meantime, this custom Steam launch command works:

/usr/bin/env LC_ALL=C %command%

After i launched the game with that, the percentages on the save select screen show billions of percent complete, but it seems to work otherwise. Also, the saves don't show up at all if i launch the game without it now :p

"The game is super slow, especially when particles come up"
- First off, make sure your computer meets the minimum specs. Roundabout requires a DirectX 11-compatible graphics card, which means:
  • NVidia: GeForce GT 400 series or higher
  • AMD: Radeon HD 6000 series or higher
  • Intel: Intel HD 4000 series or higher

Roundabout also needs a half decent CPU. The latest build has been optimized to deiver 60fps gameplay on the slower mobile CPUs found in this generation of consoles, but anything below those (like old Celeron or AMD integrated CPUs) may struggle.

"I have another random weird bug!"
Oh no! Well, there's some quick things you can try to make sure it's a problem on our end and not your end:
  • Make sure you have the latest drivers for your video card - Steam has a handy menu item (Steam->Check for Video Driver Updates) to help!
  • Verify your Steam Cache - Right click on Roundabout, go to Properties, then click on the "Verify Integrity of Game Cache" option under "Local Files".
  • Enable the Framerate Cap - We've heard reports from other Unity games that weird things can happen on some specific PCs if they run uncapped. If you see super weird behaviour or slowdowns, try turning on the cap and seeing if that helps.

"When I start the game, everything is black" or "The game crashes on AMD 5-series cards"

These old bugs should be fixed in the latest build! Make sure you're up to date and try again. If you are up to date and are still getting these issues, please let us know.

Recent changes

4/20 Performance Update
Note: This is all of the "preview" branch updates, but pushed out to everyone now that it's ready. Enjoy, and let us know if there's any issues!

  • New! Snow in Mountains can now be disabled by turning off the "details" setting in Options
  • New! eSports Speedrun intro movie can now be skipped
  • Upgraded to Unity 4.6, fixing a crapton of resolution and controller issues.
  • Merged over our optimized culler from the Xbox One and PlayStation 4 versions
  • Optimized a ton of systems for performance - pedestrians, physics, and way more to list.
  • Level fixes for a couple of hard to find pickups and cash stashes
  • AMD 5650/57xx driver crash bug appears to no longer happen! Hooray!
  • Optimized first frames of an eSports load so that there's almost no hitching when the hold timer ends.
  • Fixed eSports bug where limo motor would go silent on level loads
  • Legacy Fullscreen and Windowed Fullscreen have now been merged into "Fullscreen". Two great tastes that taste good together!
  • Better support for non-60hz monitors in Fullscreen mode
  • Fixed issue where some systems would pick a non-optimal render path
  • Fixed some typos in the credits
  • Map polish tweaks

10/16 Hotfix
  • Fixed speedrun and rampage exploit that allowed you to "stick on" a powerup
  • Tidied up terrain painting in the city
  • More optimizations, as well as some SECRET THINGS that you won't see but are actually infrastructure changes for some future updates. Let us know if you see anything weird.

10/7 Update
  • "I've Covered Wars, You Know" no longer counts towards 100% completion
  • Extras are now saved and persist between sessions
  • Camera height is now saved and persists between sessions and levels
  • The limo now respawns properly if you retry a ride while dead
  • Added a "Force 720p Video" option for players on lower performance systems. Note that this is just part one of a plan to get fast video performance for low spec systems!
  • Updated French localization

9/30 Update

While the list is small, we put a ton of work into improving our worst case performance area - Pope Farms. Hopefully this should allieviate the chugging some people were seeing.

AMD 5xxx pals: A new Catalyst driver was released last night! Please pick it up! We've heard reports from a majority of people that it either fixes or greatly reduces the driver crashes that were happening in 14.4. We'll be investigating the last remnants of this crash, but in the meantime this should greatly improve your experience!

  • 2x-4x performance improvements in the Mountains area, especially around Pope Farms. If you were struggling here before, things should be a *lot* better.
  • Minor CPU performance improvements in Suburbs starting area
  • Workaround for a bug in PhysX's non-CUDA implementation that was causing the limo to go into noclip mode if you hit a specific object from a very specific direction.
  • Audio sliders now properly load their values on profile select
  • eSports Credits music should now play on all systems


9/25 Evening Update

This is a quick update to get the Deluxe Edition Soundtrack working in the just released Steam Music Player. Stay tuned for a proper Roundabout update next week!

9/22 Evening Update (Steam build 391083)

We had a bit of time before the AMD hardware arrived, so we spent today fixing a bunch of bugs that had been reported to us either here on the discussion boards, or at ohnogeorgio@nogoblin.com. Thanks for sending them in!

  • Fixed an incredibly gross bug that would have caused general crazy weirdness. It would be unique weirdness for everyone. If you had "weird" problems like pickups not disappearing or mission start/end problems, try this build!
  • Tunnel arches have appropriate collision again
  • It's no longer possible to cheese the first Ranger Stacey ride by retrying it constantly before starting
  • Fixed bug with "How's My Driving" screen that allowed people to complete checkboxes before actually doing then.
  • "Smoke and Mirrors" is no longer required to 100% the game. See, we're not monsters after all!
  • Fixed a bug that was causing suburban-unique male pedestrian voices to not play
  • You can no longer skip the timer in a challenge by activating a time-related powerup like Turtle Power
  • Silenced a single tree that had decided it wanted to make a sound.
  • Minor credits and subtitle fixes

9/21 Morning Update (Steam build 389306)

I'm calling this build "The Input Update". There's a crapton of stuff here that should hopefully fix a bunch of weird things some people were seeing with input.

  • New Feature: You can now restart your ride anywhere! From the pause menu, "Retry Ride" will restart the current ride you are on. Not on a ride? It'll restart the last ride you picked up!
  • Updated to Unity 4.3.7p4. This update includes some fixes for third party controllers dropping, changing IDs, and generally being not great.
  • Fixed a bug that was causing some jump and horn button presses to not register on high performance/vsync-disabled PCs.
  • Fixed a bug where motion blur/'70s postproc would be reenabled after a movie regardless of what setting was enabled.
  • Hardened up the back wall of the mall to stop it from disappearing on some PCs.
  • Fixed a super rare bug that could cause the game and ui controls to get out of sync if you collided on a specific frame while doing a challenge.
  • Made generic non-Microsoft XInput devices ("Game Controller (XUSB)") bind with the default Xbox 360 controller profile instead of floating around in the wilderness.
  • Added experimental support for GameCube conrollers (via TigerGame USB Adapter)

9/19 Late Evening Update (Steam build 388825)

This build has a potential fix for Radeon GPU's crashing when intense collisions happen. If you still crash your PC on a big crash with your limo, let us know in the comments.

  • Added the ability to toggle Motion Blur and the '70s postprocessing on and off in PC Settings. (note: right now launching a Challenge from the Challenge Menu requires you to retoggle the option after loading for it to take effect. We'll fix this for tomorrow's update.)
  • Added the ability to lock the framerate to 60fps in PC Settings. If you're seeing crashes and/or random weird issues, please enable this and let us know if they still occur.
  • Fixed collision issues on Mountain Town Hall
  • Post-movie audio no longer plays in Official eSports Speedrun Mode
  • The lower cliffs behind the airport no longer gargle.

9/19 Early Morning Update (Steam build 387830)

  • Fixed a Linux bug that would cause the Charles Maximilian mission to crash on some machines
  • Fixed an audio slider bug that would stop sliders from being saved on the main menu
  • Fixed a restart mission bug with Beth's "Go to Lower Roundabout" mission
  • Lowered the volume of the "pulse" chirp sound for the Sonar upgrade and the Find Challenge
Last edited by DeliciousBees; May 7, 2015 @ 3:59pm
< >
Showing 1-15 of 81 comments
cooljammer00 Sep 18, 2014 @ 8:53pm 
Dan, will you sing to me?
DeliciousBees  [developer] Sep 18, 2014 @ 9:03pm 
I can, but I have to warn you that I only know the last word to every line of most Beastie Boys tracks.
DeliciousBees  [developer] Sep 19, 2014 @ 6:08pm 
Thanks for the heads up, mjau! I've added this to my bug list.
Infernox Sep 19, 2014 @ 6:26pm 
Hey, just letting you know that there's a bug where score multipliers from missions will stick around after dumping your passenger and you can continually collect them without them disappearing. Not quite sure how it happened, though.
Kandralla Sep 19, 2014 @ 8:29pm 
I'm getting about a quarter of a second input lag with a wireless Xbox 360 controller making it unpleasant to play.

Geforce GT 750M
Core i7-4700MQ 2.4 GHz
Cardboard Cut-Out Sep 20, 2014 @ 2:34am 
Hey, Whenever I disable motion blur and '70s processing mode, everytime I start a new mission or exit out of one the resets them back to on, yet the options screen still says they are off. I have to re-enable them and then disable them again everytime I start a mission or leave one.
The_B Sep 20, 2014 @ 8:50am 
Sadly, still getting occasional crashing on large crashes after late eve patch. Using a HD5700 and always with "display driver stopped responding" error message, if it helps!
allen Sep 20, 2014 @ 1:24pm 
Thanks for the motion blur toggle and other very quick updates, it's greatly appreciated that you got these out so fast!
slowb1rd Sep 21, 2014 @ 8:58am 
So this is a silly problem, but here goes. I bought the standard game first, and then later went and bought the Deluxe Edition DLC. I can browse the Deluxe files manually, but when I try to launch the "View Deluxe Edition Extras" choice from Steam, it comes up as a missing executable. I don't see an executable in the folder for the Deluxe content either.

I've tried checking the file integrity through Steam, and also deleting and re-downloading the Deluxe conten, with no luck. It's not that bad since I can view that stuff through Windows Explorer, but I just wanted to let you know that it seems the Deluxe download seems to be missing something when purchased separately.
DeliciousBees  [developer] Sep 21, 2014 @ 9:23am 
That is very weird, thanks for letting us know! Does the launcher show up if you delete and reinstall the main game? I'll check in with our Steam pals and see if they have any ideas.
slowb1rd Sep 21, 2014 @ 11:39am 
Okay, I just tried that and had the same result. Here's a look at the files that are in the game folder and the DLC folder:

http://imgur.com/a/XqYuN
Bieeanshee Sep 21, 2014 @ 4:49pm 
Not a huge issue, but I've crashed on quitting the last two times I've played today. Both times it's been in different modules; the first complaint was about something called stackhash (or hashstack; I was dumb and didn't think to jot the particulars down), and the second was in the main Roundabout executable, fault name 'BEX', problem module mono.dll_unloaded.

Unrelated, I'd like to make a suggestion: Make the map icons for properties that are ready to have money collected throb the way the next-mission and challenge markers do. Unless there's something that works like that already, that I haven't discovered, in which case: carry on! :)

Edit: Crud, my apologies. Wasteland 2 is doing the same thing, and from Googling I get a feeling that it's Unity and the new Nvidia driver not playing well together.
Last edited by Bieeanshee; Sep 21, 2014 @ 8:51pm
TwelveWishes Sep 22, 2014 @ 7:22am 
I use a Gioteck VX-2 controller which seems to be recognized by the game in that it shows the "Press the A button" command instead of the Press Space one, but there is no reaction upon button inputs. Am I doing something wrong or is it not supported?
georgeo23yal Sep 23, 2014 @ 7:57am 
"Silenced a single tree that had decided it wanted to make a sound."

I uh... I'm not the only one that finds this extremely creepy right? :meatytears:
DeliciousBees  [developer] Sep 23, 2014 @ 9:32am 
Heads up that I've rolled back last night's patch because of a challenge bug, should be back up with that fix later this morning.

Edit: ...and it's back up! Thanks for playing, everyone!
Last edited by DeliciousBees; Sep 23, 2014 @ 10:29am
< >
Showing 1-15 of 81 comments
Per page: 15 30 50

Roundabout > General Discussions > Topic Details