RimWorld

RimWorld

RimWorld > General Discussions > Topic Details
This topic has been locked
f1rools22 Dec 31, 2018 @ 3:41pm
What keeps making my game pause?
My very-modded game keeps pausing. To be clear by pausing I mean stopping using the time buttons. I can un-pause and what looks like 1 frame happens before it pauses again. I've got a fair few mods, however I carefully chose and re-fined them so I launch with just 1 error, that being a keybinding error (and not the pause key). I have no mods running that are designed to effect how time passes in game. Can anyone think of what might be happening to cause this?
< >
Showing 1-7 of 7 comments
Profound_Darkness Dec 31, 2018 @ 7:46pm 
So I tried to search around to refresh my memory and I have to say thanks for being clear. A large number of posts considered hickups and fps drops the same as pausing so my memory remains stale. I tend to play with developer mode enabled so I don't recall how the game acts with it switched off.

I'm a little fuzzy but I thought the game paused when there was an error. If you aren't getting a Debug log window then maybe turn developer mode on (game options) and then when the error happens you can either see what's going wrong or maybe try to play through the error.

If you opt to play through the error you should be able to turn off "auto-open" in the window that pops up and I *THINK* that will also stop the pausing. Also there is an option in ED-Enhanced options mod called "Supress writing log to file" which might be of assistance if trying to play through the error (lowers the overhead from the errors).
f1rools22 Jan 1, 2019 @ 6:47am 
Originally posted by Profound_Darkness:
So I tried to search around to refresh my memory and I have to say thanks for being clear. A large number of posts considered hickups and fps drops the same as pausing so my memory remains stale. I tend to play with developer mode enabled so I don't recall how the game acts with it switched off.

I'm a little fuzzy but I thought the game paused when there was an error. If you aren't getting a Debug log window then maybe turn developer mode on (game options) and then when the error happens you can either see what's going wrong or maybe try to play through the error.

If you opt to play through the error you should be able to turn off "auto-open" in the window that pops up and I *THINK* that will also stop the pausing. Also there is an option in ED-Enhanced options mod called "Supress writing log to file" which might be of assistance if trying to play through the error (lowers the overhead from the errors).

All sensible suggestions, however sensible would be simple, and Rimworld is never simple.

I've tested the bug using dev mode on and no errors come up. :/

I found restarting the save did not help, however restarting the game does help. As I play for a longer time the bug happens more frequently. (Stack overflow thingmajig?)

The bug relatively frequently (about once every in-game day) happens and pauses the game. If i then turn the speed back up it runs normally.

Since no error is being created I don't think surpessing writing log to file will help, and I don't really want to add more mods to my already crowded mod folder.

I should also say that there is not an event happening that is causing the game to pause as far as I can see in the messages log AND events are set to not pause my game.

Any idea's as to which sort of mods might be causing this? I'm starting to see Giddy Up! have some small problems with animal pathfinding causing them to freeze in place, but nothing else.
Turn off the "Pause at error". It's in options I believe
f1rools22 Jan 1, 2019 @ 7:31am 
Originally posted by Santa Fish:
Turn off the "Pause at error". It's in options I believe

Already not turned on. :/
i'm having the same issue have you had any luck fixing it?
Do0m[y] Nov 3 @ 7:12pm 
Hello everyone,
Here's how to fix this annoyance!

Step 1:
- Press ESC.
- Click on the "Options" button.
- Enable the "Development mode" option (down below) and click on the "Close" button.
- At the top of the screen you should see a white "P" close to an icon who looks like an Alien.
- Click on the white "P" to disable it (you should see a red cross on it now).

Step 2:
- Press ESC.
- Click on the "Options" button.
- Disable the "Development mode" option, and click on the "Close" button.

And you're good to go! No more extremely annoying pause anymore! :steamhappy:
pheanox Nov 5 @ 7:26pm 
This only needed to be necroed once.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

RimWorld > General Discussions > Topic Details