Automation - The Car Company Tycoon Game

Automation - The Car Company Tycoon Game

 This topic has been pinned, so it's probably important
Killrob  [developer] Mar 14, 2019 @ 4:35pm
Can't Select Or See ANY Car Bodies / Engine Parts
This issue stems from your system or anti-virus blocking Automation's access to its own folders. The missing car bodies are a symptom of it being impossible for the game to write to its database file in Documents\My Games\Automation.

Depending on your anti-virus or windows defender settings, you need to whitelist Automation and its .exe, as well as add an exception for Controlled Folder Access. Here is some info on how that works:

https://thehackernews.com/2017/06/windows10-controlled-folder-access-ransomware-protection.html

In addition to that, depending on how vicious your anti-virus is, you may have to run Automation with administrator privileges to have it be able to talk to Steam.

Setting this up correctly will mean the game can write to its folders and you'll be able to create cars and engines from there.

Cheers!
Last edited by Killrob; Apr 8, 2019 @ 3:50pm
< >
Showing 1-15 of 37 comments
heyy! im having this issue, the game was fine for about 50 hours and now i cant play anymore because of this, help! i have tried everything even untinstalling and reinstalling the game
Killrob  [developer] Mar 22, 2019 @ 12:11am 
Originally posted by Old mate:
heyy! im having this issue, the game was fine for about 50 hours and now i cant play anymore because of this, help! i have tried everything even untinstalling and reinstalling the game
Have you made absolutely sure that you have deactivated protected folders and whitelisted Automation in (all) your anti-viruses? Like the OP states, it is not an issue with Automation but with your system blocking the game from writing the database file.
yeah so all the windows system folders cannot be unprotected, like its not even an option to unprotect them , i can how ever add automation to the list and then remove it again but that is the only way and still does not make any difference.
Killrob  [developer] Mar 24, 2019 @ 2:29pm 
You don't need to remove the restricted access from system folders, just whitelist Automation's exe and the three folders it needs access to:

\Documents\My Games\Automation
%LocalAppData%\AutomationGame
Steam\steamapps\common\Automation\

You find the exe here:
Steam\steamapps\common\Automation\UE421\AutomationGame\Binaries\Win64
nba yung looz Mar 25, 2019 @ 9:36pm 
So how do we whitelist? I been trying to do this for sometime and I got no clue what Im doing, It worked yesterday when the update came round and then after I closed it and restarted it I had gotten the issue again, Don't quite know how to fix it even with this help, like how do you do it?
nba yung looz Mar 25, 2019 @ 9:42pm 
Ok, nevermind i was just doing it wrong
wham May 8, 2019 @ 4:44pm 
I dont know how to whitelist please help me
Originally posted by DESTROYER065:
I dont know how to whitelist please help me

Keep trying youll get it, took me a few attempts but what these guys are saying will fix it
Kaosality May 25, 2019 @ 6:47am 
No AV, windows defender disabled, windows newly installed aaaaand... No bodies xD
Uncheck read-only worked for me.
Last edited by Kaosality; May 25, 2019 @ 6:52am
InsaneZedge Sep 19, 2019 @ 12:32pm 
I have done everything detailed here, reinstalled, restarted, updated steam and drivers. STILL no way to play the game since it suddenly decided to start doing this yesterday
Originally posted by Insane Zedge:
I have done everything detailed here, reinstalled, restarted, updated steam and drivers. STILL no way to play the game since it suddenly decided to start doing this yesterday
Its the firewall thing i found after about 2 months of not playing due to giving up because of this
Spidey Oct 2, 2019 @ 2:15am 
Didn't work.
Killrob  [developer] Oct 2, 2019 @ 2:40pm 
Originally posted by Spidey:
Didn't work.
Then try to use the information on what is going on (write protected folders) and see what else could be causing that on your system.
Drefar Oct 14, 2019 @ 12:24pm 
Really man you deleted my post's for saying it didn't work for me to do all those things I just hope that you fix that problem internally good luck from here. ;)
Killrob  [developer] Oct 14, 2019 @ 4:08pm 
Originally posted by Drefar:
Really man you deleted my post's for saying it didn't work for me to do all those things I just hope that you fix that problem internally good luck from here. ;)
Uhh, what are you on about? We don't delete any posts.
Also we CAN'T fix it internally because that would mean we create malware (getting around your system security settings)... do you want us to create malware? :P
< >
Showing 1-15 of 37 comments
Per page: 1530 50