View Stats:
Cosmochoria > General Discussion > Topic Details
stumpy Aug 29, 2016 @ 12:56am
Lost progress with new patch
Once the new patch went live, the next time I opened the game, it had me select a language and it was as if I was starting from scratch. All of my progress was lost. Is there any way to recover my save?
< >
Showing 1-15 of 24 comments
Nate Schmold  [developer] Aug 29, 2016 @ 3:45pm 
Damn, i think it might have to do with the game now having different 32bit and 64bit versions.. Are you on Windows or Mac? I'll do my very best to help. So sorry for the inconvenience with this, im hoping its recoverable though.
stumpy Aug 30, 2016 @ 11:40pm 
Thanks for the quick response. I've really enjoyed playing your game by the way!

I'm on Windows 8.1 x64
Habittante Sep 8, 2016 @ 12:17pm 
:,CCCCCCCCCCCCCC </3 me too i lost all my progress
stumpy Sep 9, 2016 @ 12:49am 
Hang in there my friend. We must embrace the pain and burn it as fuel for our journey. Don't lose hope.
Damage Sep 9, 2016 @ 8:40am 
Same here. All progress gone. Assistance appreciated. W7 64bit. I love this game but I'm not sure I'm prepared to rack up another 17 hours just to get back to where I was.

Slightly concerned that this issue was posted 12 days ago and there's still no evident solution.
Last edited by Damage; Sep 9, 2016 @ 8:42am
Lozkinu Sep 11, 2016 @ 5:34am 
Yeah, I decided to play again today for a while, I thought it was ment to be at first.... hopefully it will work out. either way, win 10 - 64bit
LunaFortuna Sep 19, 2016 @ 1:39am 
I assumed it was meant to be that way. I lost all my progress, too. I've been kinda assuming that the game just does that.
Damage Sep 19, 2016 @ 5:11am 
Originally posted by LunaFortuna:
I assumed it was meant to be that way. I lost all my progress, too. I've been kinda assuming that the game just does that.

I'm sorry, what?! A game that deliberately wipes your progress? It's not "meant" to be like that, can't believe anyone would be so credulous as to think otherwise. What it is is entirely unacceptable.

Especially given that nearly a month has gone by and the developer has done nothing other than go "oops!".
Lozkinu Sep 19, 2016 @ 12:35pm 
ha ha .... * _ *
I guess I can blame my asumption on having played early access games once or twize.
they do reset the game files at times, and so it didn't really seem all that strange to me.
no matter, I'll just relax and play again if it doesn't get solved.
It's not optimal, but I can't be bothered getting angry over a game resetting.
Nate Schmold  [developer] Sep 19, 2016 @ 3:29pm 
To Damage and others affected by this issue, I have been doing my best to determine the best course of action to have this resolved. It's not a code issue, or something I can resolve via code because it has more to do with the fact that the path for Cosmochoria must have changed on your actual computer when it changed the build version from the 32bit to the 64bit version. I had thought Steams cloud saving would have taken care of syncing the versions up but apparently not.

Here's what I know:

- ALL your data should still be accessible from /Users/youruser/AppData/Local/Cosmochoria
- Your Old data is likely in the "LocalStorage" folder within that Cosmochoria Folder
- Your NEW data is being pulled from the "User Data/Default/Local Storage", so a totally new structure.
- ALL data is stored as a .localstorage file (with an accompanying .localstorage-journal file as reference)
- the .localstorage file is actually an sqlite database and fully editable using

What I am still trying to figure out / test:

- Can i copy the OLD .localstorage file and .localstorage-journal file and put in the new spot for a 1:1 replacement? It seems to be working for me in my test, but i havent fully tested this so cannot give 100% confirmation on this until i test further.

*** If you are uncomfortable with testing this / doing this - you can simply pass me a zip of your /Users/username/AppData/Local/Cosmochoria/ folder and I can attempt to convert the files over for you and pass you back instructions on how to get the save game transferred.

I deeply apologize for the delay in giving a response to this, it was not my intention to ignore anyone or 'consider it resolved'. I do definitely consider lost data to be a serious issue as your Cosmochoria progress should literally be 'sacred' as far as i'm concerned. I have been working hard on a solution with any spare time I have and any delay is only because I have a hundred balls in the air right now with a new game launch and am trying to keep all the balls from hitting the floor. I am very sorry for this particular ball seeming like it had dropped, but i promise I've been working on the solution as quickly as I've been able to.
Nate Schmold  [developer] Sep 19, 2016 @ 3:41pm 
If you do want to brave trying to copy the old file over to the new spot, remember it needs to have the same filename as the new file.... so here's what I did:

- Go to /Users/youruser/AppData/Local/Cosmochoria/Local Storage/
- Copy file__0.localstorage & file__0.localstorage-journal to my desktop
- Go to /Users/youruser/AppData/Local/Cosmochoria/User Data/Default/Local Storage
- Copied the name "chrome-extension_bhaggbbcbnpifcdieecbbhejlejmonhl_0.localstorage" and renamed my backed up file__0.localstorage to chrome-extension_bhaggbbcbnpifcdieecbbhejlejmonhl_0.localstorage
- Copied the name "chrome-extension_bhaggbbcbnpifcdieecbbhejlejmonhl_0.localstorage-journal" and renamed my backup file file__0.localstorage-journal to chrome-extension_bhaggbbcbnpifcdieecbbhejlejmonhl_0.localstorage
- Copied both of my backup files into the /Users/youruser/AppData/Local/Cosmochoria/User Data/Default/Local Storage folder, this will replace them (so back them up if you want to save any data since the upgrade)
- Once replaced, I launch cosmochoria.
- I see my OLD data in-game at that point. I haven't completely tested ALL aspects of the game, but everything is technically moved over properly, there shouldnt be any problems but I want to test a little more to be sure.

- Please note that by following the instructions above, your OLD data should still be intact in that original /Local Storage/ folder so if this doesnt work, you can still send me a zip of your Cosmochoria folder and I can do it for you and send the data back.

Unfortunately because of the way the 32/64 bit build works and the way file permissions are working with node webkit (the wrapper for the game) -- there is no way I can write game code that automatically pulls the old save game out.. unfortunately this conversion process HAS to happen manually for now. But im here to help in any way I can.
stumpy Sep 19, 2016 @ 10:12pm 
Hey Nate, thanks for looking into this and giving us the update. I am happy to hear that the save data is still there! What would be the best way to get my zip file to you?
Blue Wizard Sep 19, 2016 @ 11:23pm 
if you want to send the zip file, you can pass it over with something like dropbox or to -- thanks man!
Lozkinu Sep 20, 2016 @ 12:28am 
I tried doing it manually, and it seem to have worked - for now I don't have time to play - but I'll post a note or send a message I guess if something seem to be wrong with it later.
thanks a lot! :sunracer:
Nate Schmold  [developer] Sep 20, 2016 @ 7:44am 
Nice, i did a bunch of testing last night and things seem to be good - copying the save from the old spot to the new spot should definitely work!
< >
Showing 1-15 of 24 comments
Per page: 15 30 50

Cosmochoria > General Discussion > Topic Details