The Witcher 3: Wild Hunt

The Witcher 3: Wild Hunt

View Stats:
Turnip Lord May 28, 2015 @ 6:30am
does anyone have a fix for the vsync stutter?
the game is running at a solid 60 FPS but the vsync stutter is driving me insane. I've tried changing maximum pre rendered frames and all that ♥♥♥♥ in the control panel but nothing seems to help.
< >
Showing 1-10 of 10 comments
shelledfade May 28, 2015 @ 6:33am 
Download msi afterburner, rtss is included.

1. Turn vsync off in-game.

2. Set the in-game fps option to unlimited.

3. Use RTSS (rivatuner, comes with afterburner) to lock the framerate 1 or 2 frames lower than whatever your lowest in-game fps is. For example if your lowest in-game FPS is 45, you should lock the fps at 44.

The framerate lock option on rtss is faster than the in-game fps lock options so it feels smoother. it's more responsive when it comes to gpu-utilization over the in-game fps locks.

Don't use vsync at all unless you want your controls to feel sluggish. Locking the fps helps greatly in this game. The game stutters very badly even with very minimal fps loss when framerate isn't locked, or if you lock fps and go under your locked value it will stutter again. You need to make sure you lock the FPS just under whatever your lowest in-game FPS is.

Again as an example: If your lowest in-game fps is 45 using unlimited FPS, you should lock it at 44.
Last edited by shelledfade; May 28, 2015 @ 6:41am
Turnip Lord May 28, 2015 @ 6:42am 
Originally posted by Shelledfade:
Don't use vsync at all unless you want your controls to feel sluggish. Locking the fps helps greatly in this game. The game stutters very badly even with very minimal fps loss when framerate isn't locked, or if you lock fps and go under your locked value it will stutter again.
apart from some source engine games, nothing is really playable for me without vsync on. can't see anything through the constant screen tearing and stuttering.

the stuttering I'm experiencing is different from what you're describing. it stays at a constant 60 fps (never below 67 without any limiter, as far as I could tell) but it just stutters every 4-6 seconds when vsync is on. it feels like the cpu is failing to prepare frames for the gpu to render, so it has to stop and wait to receive the frames. there was a cave that for some reason was causing performance loss and when I dropped down to 56-57 it didn't really cause stuttering at all, and didn't disrupt gameplay much. so I don't think it's the same kind of stutter that you're talking about.
shelledfade May 28, 2015 @ 6:45am 
turn hardware cursor on. If you have mouse acceleration on in 3rd party mouse software turn it off, and you should really try my suggestion to see if it helps. Vsync doesn't do anything other than make movement feel sluggish.

Also make sure you play the game in borderless windowed mode. For whatever reason they recommend that over in gog version (what I have) so may help your problem. Game crashes less, has less bugs ect,ect, even some graphical settings like triple buffering and whatnot work correctly in borderless windowed mode while they don't in fullscreen. It is not recommended to use fullscreen for witcher 3, at least for gog version.
Last edited by shelledfade; May 28, 2015 @ 6:47am
Turnip Lord May 28, 2015 @ 6:51am 
Originally posted by Shelledfade:
turn hardware cursor on. If you have mouse acceleration on in 3rd party mouse software turn it off, and you should really try my suggestion to see if it helps. Vsync doesn't do anything other than make movement feel sluggish.

Also make sure you play the game in borderless windowed mode. For whatever reason they recommend that over in gog version (what I have) so may help your problem. Game crashes less, has less bugs ect,ect, even some graphical settings like triple buffering and whatnot work correctly in borderless windowed mode while they don't in fullscreen. It is not recommended to use fullscreen for witcher 3, at least for gog version.
on my end, the opposite of everything you're saying seems to be true. borderless window causes horrendous performance for me, and some of the worst stuttering I've ever seen. and having vsync off makes the game so sluggish and unstable that I'm basically unable to survive fights with the average enemy.
shelledfade May 28, 2015 @ 6:54am 
hm i'm using a single gtx 980 so maybe if you're using sli or crossfire then borderless windowed mode may not be a good idea.

I get better performance in borderless mode than fullscreen, less bugs/crashes.
Turnip Lord May 28, 2015 @ 6:57am 
Originally posted by Shelledfade:
hm i'm using a single gtx 980 so maybe if you're using sli or crossfire then borderless windowed mode may not be a good idea.

I get better performance in borderless mode than fullscreen, less bugs/crashes.
single 970. but, there must be something different about my setup, because if having vsync off was the same for everyone else as it is for me no one would ever play without it.
vonbleak May 28, 2015 @ 6:59am 
I turned in game v-sync off, and set frames to unlimited...then in nvidia control panel i turned on adaptive v-sync - got rid of all my tearing/stutter issues, i use a single 970...
Last edited by vonbleak; May 28, 2015 @ 7:01am
shelledfade May 28, 2015 @ 7:06am 
since you have a 970 I think I can at least try to help you here a bit more.

Reset your witcher 3.exe settings in nvidia control panel to defaults.
Set multi-display/mixed-gpu acceleration to single display performance mode
power management mode - prefer maximum performance
use 16x anisotropic filtering on (better than in-game filtering).
vertical sync off. Triple buffering off, threaded optimization on

Don't touch any other settings in control panel other than these.

lock your FPS with msi afterburner/rivatuner instead of in-game lock, like I said its more responsive with gpu-utilization than the in-game stuff. Even if you have vsync on and your fps is set to unlimited it will cause bad stuttering, you NEED to lock FPS for this game.

Turn off in-game vysnc. Turn on borderless windowed mode.

If you're using a downsample resolution (DSR) in-game, then you have to set your monitor to the same resolution for borderless windowed mode in order for it it to display accurately for DSR and borderless window mode.

Normally I wouldn't recommend borderless windowed mode but its the first thing they recommend people do over there at gog. They even suggest that if you have multiple monitors to unplug them and leave a single display up. The game is pretty damn buggy.

Last edited by shelledfade; May 28, 2015 @ 7:14am
Sniedelwoods Jul 8, 2015 @ 12:39pm 
Hi everyone.
My problem was stutter and fps drops between 50-60 fps.
I turned ingame Vsync off, and turned Vertical Sync "Force on" at nvidia inspector.
Also I set the Frame Rate Limiter at nvidia inspector to 60 fps.
Now stutter is gone and NO frame drops between 50-60 fps.
I hope this fix will help some people here :)

Last edited by Sniedelwoods; Jul 8, 2015 @ 12:40pm
gamertaboo Jul 8, 2015 @ 12:43pm 
I've had great results turning V-sync completely off, and framerate set to unlimited, and that's it. At least give it a try, v-sync only makes the game worse for TW3. At least on my computers.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Date Posted: May 28, 2015 @ 6:30am
Posts: 10