Sid Meier's Civilization VI

Sid Meier's Civilization VI

View Stats:
LionMaks May 23, 2020 @ 5:35am
2K Launcher failure
I can't start the game. It just opens the 2K Game Launcher and it stucks with no error or something, just doesn't respond at all.

Fix it now please!
Originally posted by sercera:
Does the game work if you bypass the launcher altogether?

You can bypass the launcher if you set a special option in the the properties tab of the game (in steam)

To set the special option: right click the game in your steam library and click properties. In the next window make sure you're in the "general" tab and then click the button "Set Launch Options"

In the popup window first place a "
Then copy and paste the install location of the game file (the .exe file that plays the game)
follow that with the name of the .exe file and then close the "
then follow that with %command% (with a space between the last quotation mark and the first %)

Example:

"C:\Program Files (x86)\Steam\SteamApps\common\Sid Meier's Civilization VI\Base\Binaries\Win64Steam\CivilizationVI.exe" %command%

(note - this is just an example --- your install location may differ completely from mine depending on many different things, so doublecheck your install location before doing this)
< >
Showing 1-15 of 83 comments
richard.taylor May 23, 2020 @ 5:50am 
Me too!

It was working and loading just fine until it downloaded an auto-update. Now when I click 'Play' on the launcher window it just shuts down the window and nothing happens.
Ashen Shugar May 23, 2020 @ 6:09am 
Same issue here
Silly Kitty May 23, 2020 @ 6:13am 
Having issue with error saying: 2k launcher has stopped working.
This then shut and game does not start. Is this same issue for anyone else?
Navin May 23, 2020 @ 6:19am 
Same issue here
Ashen Shugar May 23, 2020 @ 6:28am 
I kind of funny i buy a dlc and now the game stops working. Slow clap well done.
t.d.w.82 May 23, 2020 @ 8:25am 
Такая же проблема
jfmerdinger May 23, 2020 @ 10:56am 
same issue...
desmond.wang May 23, 2020 @ 12:30pm 
Same issue here. Clicks on "Play", then launcher disappears, but game doesn't launch. Happened after the update.
Mech03 May 23, 2020 @ 12:45pm 
me too, anyone fix this
rdBala May 23, 2020 @ 12:49pm 
This is happening to me with Xcom and Civ 6... seems like it is all 2K games that use the launcher. WEAK
Jaeger Sylva May 23, 2020 @ 1:27pm 
Mine will load, but all load times are increased like 10-fold. Over a minute to change over turns, even in the ancient era with one city and a warrior.
The author of this thread has indicated that this post answers the original topic.
sercera May 23, 2020 @ 1:35pm 
2
Does the game work if you bypass the launcher altogether?

You can bypass the launcher if you set a special option in the the properties tab of the game (in steam)

To set the special option: right click the game in your steam library and click properties. In the next window make sure you're in the "general" tab and then click the button "Set Launch Options"

In the popup window first place a "
Then copy and paste the install location of the game file (the .exe file that plays the game)
follow that with the name of the .exe file and then close the "
then follow that with %command% (with a space between the last quotation mark and the first %)

Example:

"C:\Program Files (x86)\Steam\SteamApps\common\Sid Meier's Civilization VI\Base\Binaries\Win64Steam\CivilizationVI.exe" %command%

(note - this is just an example --- your install location may differ completely from mine depending on many different things, so doublecheck your install location before doing this)
Mech03 May 23, 2020 @ 3:05pm 
tried that still wont load, and error states " file config.json isn't exist. launcher will be closed. "
ender732 May 23, 2020 @ 5:04pm 
Originally posted by sercera:
Does the game work if you bypass the launcher altogether?

You can bypass the launcher if you set a special option in the the properties tab of the game (in steam)

To set the special option: right click the game in your steam library and click properties. In the next window make sure you're in the "general" tab and then click the button "Set Launch Options"

In the popup window first place a "
Then copy and paste the install location of the game file (the .exe file that plays the game)
follow that with the name of the .exe file and then close the "
then follow that with %command% (with a space between the last quotation mark and the first %)

Example:

"C:\Program Files (x86)\Steam\SteamApps\common\Sid Meier's Civilization VI\Base\Binaries\Win64Steam\CivilizationVI.exe" %command%

(note - this is just an example --- your install location may differ completely from mine depending on many different things, so doublecheck your install location before doing this)

This worked for me. I'm on Rise & Fall only, did not purchase new DLC or pass. Was having issues with the 2K launcher just not working (it would open from Steam, I would click the button and the window would close and Steam would just revert back to the "Play" button as if nothing happened.

So it seems the issue with the new 2K launcher that they've forced on us.
Ashen Shugar May 23, 2020 @ 6:39pm 
Tried the above fix no change for me system

i9 9900kf
Gigabyte Z390 Aorus master
32GB 3200 ram
980ti 6GB
W10 pro.

I always appreciate game devs releasing updates at close of business on a friday, cause nothing ever goes wrong... ♥♥♥♥♥♥♥ morons.
< >
Showing 1-15 of 83 comments
Per page: 15 30 50