X Rebirth

X Rebirth

View Stats:
X Rebirth > General Discussions > Topic Details
BaElzaden Nov 15, 2013 @ 7:00am
DEVS(replies from the CEO) - Bugs, features, optimization and simple fixes.
Hello Devs and fellow players!

*READ*------->*ANSWERS BY EGO_zav CEO at post #258 and #296, page 18 and 20 on THIS THREAD*<------ *READ*

If any of you notice bugs etc, do say on this thread and i will update the thread with them.

This is a compilement for the devs to see (posting this to the egosoft forums later on).

If you find me repeating the same bug or anything on the list, let me know.

Keep it nice and clear, useless spam posts is not the way to go here.

English only, so everyone will understand what you are saying.

*UPDATED* *3 new features and 1 new bug*



- Bugging animations
--> Walking through Albion skunk doors and the pilot chair when returning to ship from a station(loading the game again helps here).

- Selling goods
--> Ordering a ship to sell goods during the first selling mission. The ship wont move to sell the goods to the allocated station you ordered the ship to sell (i dont see any option other than buy the wares again from somewhere and try again UPDATE: Tried it again, the ship starts going to another place to sell the wares, even if i flew to the Lonely Giant and pressed sell).

- Bug While trying to hire a captain for freighter it is possible to get stuck in the lockers if you search them for loot.

- You can get stuck in structures by boosting in it.

- Robots on some stations can push you to a wall, you get stuck inside the robot and move with it.

- Stuck in crew quarters. Accessed the menu whilst on flight (Enter > Crew). Can't reenter cockpit. The keypad to cockpit doesn't "reset" for me to be able to reenter cockpit when I load the saved game.

- Can't save the game, when saved, it freezes and an error pops up.

-When leaving a station the ship control defaults to direct control, this usually means when you undock your ship instantly starts spinning in the direction the mouse is pointed, causing unwanted bumps with the station.

- Betty is not speaking at all in german setting.

- Mining laser sometimes has no sound or animation.

- Sometimes opening the trade menu doesn't show the trade screen but allows you to move up and down.

- Trade ship won't load the Energy Cells in the 1st trade mission.

- No targeting hotkeys.

- Bug where information console on the ship dont show up,makes it difficult to look at the map and read the quest information and to complete transfers.
-->"I have more infos on this. This happens, if you exit a station via Menu (Leave Station). When you enter your ship via the door, then this console and map comes back." - Aisling

This is a horrible bug, because this is in the savegame. So if you enter the ship always via menu, then the player fly without map etc. It's a gamebreaker. I was glad to find out how to get this back.

- Ships in highways just despawn as soon as i leave the highway, there is no traffic comming out of those highways at all, while the traffic inside is crazy (this IS a bug, isn't it? i mean.. every ship has a purpose and a destination in x-games, no?).

- If you use the vent cover at the cover it lifts up and pins you to the wall, you then cant use it again to close it so a reload is required.

- Game crashing while saving. The save gets lost because of it.

- Double clicking a station with docking options or selling options, sometimes you cannot get the option out without first reloading the game.

- When launching a new game, right after the initial loading screen, the screen turns black with only the mouse being visible. Meanwhile an error popup for crash and crashdump occurs on desktop (can hear the windows error sound).

- The hud freezes some times when trying to raise the show information of a ship or "i" station parts

- When exiting game(?) Saved dump file to XU_2013_11_15_17_55_38.dmp

- Failed to save dump file to 'XU_2013_11_15_19_14_51.dmp' (error -2147024865) and the game crashes while starting.

- Sometimes when a save game is loaded, it's just black screen with crosshair.

- When you open the vent door and standing close to it, it lifts you up and you are stuck forever.

- When exiting the highway on the way to buy solar cells you end up flung into empty (void) space around 1,400,000 KM from my objective.

- After loading the cursor vanishes.

- Game crashes to desktop, mentions a dmp file with the date/time happened. More info on the error on post #158 on this thread by AbraxasTBC

- *SPOILER* Story mission: When I'm told to go to look for terran shield (talking to a NPC) I can't buy shields (set to 0, 10 available, but bar stuck on 0).

- *SPOILER* Story mission: When I need to hack a station, i get to where we are asked to, an information point, I select "hack" and nothing happen. Mission objective "hack station" pop up again the same time.

- When choosing station scanning mode, if you select the crew from menu and walk to the back of the ship you cannot switch off the station scanning mode when you return.

- Invet mouse pitch not working for some.

- Cannot change the job of a defence officer on my transporter, if trying to change it, it jumps right back to the original job it had before.


- Add an option to zoom in and out with mouse scroll when looking the map (havent noticed if an option to do that is already in there).

- Autotravel system option - inside Highways and Sectorswaps.

- Overhaul UI - its horrible and the font is too small.

- Highres Textures and Revamped Models inclusive Facial Animations.

- Improved AI.

- Unlock AF in Options.

- Better Indicator for "Missions/Quests" for example a "blue line".

- Something to actually see your own ships, they seem to just randomly appear and disappear (green lines around the ship should be seen sooner).

- External view.

- Add a SINZA like device no one likes it to wait 20 min in real time just for the freighter to dock for a single story mission.

- The graphical options don't offer enough tweakage to get the game running smooth

-Have some info in the optinos menus about what a different option does when toggled ON/OFF. Especially in graphics options.

- Targeting hotkeys

- Add an option to talk to the people on station with coms after you have met them once(might be one already? thought to add this anyway).

- Give a possibility to skip animations such as conversations.

- Animation to actually see the ship docking the shipyard/station as it flies inside.

- Mapping mouse buttons.

- Borderless windowmode.

- Low, medium, high and ultra graphics presets.

- "An option to shut off some of the more intensive post processing effects. while it might not be pretty, it would be of immense help to those that have meduim level pcs and those on mobile platforms (medium to high grade laptops which at this point in the digital future accounts for a LOT of the pcs out there)" - letalis001

- Have a list of your ships, what they are doing right now

- If one ship has more jobs: like buy stuff at this station and the second job: sell this stuff at that station, show the somewhat estimated time until it finished all job

- Be able to select/mark ship/stations on your maps again.

- AUTOSAVE (with all these crashes happening!!)


- Bad optimization in most areas, fps dropping a lot in small areas also(someone has said something about a fix to this?)

- "Game executable is 32 bit and memory usage is limited to 2.3GB. Is this why we all lag?" - Riful

-"Shadow maps are poorly focused (taking camera perspective into account should help to increase the focus area). Take a look on alternative techniques such as CSM or VSMs." - Xugar

-"FPS drop should not be that dramatic as it is, make sure to meshes with same material together to minimize material shader program swaps." - Xugar

A list of some simple fixes from other people:

- "If you get stuck on something while on a station (happened to me on a grate), try hitting enter to bring up the main menu, then 5 and 5 again to return to the ship. This enabled me to get unstuck without having to reload" - Reaper

- Fix for the disappearing mouse cursor
Control Panel:
Disable mouse trails
Disable disappearing cursor when typing - S The Viking

Energy cell story mission:

Originally posted by Jimddu:
Originally posted by Aristagoras:
If you experience the dreaded "TOO MANY TASKS" error simply open your savegame (documents/egosoft/XRebirth/12345/save) in any XML-capable editor, search for OWNER="PLAYER" (no caps) and then just find your energy trader. There shouldn't be too many entries for your property. Go to the [trade] and then [shopping] section, delete those three (!) trade orders, save the file.
Reload the savegame, issue the trade order for e-cells, done. That actually worked for me - finished the mission in less than 5 minutes. This is more or less a workaround for the coming CANCEL button in the trade menu ;)

It worked for me !!

-open your savegame file in wordpad for example
-ctrl+f to open a searchbox and type "shopping"
-delete the lines between the shopping entries
-save and reload

bump and thx Aristagoras for this, hope it will works for you

Updating this if/when more things come up.


**UPDATED 15.11.2013 23:25 cet+2**
Last edited by BaElzaden; Nov 16, 2013 @ 10:36am
< >
Showing 1-15 of 1,330 comments
Operator175 Nov 15, 2013 @ 7:08am 
Bug In flight I enter crew quarters to speak with freighter captain before delivery, I click door control to return to cockpit and turn back to see if I missed something in crew bay. Door closes and control to cockpit does not work anylonger,It does not light up when cursor is over it. I had to load a quicksave to move on
Operator175 Nov 15, 2013 @ 7:10am 
Bug graphical glitch on the sales screen where the asteroids behind were showing through and making text unreadable.
Operator175 Nov 15, 2013 @ 7:10am 
Bug While trying to hire a captain for freighter it is possible to get stuck in the lockers if you search them for loot
Karl Nov 15, 2013 @ 7:16am 
The forum crashed so I guess I'll post here.

Now I'm stuck at the ship INFO window. Clicking on those "i" info icons on stations in the beginning. It's as if the buttons on the window wasn't toggled or something, anyway I'm still stuck at the window. The game is still running, did not crash. Also, double-clicking on stuff proved to be quite difficult, and I'm sure I double-click right on the icons.

On a rig with 280x graphic card with latest driver so I don't think I'm having any technical issues other than the software.
Urbanwastelander Nov 15, 2013 @ 7:18am 
I cannot see my weapon huds or sheild hud they are black?
Sumeragy Nov 15, 2013 @ 7:18am 
@Kaiserkev I have the same bug whit the selling Window it helps to alt+tab change to windows and back into the game. But trying again will get u stuck again...
Rekalty Nov 15, 2013 @ 7:18am 
"There are too many trips planned for this ship"
And you can do nothing about it what so ever...
EternalCore Nov 15, 2013 @ 7:22am 
The game needs a Highres Textures pack!
Rob Graham Nov 15, 2013 @ 7:22am 
bug crash to desktop on launch, sound card fix NOT working, error dumps already posted in the other thread.
Belle o' Delphine Nov 15, 2013 @ 7:23am 
Can't save the game, when I do it freezes and an error pops up
TinyBabyOwl Nov 15, 2013 @ 7:23am 
Originally posted by Crushington:
I noticed a bug: X-Rebirth. My suggestion to the devs: Develop a finished, working product before releasing it.

danskmacabre Nov 15, 2013 @ 7:24am 
I personally had fairly decent performance as it was.
however if you use a Nvidia card and set up a custom profile for this game in the nvidia console, then override EVERYTHING. the performance is increased and the graphics are a LOT better as well.
I maxed out everything on my rig and it plays fine.

8Gb ram
Windows 7 64 bit
250GB SSD drive
AMD FX6300 6 core CPU (3.5 ghz)
Nvidida Geoforce GTX660 (1 GB ram)
Nick Chronic Nov 15, 2013 @ 7:24am 
there is no 1080 settings . gpu 40% cpu 30% = 15 fps (WTF)

MSI R7950
Last edited by Nick Chronic; Nov 15, 2013 @ 7:25am
Gordini Nov 15, 2013 @ 7:24am 
Originally posted by Crushington:
I noticed a bug: X-Rebirth. My suggestion to the devs: Develop a finished, working product before releasing it.

Guess you never played a Egosoft title on release day before.
Dersh Nov 15, 2013 @ 7:24am 
When I am interacting with a merchant npc every time I click one of the interaction menus the npc does some kind of squat lol.
< >
Showing 1-15 of 1,330 comments
Per page: 15 30 50

X Rebirth > General Discussions > Topic Details
Date Posted: Nov 15, 2013 @ 7:00am
Posts: 1,330