Tabletop Simulator

Tabletop Simulator

View Stats:
Tabletop Simulator > Bug Reports > Topic Details
This topic has been locked
Kimiko Mar 18, 2016 @ 4:12pm
Beta Branch - Unity 5 Bug Reports & Issues
Please post all your findings here of the beta branch version of Tabletop Simulator with Unity 5.

To opt in to the beta, right click on Tabletop Simulator in your Steam library, then click Properties. There will be a new “Betas” tab. At the drop down menu choose “beta - Unity 5”. If it asks for a code, you can ignore it, as you will get the download.

Minimum requirements Windows XP SP2
Minimum requirements Mac OS X 10.8

Known Issues:
  • Concave/Nonconvex colliders are only supported for locked objects.
  • Touch input is currently disabled for porting to Unity 5.
  • Tablet not working in Linux.
  • Voice chat too low - FIXED!
  • Black color text hard to read.
  • Linux & Mac: If your GPU/drivers don't support OpenGL 3.0 or higher, you will need to add -force-opengl to your game launch parameters to fallback to the old Unity OpenGL renderer.
  • Trash can bug when hovering over it in Workshop/Save&Load menus. - FIXED!

Linux Issues:
  • All sounds aren’t working on Linux.
  • Add -force-opengl to the launch parameters otherwise the game will crash. This is a Unity bug in Unity 5 that Unity is planning on fixing at some point.
  • If sound isn't working: If you're using pulseaudio, try reinstalling pulseaudio. If you are not using pulseaudio, remove or rename the pulseaudio libs in the Steam Runtime to something else.
Last edited by Kimiko; Mar 28, 2016 @ 2:51pm
< >
Showing 1-15 of 31 comments
Bustok Mar 18, 2016 @ 7:06pm 
chat voice too low, i can't hear other players
skully1308 Mar 18, 2016 @ 9:14pm 
Originally posted by Bustok:
chat voice too low, i can't hear other players
Cubic's Rube Mar 19, 2016 @ 9:07pm 
I can also confirm. Chat voice is super low, impossible to hear others.
Kitsune Zeta Mar 20, 2016 @ 4:38pm 
Colors seem to be a little weird in the notebook...

http://steamcommunity.com/sharedfiles/filedetails/?id=649515711

http://steamcommunity.com/sharedfiles/filedetails/?id=649516690

I have no idea what causes the issue. Windowed Mode and resolution don't affect it.

[edit: I can reliably trigger it by loading any saved game or workshop item. I haven't tried it with a game saved using the Unity 5 Beta yet, but I do know this issue is Beta-specific]
Last edited by Kitsune Zeta; Mar 22, 2016 @ 2:21pm
Knil  [developer] Mar 21, 2016 @ 3:02pm 
Hotfix now live.

Fixed Lua scripting GetTable()

Beta - Unity 5:
Fixed threading mod loading on Linux
Fixed tablet not working on Windows and Mac (Linux still broke)
Fixed voice chat volume being way too low
Fixed non-convex objects falling through the table
Knil  [developer] Mar 22, 2016 @ 10:11am 
Hotfix

Beta - Unity 5:
Fixed voice chat not working (for real this time!)
Fixed end turn button making button sound twice.
ryan Mar 22, 2016 @ 7:16pm 
anything i can do to improve the performance of the unity 5 build? i had to revert to the live version because of stuttering performance issues.
Aro Mar 22, 2016 @ 9:29pm 
Mmh ok ran in to a bug twice now, not sure of the cause though.
When I try to type something in the scripting window it "scrolls" to the bottom hiding everything and makes the scroll bar small. Dragging the scroll bar up reveals the entered/changed text but any attempt to interact again does the same result. Fix is to exit to main menu then load back in to the save.

No idea how to reproduce nor the cause, could record it the next time if it happens but not sure how much help that would be.
Knil  [developer] Mar 22, 2016 @ 9:47pm 
Originally posted by rybaby:
anything i can do to improve the performance of the unity 5 build? i had to revert to the live version because of stuttering performance issues.

Would love to get some more info was it on a particular workshop mod? Performance should definitely be improved in the beta build.

Some more info in general would be awesome.
Kimiko Mar 23, 2016 @ 10:09am 
Hotfix Unity 5 Beta 3:

If you made any saves with infinite bags in the Unity 5 beta clients you might have some garbage objects in your save. When loading saves we will detect these garbage objects and will not load them. If you re-save these files they will be fixed.

Hand Improvements:
Cards in hand will now use the entire width of the hand allowing massive hands.
Improved the layering effects to be less linear.

Bugs:
Fixed cloning infinite bag bug creating garbage in save file.
Fixed jittering cards in hand and other issues.
Fixed tablet working on Mac and maybe on Linux.
Dudrie Mar 23, 2016 @ 12:26pm 
I recognized that it's extremly difficult to hit the "Delete Save Game"-Button next to a sva game in the save/load menu because it's disappearing very fast. You can hit it if you move your mouse to it over and over again. But most of the time the button will just disappear.
HansKlopek Mar 23, 2016 @ 7:26pm 
I noticed a little bug. In the beta, there appears to be an issue with pasting copied text using the CTRL-V method in the scripting dialog box. It appears to work fine in other areas (notes, rules, etc.). It works ok with the non-beta version, just an issue with the beta.
TDuncker Mar 24, 2016 @ 5:25am 
I don't know if this is a beta bug, but it's happened thrice to me now after I changed to the beta and I don't recall ever noticing it before in TTS, but I've seen it in other games.

Sometimes my mouse gets misaligned, so that the actual point it'll press on and the point my cursor is on aren't the same; it'll click like 1cm above where I hold my cursor. Example would be pressing "Multiplayer" and it'll press "Singleplayer" which is right over it in the menu. I can even see it highlight singleplayer instead even without my cursor on it, so I know it'll hit that.

A quick restart fixes it whenever it happens.

EDIT: Just had 4 launches in a row where I kept restarting, since it did it. After 4 restarts, I decided to opt out of beta to check and it immediately worked fine again.
Last edited by TDuncker; Mar 24, 2016 @ 11:28am
Kitsune Zeta Mar 24, 2016 @ 7:19am 
Originally posted by Dudrie:
I recognized that it's extremly difficult to hit the "Delete Save Game"-Button next to a sva game in the save/load menu because it's disappearing very fast. You can hit it if you move your mouse to it over and over again. But most of the time the button will just disappear.
So that bug's not just in the Workshop game list, then?

Unless the "Saved Game" menu is also getting an overhaul/replacement (I don't think the playerbase would mind), the bug can get moved out of "wontfix" then. I had a brief chat with Kimiko when I found the bug in the workshop game list, and Kimiko said that it's likely not getting fixed in the beta branch since the Workshop menu's being outright redone (probably as part of the Game Manager thing). I wouldn't be surprised if the saved game menu also gets axed in the process of this.

[edit: read The Scoop #12. Last paragraph under Future Updates confirms the Workshop and Save/Load menus are being redone into the new "Game Manager" window. So, yeah, looks like this is staying in wontfix for the moment.]
Last edited by Kitsune Zeta; Mar 24, 2016 @ 7:21am
Beef Mar 24, 2016 @ 11:27am 
Theres a bug where when trying to delete things from your saved objects, when you hover over what you want to delete and go to the trash can, it dissapears before you can click it.
< >
Showing 1-15 of 31 comments
Per page: 15 30 50

Tabletop Simulator > Bug Reports > Topic Details
Date Posted: Mar 18, 2016 @ 4:12pm
Posts: 31