RollerCoaster Tycoon: Deluxe

RollerCoaster Tycoon: Deluxe

SirNailik Jun 29, 2014 @ 4:06am
(Error trapper) Looking for help.
I am getting a error saying this-

Error Trapper
Exception Raised - Access Violation
Error Location Windows Display Drivers

I have look all over online but can not get a anwser on how to fix this problem. I wished I known it was going to be this much of a problem getting this all set up. People help me and other figure this problem out.
< >
Showing 1-15 of 18 comments
jensj12 Jun 29, 2014 @ 11:19am 
Have you tried using compatibility settings? (win95, winxp, run as administrator, probably even some of the others) Might also be helpful, which OS do you run?
SirNailik Jun 29, 2014 @ 11:59am 
I am running Windows 7 64bit, However I have tryed change the compatibility and all of those things. It seems to keep on saying the error lays with in the display drivers. I always have all my drivers up to date, and every thing else. This problem also happen to me with warcraft 3 in the past, I could never get that to run. Hmmmmm.
Rococo Cupcake Jun 29, 2014 @ 5:20pm 
I have exactly the same problem. Searching for answers on what to do... :/
jensj12 Jul 1, 2014 @ 12:58pm 
Sometimes reinstalling the game and rebooting just fixes it. Just try every option you have and someday it may work. Also try the setting within steam (checking files ect)
SirNailik Jul 1, 2014 @ 6:35pm 
Yeah, I have tryed alot of things. I am just going to have to wait until I can upgrade my computers parts again to I can reinstall my OS. I think it is my OS, at this moment. I was on my friends windows 8 computer and it worked fine, with out having to change its settings, she could also save with out a problem. However I have better parts in my computer then her computer, So I just think it is my OS is just out of data or need to be reinstalled. I have not reinstalled it for around last year almost two, when I upgraded the parts. I will be upgrading it again in the next three weeks when I go back to college. If it is my OS needing to be reinstalled I will posts on this again.
jensj12 Jul 2, 2014 @ 2:52pm 
This might work for you: Go to your advanced system settings, advanced tab, performance settings, DEP and add RCT.exe to that list.
SirNailik Jul 3, 2014 @ 5:19am 
I have tryed this also, I still had not effect. Like I said in the past I had the same problem with warcraft 3. Thanks for the suggestion though.
Last edited by SirNailik; Jul 3, 2014 @ 5:19am
jensj12 Jul 3, 2014 @ 5:25am 
Don't ask me why, but I suddenly get the same error now with the cd-version of the game. I'll post it here as soon as I find a solution for it.
SirNailik Jul 3, 2014 @ 6:40am 
sounds cool, thanks for the help.:tdealwithit:
addictinggamer728 Jul 18, 2014 @ 12:09pm 
So I had the same problem come up on mine, I'm running Windows 8.1 64bit and I solved the problem by first running it in comparability mode as an administrator and setting the resolution in the game to the minimum setting. I was literally trying anything and this worked. Hope this helps.
xitzwotsit Sep 30, 2014 @ 3:02am 
how can i run this in admin mode through steam? also what is comparability mode
MattTheInsane Dec 2, 2014 @ 5:29pm 
Dead thread but just giving a headsup.

Error trapper is bassically a regular old crash. There really is no solution other then to play a different scenario or play a save earlier then from the crash and run from there.

If this keeps happening try doing some troubleshooting. Figure out when it happens and what you did immediatlly before.

Keep doing the same thing to see if it repeats itself and simply avoid doing that one task.

There isnt a fix mainly because chris sawyer made a game in assembly and used alot of shortcuts making an imperfect game...

sorry if this wasnt the help people were looking for but this is pretty much the only thing within 15 years people have come up with that works.
skuski Mar 12, 2015 @ 6:45pm 
Fairly positive this is graphics card related... I have a GT 540M. Within the last month or so I have not been able to launch Sim City (2013), RCT2, Star Wars Republic Commando, Star Wars Starfighter or RCT... RCT2 gives me an error that it cannot detect a video card. Not sure what these games have in common, as other games seem to work fine.
f203ga Apr 19, 2016 @ 2:56am 
I always get that error at the end of the Evergreen Gardens senario, on the last day as I'm about to finish it. I've uninstalled and reinstalled the game a few times, deleted all traces of the game from the registry before reinstalling, trying various compatibility settings, used both the motherboard graphics and separate graphics card and still have no success. I'm running a Windows 10 machine. Does anyone have any more solutions for me to try?
Sn45 May 5, 2016 @ 5:16pm 
was having this issue, change display resolution from 1920 x 1080 problem solved. game works great (not full screen ) was able to get 90% by adjusting my monitor and other settings.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50