RollerCoaster Tycoon World

RollerCoaster Tycoon World

 This topic has been pinned, so it's probably important
Seifer Apr 1, 2016 @ 9:13pm
57% Crash - WORKING SOLUTION!
Okay. I've spent hours trying to get into RCTW but the game always crashed when the loading got to 57%.

HERE IS THE SOLUTION

1. Open Steam, go to Library > Games screen.
2. Right-click RollerCoaster Tycoon World
3. Select Properties
4. In the "General" tab, click Set Launch Options
5. In the box provided type "-force-d3d9" (without the quote symbols)
6. Hit Ok & Close
7. Launch your game


IF YOU GET THE PINK SCREEN WHEN YOU START A SCENARIO:

1. At the main menu, click Options
2. Click Graphics
3. Set everything as desired (recommended max on everything according to Nvizzio)
4. Set HBAO+ to DISABLE (this is what gets rid of the pink!)
5. Launch a scenario


NOTE about Graphics settings

Make sure to check your graphics settings EVERY time you are about to change scenario or re-launch the game.
Mine keep resetting to some kind of default (even if I haven't quit the whole game.)
Last edited by Seifer; Apr 2, 2016 @ 7:44am
< >
Showing 1-15 of 146 comments
Seifer Apr 1, 2016 @ 9:18pm 
*bump*
SteelFyre666 Apr 1, 2016 @ 10:03pm 
uninstalled steam and RCTW then reinstaled using default
then followed the above.

THANK YOU SO MUCH Seifer that worked for me!

Now on to the fun!
bobertadam Apr 1, 2016 @ 10:08pm 
it worked for me!
Higgins Apr 1, 2016 @ 10:21pm 
You're a real one! Thanks man.

Hey_Bail Apr 1, 2016 @ 10:28pm 
WOW!!! IT WORKED!!!! THANK YOU!!!!
Poppy5686 Apr 2, 2016 @ 3:03am 
It works but my peeps animation is really buggy and after a while they stop walking and only fly up an down as if you pick them up and drop them again. but all at once. When that starts it becomes impossible to build anything. Does anyone else have this issue who had the 57% problem before ? Any ideas how to fix it ?
Dannyslinn Apr 2, 2016 @ 3:03am 
I think it's funny that he can fix it while the developers don't seem to have a clue. Well done to you :-)
patrickb1973 Apr 2, 2016 @ 3:17am 
This worked, thanks.
I got never this Problems.. I just say Good Job :)
Seifer Apr 2, 2016 @ 3:20am 
Originally posted by Sonja:
It works but my peeps animation is really buggy and after a while they stop walking and only fly up an down as if you pick them up and drop them again. but all at once. When that starts it becomes impossible to build anything. Does anyone else have this issue who had the 57% problem before ? Any ideas how to fix it ?


I too had this issue at some point. I don't think it's related to the 57% bug.

Mine happened right at the beginning of the scenario.
I also couldn't build anything unless I raised it 8ft above the land.
Then I couldn't connect paths to the rides because the paths couldn't go lower than the 8ft either.

I restarted the map twice, and the third time it worked. I built a bunch of stuff, then went to bulldoze a staff entertainer building and EVERY ride/building got bulldozed all at once.... and the peeps started flying up/down again.
patrickb1973 Apr 2, 2016 @ 3:23am 
The problem is not related but had the same problem just now, had to restart my game to fix it again, really annoying that i have to start over again
Seifer Apr 2, 2016 @ 3:30am 
Originally posted by patrickb1973:
The problem is not related but had the same problem just now, had to restart my game to fix it again, really annoying that i have to start over again

I saved my game and the first few times I loaded it the peeps were still stuck in the up/down glitch, but I just loaded my save again just now and they weren't glitched out.

Maybe try saving and loading it up a bunch of times to see if it sorts itself out.
Ginryu Apr 2, 2016 @ 3:42am 
Tank you very very very very very much...
Dannyslinn Apr 2, 2016 @ 4:16am 
I still end up with pink screen when settings are put to high. it then crashes. how annoying
Poppy5686 Apr 2, 2016 @ 4:18am 
Thanks it works now. You're awesome.
< >
Showing 1-15 of 146 comments
Per page: 15 30 50