Stellaris

Stellaris

View Stats:
Stellaris > General Discussions > Topic Details
Mods not downloading properly
Stellaris mods aren't making the files in Documents\Paradox Interactive\Stellaris\mod that they're supposed to, for some reason, so the game isn't registering the mods I'm downloading.

It mostly happens with some mods I had to try to delete from my computer a while back, and now those mods (most of which are some of my FAVORITE mods) are NOT being redownloaded properly.

Their Workshop Content files are showing up properly, but the mod folder files that're supposed to link to them are NOT being downloaded...

Anyone have any idea what I need to do to fix this? Already tried:

-Verifying Game Integrity
-Unsubbing and Resubbing from mods
-Uninstalling and Reinstalling Stellaris
Last edited by Kamen Rider Nexus; Sep 26, 2020 @ 4:51pm
< >
Showing 1-7 of 7 comments
Yeah i have this problem, was using mods just fine one day and apparently gone the next. The mods are the only reason ive poured so many hours into the game not their stupid new species dlcs. If i wanted cool new species i would go to the workshop, if i wanted a new shipset i would go to the workshop, if i wanted new civics again i would go to the workshop. Just about time to wash my hands of this game for good.
If you're going full Nuclear option and hard re-installing steam you'll have to clearn the mod folders as well, make sure the entire root and all documents are 100% clear. Rebooting steam helps, since this isn't entire a paradox issue(steam is known to be glitchy and it's reading the mods from a STEAM account). Thi is a compatability issue, reset steam if you plan to do this.
Kamen Rider Nexus Sep 27, 2020 @ 10:41pm 
I'm not gonna be reinstalling Steam...have WAY too many games that I'd have to reinstall if I did that...As for restarting Steam, that's something I did do, but apparently forgot to list, so... ... ...
Ajey Sep 27, 2020 @ 11:18pm 
go to documents/paradox interactive/stellaris/mod => delete all .mod files
=> after next launch of stellaris you should reload the .mod files automatically and your mods should get updated
Yeah ive done that, however, the problem has always been that i have actually had the files all along but the launcher just isnt recognizing them no matter how many times i redownload them or resubscribe
Kamen Rider Nexus Sep 28, 2020 @ 2:58pm 
Yeah, with me, its the fact it just flat out won't download the .mod files...not even starting the launcher will provoke it to do so...
Kamen Rider Nexus Sep 28, 2020 @ 10:36pm 
Ended up frustrated and did multiple things at once to try to fix it...and one of them worked...
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Stellaris > General Discussions > Topic Details
Date Posted: Sep 26, 2020 @ 10:08am
Posts: 7