No Man's Sky

No Man's Sky

View Stats:
No Man's Sky > Technical Support > Topic Details
This topic has been locked
Khelvoryk Aug 13, 2016 @ 2:15am
PC USERS : Incredible FPS fix !
I don't have the game, but one of my firends have it and told me about this fps issue.

So, I saw on Reddit someone post a fix for this, and my friend told me that it worked (120 FPS max, 60 FPS with no lag).

This is what the guy says:
"Go to : C:\Program Files (x86)\Steam\steamapps\common\No Man's Sky\Binaries\SETTINGS

Then find the file "TKGRAPHICSSETTINGS.MXML" and open it.

You will then find the "GSync" option. It's "true" by default, change it to "false".

I'm personaly running NMS on a computer that doesn't even have the minimum config', i can tell you the FPS boost is absolutely amazing.

Seems to work for most people as well !

EDIT : I'm not the one who found the fix, i'm just spreading the information.
"

I hope it can help you

Source: The post on reddit
Last edited by Khelvoryk; Aug 13, 2016 @ 5:48am
< >
Showing 1-15 of 86 comments
CaptainSuperSlow Aug 13, 2016 @ 2:16am 
Works 100%. Thanks. Smooth as butter now.
alarai Aug 13, 2016 @ 2:39am 
Don't seem to be an universal solution, just tested and no increase at all. Still barely above 30 fps in 1360*768 with a GTX 1080. Guess it probably relives a lot on some systems.
Elgar Aug 13, 2016 @ 2:43am 
Originally posted by alarai:
Don't seem to be an universal solution, just tested and no increase at all. Still barely above 30 fps in 1360*768 with a GTX 1080. Guess it probably relives a lot on some systems.

I have a GTX 1070 and I'm always between 100 and 130 fps. You have to turn off v-sync and choose max for the fps setting, in the graphical settings.
JordansMoves Aug 13, 2016 @ 2:44am 
"False " on gSync. Wow! What a difference!!! I think I can up my res now!

Win 7
Bootcamp Laptop
nVid 750m
16gig ram
Last edited by JordansMoves; Aug 13, 2016 @ 2:45am
Graysparv Aug 13, 2016 @ 2:51am 
Lol, the game went from ok to smooth as butter, thank you very much!
alarai Aug 13, 2016 @ 2:59am 
Originally posted by Elgar:
Originally posted by alarai:
Don't seem to be an universal solution, just tested and no increase at all. Still barely above 30 fps in 1360*768 with a GTX 1080. Guess it probably relives a lot on some systems.

I have a GTX 1070 and I'm always between 100 and 130 fps. You have to turn off v-sync and choose max for the fps setting, in the graphical settings.

Wow, thanks. It seems that actually the buggy thing is the max ips, changed it to 90 with vsync and I got 60 fps. Though it introduces some stutters. Unlimited and vsync off has lot of stutters.
Z~ Aug 13, 2016 @ 2:59am 
This really needs to be stickied, haven't had time to test it much, but no stutters after implementing the change.
Monthis Aug 13, 2016 @ 3:05am 
I disabled vsync and gsync and set the max fps to 90 and that fixed about 90% of the problems. Of course there's a lot of tearing but it beats what was happening before. Only problem I have left is after about 1 or 1.5 hours of gameplay the FPS takes a dive and doesn't recover. I have to restart the program. Running just a 960 2GB and an old i5-2500k...
Alucard Aug 13, 2016 @ 3:06am 
How do we do when we have a G-Sync monitor?
TheKildar Aug 13, 2016 @ 3:06am 
No real change for me, I have tried every fix and combination of fixes that I can find, still can't get above 36 fps maximum, with frequent drops/stutters. My setup should def be able to handle this game on max settings, but nope. Also still drops frames when i get in my ship too.
Irot Noot Aug 13, 2016 @ 3:42am 
Excellent tip, worked for me as well.
Cal Varrus Aug 13, 2016 @ 3:52am 
Works. This should be pinned.

GTX 760 i5 4670K

Really helped. I was able to switch some settings to High.
Cal Varrus Aug 13, 2016 @ 4:04am 
Originally posted by TRON:
didnt do nothing at all.

Did it do Anything since it didn't do nothing?
CpTm4rksm4n Aug 13, 2016 @ 4:08am 
didnt work for me
OxKing Aug 13, 2016 @ 4:10am 
I just had to carry my pc home from a friend to have good FPS and no stutters anymore. lol
There it was connected on his Samsung TV (no 4k) via HDMI. Now im using my Display Port.
I don't know it it was that, the Rebooting or the internet connection at him. But now it works great.
< >
Showing 1-15 of 86 comments
Per page: 15 30 50

No Man's Sky > Technical Support > Topic Details
Date Posted: Aug 13, 2016 @ 2:15am
Posts: 86