No Man's Sky

No Man's Sky

View Stats:
No Man's Sky > Technical Support > Topic Details
Neksu Aug 15, 2017 @ 2:32am
Low res textures on AMD drivers?
So I just bought the game yesterday since the new update came out, and the game finally seemed fun. Well, I launch the game and everything looks horrible, no matter how I change the graphic settings. I tried changing the "TextureStreamingEx" in the game files to "Off" like some people suggested, but that just crashes my game during loading. My driver is R9 200 / HD 7900.
< >
Showing 1-15 of 74 comments
HG_WhiskeyJack  [developer] Aug 15, 2017 @ 2:57am 
Hello there,

Thanks for starting a thread on this, I am attempting to gather productive info on this issue :) can you please clarify that the issue looks like this?

https://ibb.co/d3TKEv

You said that your driver is R9 200/ HD 7900, they are seperate cards, can you please tell me which one you are running, and are you on the latest drivers? (If you could check that would be great.

If anyone is experiencing this particular issue on NVidia I would like to know.

Many thanks!
Neksu Aug 15, 2017 @ 3:28am 
Originally posted by HG_WhiskeyJack:
Hello there,

Thanks for starting a thread on this, I am attempting to gather productive info on this issue :) can you please clarify that the issue looks like this?

https://ibb.co/d3TKEv

You said that your driver is R9 200/ HD 7900, they are seperate cards, can you please tell me which one you are running, and are you on the latest drivers? (If you could check that would be great.

If anyone is experiencing this particular issue on NVidia I would like to know.

Many thanks!

I'm running it on R9 200. Yes, the image in question is exactly what it looks like. Any help would be appreciated.
Neksu Aug 15, 2017 @ 3:32am 
And yes, all my drivers are up to date.
HG_WhiskeyJack  [developer] Aug 15, 2017 @ 4:03am 
Ok thank you for the information.

So we have been looking at this issue, I think what is happening is that the AMD driver is causing your PC to fall back on using the Intel on board graphics as opposed to using the card.

This is exactly what the game looks like when running on certain Intel boards, and this is likely what a lot of AMD users are experiencing, and sadly nothing we can do with our game will dictate which GPU your PC uses.

There is regrettably not a setting that is readily available within an AMD driver to force the AMD card to be used as the primary device. We are talking to AMD about this, in the meantime if you are comfortable with your PC and you have a working Graphics Card you can try disabling on board graphics as that may force your machine to use your graphics card.

Many thanks.
fluppi Aug 15, 2017 @ 4:05am 
Turn off the Texture streaming like this:

Open TKGRAPHICSSETTINGS file in your game files

Change TextureStreamingEx value to "Off"

Thats how I got my textures back. The downside of this edit is, my game crashes everytime I want to jump to another star system, so I have to quit the game, change to back to "auto" again, start the game wait 300 years for loading, jump to destination, save and quit, change streaming back to off, start the game, watch another 300 years loading screen, play. I hate it.

Ok started the game today, now I can only play when the texture streaming is on auto, if not I don't get past the loading stream. I should stop giving advises, somehow this breaks my game even more...
Last edited by fluppi; Aug 15, 2017 @ 4:12am
HG_WhiskeyJack  [developer] Aug 15, 2017 @ 4:10am 
Hello, the suggestion made by fluppi does sometimes work.

User' who have been playing since before Pathfinder will have "TextureStreaming" in addition to "TextureStreamingEx", within their TKGRAPHICSSETTINGS file, and so they should change both.

Hopefully this helps, thanks.
Luda Aug 15, 2017 @ 4:13am 
@HG_WhiskeyJack hi im experiening low res textures on all alien species and animals making their skin result in a low res blur, im on nvidia with a gtx 1050ti and have tried reinstalling the game and drivers but to no avail , any help ??
Last edited by Luda; Aug 15, 2017 @ 4:15am
Neksu Aug 15, 2017 @ 4:20am 
Originally posted by fluppi:
Turn off the Texture streaming like this:

Open TKGRAPHICSSETTINGS file in your game files

Change TextureStreamingEx value to "Off"

Thats how I got my textures back. The downside of this edit is, my game crashes everytime I want to jump to another star system, so I have to quit the game, change to back to "auto" again, start the game wait 300 years for loading, jump to destination, save and quit, change streaming back to off, start the game, watch another 300 years loading screen, play. I hate it.
I wish I was at least in that situation. I can't even load the game if I do that.
Verde Aug 15, 2017 @ 4:29am 
"This is exactly what the game looks like when running on certain Intel boards, and this is likely what a lot of AMD users are experiencing, and sadly nothing we can do with our game will dictate which GPU your PC uses."

I'm also experiencing this issue but only since the Pathfinder update, it ran perfectly fine before 1.2 so I don't understand how is it "not possible" for you to fix this. Clearly something was changed during Pathfinder that causes this glitch.
Verde Aug 15, 2017 @ 4:33am 
Originally posted by Neksukka:
I wish I was at least in that situation. I can't even load the game if I do that.

Be sure that your "TexturePageSizeKb" isn't too high as well. When mine was set to 2048 the game crashed at startup with Streaming "Off". Setting it back to 64 or 32 made it launch normally without issues and the textures are fixed. I'm also running the game on Medium settings.
ElKonsolero Aug 15, 2017 @ 5:10am 
It might be worth mentioning that, if you turn texture streaming off, you might also have to reduce texture size/quality, depending on your available vram. Else the game will apparently run out of vram sooner or later and ctd. Setting textures to "Medium" did the trick for me (HD 7950 w. 3gb vram). Game's been launching and running fine since then. Did several warp jumps, landed on different planets etc. No crashes so far.

Careful! If you have/want to change this manually in TKGRAPHICSSETTINGS.MXML, "medium" is called "normal" there (Property name="TextureDetail" value="Normal")!
Last edited by ElKonsolero; Aug 15, 2017 @ 5:15am
Agricola Aug 15, 2017 @ 4:33pm 
I had tried just about everything but still textureless graphics. Next up is to wipe game, uninstall drivers and try again.
tnunley Aug 15, 2017 @ 6:36pm 
Take my advise guys a BAIL on this game if you are having graphics issues and are a AMD card holder. NONE of the "fixes" that are discribed work 100% for everyone. It is just plain poor support from Hello Games.
I got my money back, I would advise you to do the same instead of waiting, and waiting,and waiting for a patch to fix things that may never come.
Very sad indeed. Game had such huge potential but followthrough was a one eyed gimp swatting at gnats.
Jaho Aug 15, 2017 @ 7:04pm 
Originally posted by HG_WhiskeyJack:
Ok thank you for the information.

So we have been looking at this issue, I think what is happening is that the AMD driver is causing your PC to fall back on using the Intel on board graphics as opposed to using the card.

This is exactly what the game looks like when running on certain Intel boards, and this is likely what a lot of AMD users are experiencing, and sadly nothing we can do with our game will dictate which GPU your PC uses.

There is regrettably not a setting that is readily available within an AMD driver to force the AMD card to be used as the primary device. We are talking to AMD about this, in the meantime if you are comfortable with your PC and you have a working Graphics Card you can try disabling on board graphics as that may force your machine to use your graphics card.

Many thanks.
i have this problem with super low res textures to and i have a AMD only system GPU is a R9 280 3GB and CPU is a FX 8320 so no intel stuff that could be used instead of my GPU. the tweak with the texturestreaming works for me but its not optimal.
jdavis1278 Aug 15, 2017 @ 7:06pm 
I'm having the same issue. Radeon R6, ran fine and smooth before the update. Now graphics are VERY low rez/// I've tried everything!!!
< >
Showing 1-15 of 74 comments
Per page: 15 30 50

No Man's Sky > Technical Support > Topic Details
Date Posted: Aug 15, 2017 @ 2:32am
Posts: 74