No Man's Sky

No Man's Sky

View Stats:
No Man's Sky > Technical Support > Topic Details
SteelRonin Aug 14, 2017 @ 7:28am
FPS drop
I have a huge FPS drop after the patch, I don't know what video setting option is causing this. Any idea?

Thanks in advance
< >
Showing 1-14 of 14 comments
DetectiveZit Aug 14, 2017 @ 7:34am 
seems like it is vsync.
i turned it off ingame and turned vsync in my nvidia control panel. no drops now.
SteelRonin Aug 14, 2017 @ 7:50am 
Originally posted by Admiral Schuka:
seems like it is vsync.
i turned it off ingame and turned vsync in my nvidia control panel. no drops now.

going to check it, thanks dude
Wylie28 Aug 14, 2017 @ 8:00am 
900 series or AMD? Both have drivers issues atm but there are solutions. If its not one if the above ill need to know a little more to help.
LordDeimosIV Aug 14, 2017 @ 8:01am 
Posting your pc specs and in-game settings would help.
Last edited by LordDeimosIV; Aug 14, 2017 @ 8:02am
River Aug 14, 2017 @ 8:04am 
same problem
i5 3330, 16GB, RX 480 8GB
Wylie28 Aug 14, 2017 @ 8:19am 
Originally posted by River:
same problem
i5 3330, 16GB, RX 480 8GB

You need to completely grt rid of your drivers using a program, DDU, i think. Then reinstall them. Idk if AMD has some sort f shader caching people are forgetting or what. But fresh drivers fix the problems
BigRowdy Aug 14, 2017 @ 8:21am 
Dopes anyoen search threads before starting the same topic over and over again anymore?
Can you share your system specs?
japp_02 Aug 14, 2017 @ 8:26am 
Try this from the CPU doctor:

If you have Nvidia Experience switch it off
Go check the troubleshooting for Windows 10 + Windows Creators
Disable any card 'enhancer' or 'tweaker' program, go with the game settings
Switch Vsynch off for whatever AA setting you are using
Medium settings will not degrade the grafics visibly, so switch a notch down

Hope it helps,
Last edited by japp_02; Aug 14, 2017 @ 8:26am
HG_WhiskeyJack  [developer] Aug 14, 2017 @ 8:33am 
Hello,

Sorry you are encounting issues.

Without going into how Vsync works, if you have settings that push the limits of your hardware, and this results in spikes in your fps, this can sometimes have horrible consequences with vsync.

I would recommend either lowering your graphics settings or disabling vsync both in game and in your driver settings (as recommended above).

But also please remember that you have a universe to explore :) as a result of that our engine and tech is very different to that of other games and so the graphics settings will differ when compared to other games. So if you are having issues with frame rate the first course of action is to try lowering your graphics settings and see if that helps.

Many thanks all, enjoy Atlas Rises.
Last edited by HG_WhiskeyJack; Aug 14, 2017 @ 8:33am
SteelRonin Aug 14, 2017 @ 8:39am 
I have:
I7-4970k
16 GB ram
GTX 970

I used to play this game at 60 fps without problems. Now I have 30 max in some planets. I will still try to find the best settings, I don't want to play a game with a nintendo 64 graphics after playing it without issues.
General Tso Aug 14, 2017 @ 8:47am 
I don't think it's just vsync, I think there's some issues with the update causing decreased performance relative to the previous version, which in turn is causing larger framerate drops via vsync.

Vsync as implemented in this game will drop the framerate to half your refresh rate if the game can't reach fps equal to your refresh rate. So for example if on 1.24 you were getting 60+ fps (like I was), with vsync on you'd still be getting a solid 60 fps performance. If 1.3 drops your avg fps to say 55 fps, suddenly you're seeing hard framerate drops to 30 fps and below due to vsync. Turning off vsync will unlock your framerate from refresh rate and you'll be up to 55 fps, and the problem will appear solved. But you haven't actually fixed the problem, which is that 1.3 is causing reduced performance on a lot of people's systems independent of vsync (on some people's systems way lower than my 55 fps example).

This is also why I suspect people are e reporting the problem solved by using adaptive vsync via the Nvidia control panel for example.

In short if you were able to run smoothly with in-game vsync prior to 1.3, you should still be able too, but can't not because anything to do with vsync but because of a significant reduction in performance relative to 1.24. Messing with vsync is a bandaid fix, not a solution. At least that's my suspicion.

I'm running on a gtx970, i7 3.4ghz, 8g ram and win7 and without vsync, at any in game settings, my avg fps have dropped around 40% with this update.
Wylie28 Aug 14, 2017 @ 9:05am 
Originally posted by SteelRonin:
I have:
I7-4970k
16 GB ram
GTX 970

I used to play this game at 60 fps without problems. Now I have 30 max in some planets. I will still try to find the best settings, I don't want to play a game with a nintendo 64 graphics after playing it without issues.

Easy fix for you. Just go to the next set of Beta drivers. The current 900 series ones are a bit screwed up atm. Im seeing problems reported across most of my games.
Wylie28 Aug 14, 2017 @ 9:06am 
Originally posted by General Tso:
I don't think it's just vsync, I think there's some issues with the update causing decreased performance relative to the previous version, which in turn is causing larger framerate drops via vsync.

Vsync as implemented in this game will drop the framerate to half your refresh rate if the game can't reach fps equal to your refresh rate. So for example if on 1.24 you were getting 60+ fps (like I was), with vsync on you'd still be getting a solid 60 fps performance. If 1.3 drops your avg fps to say 55 fps, suddenly you're seeing hard framerate drops to 30 fps and below due to vsync. Turning off vsync will unlock your framerate from refresh rate and you'll be up to 55 fps, and the problem will appear solved. But you haven't actually fixed the problem, which is that 1.3 is causing reduced performance on a lot of people's systems independent of vsync (on some people's systems way lower than my 55 fps example).

This is also why I suspect people are e reporting the problem solved by using adaptive vsync via the Nvidia control panel for example.

In short if you were able to run smoothly with in-game vsync prior to 1.3, you should still be able too, but can't not because anything to do with vsync but because of a significant reduction in performance relative to 1.24. Messing with vsync is a bandaid fix, not a solution. At least that's my suspicion.

I'm running on a gtx970, i7 3.4ghz, 8g ram and win7 and without vsync, at any in game settings, my avg fps have dropped around 40% with this update.

easy fix for you too. Just go to the next set of Beta drivers. The current 900 series ones are a bit screwed up atm. Im seeing problems reported across most of my games.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

No Man's Sky > Technical Support > Topic Details
Date Posted: Aug 14, 2017 @ 7:28am
Posts: 14